]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-link.patch
- updated to 14.3
[packages/postgresql.git] / postgresql-link.patch
index 1e89ba17f66faf5c6d306a708011a8a6c47c2367..cf79e14a979f67c9d38426f20c590f677639e9c6 100644 (file)
@@ -1,31 +1,40 @@
---- postgresql-9.5.0/configure.in.orig 2016-01-14 18:59:41.640973653 +0100
-+++ postgresql-9.5.0/configure.in      2016-01-14 21:10:21.783977990 +0100
-@@ -1192,7 +1192,9 @@
+diff -ur postgresql-14.0.orig/configure.ac postgresql-14.0/configure.ac
+--- postgresql-14.0.orig/configure.ac  2021-11-01 14:52:54.420842615 +0100
++++ postgresql-14.0/configure.ac       2021-11-01 14:53:49.104982037 +0100
+@@ -1494,6 +1494,7 @@
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
 +  AC_CHECK_LIB(dns_sd, DNSServiceRegister, [BONJOUR_LIBS=-ldns_sd])
+ dnl At some point we might add something like
+ dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
+ dnl but right now, what that would mainly accomplish is to encourage
+@@ -1501,6 +1502,7 @@
+ dnl If you want to use Apple's own Bonjour code on another platform,
+ dnl just add -ldns_sd to LIBS manually.
  fi
 +AC_SUBST([BONJOUR_LIBS])
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
-@@ -54,7 +54,7 @@
+diff -ur postgresql-14.0.orig/src/backend/Makefile postgresql-14.0/src/backend/Makefile
+--- postgresql-14.0.orig/src/backend/Makefile  2021-11-01 14:52:54.349842434 +0100
++++ postgresql-14.0/src/backend/Makefile       2021-11-01 14:53:49.105982039 +0100
+@@ -63,7 +63,7 @@
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
--      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) -o $@
-+      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) $(BONJOUR_LIBS) -o $@
+-      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) $(BONJOUR_LIBS) -o $@
  
  endif
  endif
---- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
-@@ -216,6 +216,7 @@
- PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
- PTHREAD_LIBS          = @PTHREAD_LIBS@
+diff -ur postgresql-14.0.orig/src/Makefile.global.in postgresql-14.0/src/Makefile.global.in
+--- postgresql-14.0.orig/src/Makefile.global.in        2021-11-01 14:52:54.297842301 +0100
++++ postgresql-14.0/src/Makefile.global.in     2021-11-01 14:53:49.105982039 +0100
+@@ -172,6 +172,7 @@
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
  
 +BONJOUR_LIBS            = @BONJOUR_LIBS@