]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-ossp_uuid.patch
- versioned package, 9.3.24
[packages/postgresql.git] / postgresql-ossp_uuid.patch
index b5b2dfa5477626b92c86e6d606cdc48d7eb655ca..08c5a0c8e3ba323c57edec913c8f02bfe5a1e28a 100644 (file)
@@ -1,34 +1,29 @@
---- postgresql-9.4.0/configure.in.orig 2015-01-05 23:55:32.000000000 +0100
-+++ postgresql-9.4.0/configure.in      2015-01-06 00:03:58.433386714 +0100
-@@ -1166,13 +1166,13 @@
-         [AC_MSG_ERROR([header file <uuid.h> does not match E2FS UUID library])])],
-       [AC_MSG_ERROR([header file <uuid/uuid.h> or <uuid.h> is required for E2FS UUID])])])
- elif test "$with_uuid" = ossp ; then
--  AC_CHECK_HEADERS(ossp/uuid.h,
--    [AC_EGREP_HEADER([uuid_export], ossp/uuid.h, [],
--      [AC_MSG_ERROR([header file <ossp/uuid.h> does not match OSSP UUID library])])],
-+  AC_CHECK_HEADERS(ossp-uuid/uuid.h,
-+    [AC_EGREP_HEADER([uuid_export], ossp-uuid/uuid.h, [],
-+      [AC_MSG_ERROR([header file <ossp-uuid/uuid.h> does not match OSSP UUID library])])],
-     [AC_CHECK_HEADERS(uuid.h,
-       [AC_EGREP_HEADER([uuid_export], uuid.h, [],
-         [AC_MSG_ERROR([header file <uuid.h> does not match OSSP UUID library])])],
--      [AC_MSG_ERROR([header file <ossp/uuid.h> or <uuid.h> is required for OSSP UUID])])])
-+      [AC_MSG_ERROR([header file <ossp-uuid/uuid.h> or <uuid.h> is required for OSSP UUID])])])
+diff -urpa postgresql-9.3.24.orig/configure.in postgresql-9.3.24/configure.in
+--- postgresql-9.3.24.orig/configure.in        2018-08-23 19:56:17.313401333 +0000
++++ postgresql-9.3.24/configure.in     2018-08-23 20:17:36.902386926 +0000
+@@ -1167,9 +1167,9 @@ fi
+ # for contrib/uuid-ossp
+ if test "$with_ossp_uuid" = yes ; then
+-  AC_CHECK_HEADERS(ossp/uuid.h, [], [
++  AC_CHECK_HEADERS(ossp-uuid/uuid.h, [], [
+     AC_CHECK_HEADERS(uuid.h, [],
+-      [AC_MSG_ERROR([header file <ossp/uuid.h> or <uuid.h> is required for OSSP-UUID])])])
++      [AC_MSG_ERROR([header file <ossp-uuid/uuid.h> or <uuid.h> is required for OSSP-UUID])])])
  fi
  
  if test "$PORTNAME" = "win32" ; then
---- postgresql-9.4.1/contrib/uuid-ossp/uuid-ossp.c.org 2015-03-23 10:41:24.000000000 +0100
-+++ postgresql-9.4.1/contrib/uuid-ossp/uuid-ossp.c     2015-03-23 10:54:29.403373571 +0100
-@@ -29,8 +29,8 @@
- #ifdef HAVE_UUID_H
- #include <uuid.h>
- #endif
+diff -urpa postgresql-9.3.24.orig/contrib/uuid-ossp/uuid-ossp.c postgresql-9.3.24/contrib/uuid-ossp/uuid-ossp.c
+--- postgresql-9.3.24.orig/contrib/uuid-ossp/uuid-ossp.c       2018-08-23 19:56:17.179401335 +0000
++++ postgresql-9.3.24/contrib/uuid-ossp/uuid-ossp.c    2018-08-23 21:18:08.165346042 +0000
+@@ -20,8 +20,8 @@
+  * install ossp-uuid from a tarball, it's installed as uuid.h. Don't know
+  * what other systems do.
+  */
 -#ifdef HAVE_OSSP_UUID_H
 -#include <ossp/uuid.h>
 +#ifdef HAVE_OSSP_UUID_UUID_H
 +#include <ossp-uuid/uuid.h>
- #endif
- #ifdef HAVE_UUID_UUID_H
- #include <uuid/uuid.h>
-
+ #else
+ #ifdef HAVE_UUID_H
+ #include <uuid.h>