]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql.spec
- updated to 16.2
[packages/postgresql.git] / postgresql.spec
index 2f8430b2401ee7c00c7033a0d3352cad5f45c727..eb0ed812839b5b099877ad344636bc785eff76a6 100644 (file)
@@ -2,7 +2,7 @@
 # Conditional build:
 %bcond_without tests                   # disable testing
 %bcond_without tcl                     # disable Tcl support
-%bcond_without kerberos5               # disable kerberos5 support
+%bcond_with    kerberos5               # disable kerberos5 support
 %bcond_without perl                    # disable Perl support
 %bcond_without python                  # disable Python support
 %bcond_with    bonjour                 # Bonjour/DNS_SD support
@@ -14,8 +14,8 @@
 #
 
 %define beta %{nil}
-%define pgsqlversion 14
-%define pgsqlpriority 140
+%define pgsqlversion 16
+%define pgsqlpriority 160
 
 Summary:       PostgreSQL Data Base Management System
 Summary(de.UTF-8):     PostgreSQL Datenbankverwaltungssystem
@@ -29,11 +29,11 @@ Summary(uk.UTF-8):  PostgreSQL - система керування базами 
 Summary(zh_CN.UTF-8):  PostgreSQL 客户端程序和库文件
 Name:          postgresql-%{pgsqlversion}
 Version:       %{pgsqlversion}.2
-Release:       2
+Release:       1
 License:       BSD
 Group:         Applications/Databases
 Source0:       http://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
-# Source0-md5: aae1ede6de233e2d44437d66bc1cd3b8
+# Source0-md5: 3d19d93434666db5d33e692472915ae5
 Source1:       postgresql.init
 Source2:       pgsql-Database-HOWTO-html.tar.gz
 # Source2-md5: 5b656ddf1db41965761f85204a14398e
@@ -110,7 +110,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # omitted contribs:
 # spi, test_decoding, worker_spi - examples/tests
 # tsearch2 - old module for compatibility only
-%define        contrib_modules adminpack amcheck auth_delay auto_explain bloom %{?with_perl:bool_plperl} btree_gin btree_gist citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn %{?with_perl:jsonb_plperl} %{?with_python:jsonb_plpython} lo ltree %{?with_python:ltree_plpython} oid2name old_snapshot pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_stat_statements pg_surgery pg_trgm pg_visibility pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} spi sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
+%define        contrib_modules adminpack amcheck auth_delay auto_explain basebackup_to_shell basic_archive bloom %{?with_perl:bool_plperl} btree_gin btree_gist citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn %{?with_perl:jsonb_plperl} %{?with_python:jsonb_plpython} lo ltree %{?with_python:ltree_plpython} oid2name old_snapshot pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_stat_statements pg_surgery pg_trgm pg_visibility pg_walinspect pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} spi sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
 
 %description
 PostgreSQL Data Base Management System (formerly known as Postgres,
@@ -406,7 +406,7 @@ Summary:    PL/Python - PostgreSQL procedural language
 Summary(pl.UTF-8):     PL/Python - język proceduralny bazy danych PostgreSQL
 Group:         Applications/Databases
 Requires:      %{name} = %{version}-%{release}
-%pyrequires_eq python
+%pyrequires_eq python3
 Obsoletes:     postgresql-module-plpython
 
 %description module-plpython
@@ -881,7 +881,6 @@ fi
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_waldump
 %attr(755,root,root) %{pgsqllibdir}/bin/pgbench
 %attr(755,root,root) %{pgsqllibdir}/bin/postgres
-%attr(755,root,root) %{pgsqllibdir}/bin/postmaster
 
 %attr(755,root,root) %{moduledir}/cyrillic_and_mic.so
 %attr(755,root,root) %{moduledir}/dict_int.so
@@ -925,7 +924,6 @@ fi
 %{pgsqldatadir}/man/man1/pg_upgrade.1*
 %{pgsqldatadir}/man/man1/pgbench.1*
 %{pgsqldatadir}/man/man1/postgres.1*
-%{pgsqldatadir}/man/man1/postmaster.1*
 
 %files -n postgresql-common
 %defattr(644,root,root,755)
@@ -1002,6 +1000,7 @@ fi
 %{_includedir}/postgres_ext.h
 %dir %{_includedir}/postgresql/internal
 %{_includedir}/postgresql/internal/c.h
+%{_includedir}/postgresql/internal/fe-auth-sasl.h
 %{_includedir}/postgresql/internal/libpq-int.h
 %{_includedir}/postgresql/internal/port.h
 %{_includedir}/postgresql/internal/postgres_fe.h
@@ -1141,6 +1140,8 @@ fi
 %attr(755,root,root) %{moduledir}/auth_delay.so
 %attr(755,root,root) %{moduledir}/auto_explain.so
 %attr(755,root,root) %{moduledir}/autoinc.so
+%attr(755,root,root) %{moduledir}/basebackup_to_shell.so
+%attr(755,root,root) %{moduledir}/basic_archive.so
 %attr(755,root,root) %{moduledir}/bloom.so
 %attr(755,root,root) %{moduledir}/btree_gin.so
 %attr(755,root,root) %{moduledir}/btree_gist.so
@@ -1163,6 +1164,7 @@ fi
 %attr(755,root,root) %{moduledir}/pg_stat_statements.so
 %attr(755,root,root) %{moduledir}/pg_surgery.so
 %attr(755,root,root) %{moduledir}/pg_visibility.so
+%attr(755,root,root) %{moduledir}/pg_walinspect.so
 %attr(755,root,root) %{moduledir}/pgrowlocks.so
 %attr(755,root,root) %{moduledir}/pgstattuple.so
 %attr(755,root,root) %{moduledir}/postgres_fdw.so
@@ -1230,6 +1232,8 @@ fi
 %{extensiondir}/pg_surgery.control
 %{extensiondir}/pg_visibility--*.sql
 %{extensiondir}/pg_visibility.control
+%{extensiondir}/pg_walinspect--*.sql
+%{extensiondir}/pg_walinspect.control
 %{extensiondir}/pgrowlocks--*.sql
 %{extensiondir}/pgrowlocks.control
 %{extensiondir}/pgstattuple--*.sql
@@ -1273,22 +1277,10 @@ fi
 %attr(755,root,root) %{moduledir}/hstore_plpython3.so
 %attr(755,root,root) %{moduledir}/jsonb_plpython3.so
 %attr(755,root,root) %{moduledir}/ltree_plpython3.so
-%{extensiondir}/hstore_plpythonu--*.sql
-%{extensiondir}/hstore_plpythonu.control
-%{extensiondir}/hstore_plpython2u--*.sql
-%{extensiondir}/hstore_plpython2u.control
 %{extensiondir}/hstore_plpython3u--*.sql
 %{extensiondir}/hstore_plpython3u.control
-%{extensiondir}/jsonb_plpythonu--*.sql
-%{extensiondir}/jsonb_plpythonu.control
-%{extensiondir}/jsonb_plpython2u--*.sql
-%{extensiondir}/jsonb_plpython2u.control
 %{extensiondir}/jsonb_plpython3u--*.sql
 %{extensiondir}/jsonb_plpython3u.control
-%{extensiondir}/ltree_plpythonu--*.sql
-%{extensiondir}/ltree_plpythonu.control
-%{extensiondir}/ltree_plpython2u--*.sql
-%{extensiondir}/ltree_plpython2u.control
 %{extensiondir}/ltree_plpython3u--*.sql
 %{extensiondir}/ltree_plpython3u.control
 %endif