]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql.spec
- updated to 11.0
[packages/postgresql.git] / postgresql.spec
index 5163b5e110ea4b46b4a632342330b467ee3f9991..3107fa035ecf2bf2599ca5a2a48d868fbc3bed90 100644 (file)
@@ -14,8 +14,8 @@
 #
 
 %define beta %{nil}
-%define pgsqlversion 10
-%define pgsqlpriority 100
+%define pgsqlversion 11
+%define pgsqlpriority 110
 
 Summary:       PostgreSQL Data Base Management System
 Summary(de.UTF-8):     PostgreSQL Datenbankverwaltungssystem
@@ -28,12 +28,12 @@ Summary(tr.UTF-8):  Veri Tabanı Yönetim Sistemi
 Summary(uk.UTF-8):     PostgreSQL - система керування базами даних
 Summary(zh_CN.UTF-8):  PostgreSQL 客户端程序和库文件
 Name:          postgresql-%{pgsqlversion}
-Version:       %{pgsqlversion}.5
-Release:       2
+Version:       %{pgsqlversion}.0
+Release:       1
 License:       BSD
 Group:         Applications/Databases
 Source0:       http://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
-# Source0-md5: a5fe5fdff2d6c28f65601398be0950df
+# Source0-md5: 338ede84c0443db02ff6e8c4c8cbc5e9
 Source1:       postgresql.init
 Source2:       pgsql-Database-HOWTO-html.tar.gz
 # Source2-md5: 5b656ddf1db41965761f85204a14398e
@@ -108,7 +108,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # omitted contribs:
 # spi, test_decoding, worker_spi - examples/tests
 # tsearch2 - old module for compatibility only
-%define        contrib_modules adminpack auth_delay auto_explain bloom btree_gin btree_gist chkpass citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn lo ltree %{?with_python:ltree_plpython} oid2name pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_standby pg_stat_statements pg_trgm pg_visibility pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
+%define        contrib_modules adminpack auth_delay auto_explain bloom btree_gin btree_gist citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn lo ltree %{?with_python:ltree_plpython} oid2name pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_standby pg_stat_statements pg_trgm pg_visibility pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
 
 %description
 PostgreSQL Data Base Management System (formerly known as Postgres,
@@ -189,6 +189,7 @@ PostgreSQL - wspólne pliki i katalogi.
 Summary:       Common directories for PostgresSQL %{pgsqlversion}
 Summary(pl.UTF-8):     Wspólne pliki i katalogi dla PostgreSQL %{pgsqlversion}
 Group:         Applicataion/Databases
+Requires:      postgresql-common >= %{version}-%{release}
 
 %description dirs
 Common directories for PostgresSQL %{pgsqlversion}
@@ -659,7 +660,7 @@ done
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
-       $RPM_BUILD_ROOT/var/{lib/pgsql,log,run/postgresql} \
+       $RPM_BUILD_ROOT/var/{lib/postgresql/%{pgsqlversion},log,run/postgresql} \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
        $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
 
@@ -759,14 +760,14 @@ fi
 
 %triggerpostun -- postgresql < 10.5-2
 if [ -n "`/bin/id -u postgres 2>/dev/null`" ]; then
-       /usr/sbin/usermod -d /var/lib/pgsql postgres
+       /usr/sbin/usermod -d /var/lib/postgresql postgres
 fi
 echo
 echo "This version of PostgreSQL uses new default location for database clusters."
 echo "Please move your existing clusters before starting PostgreSQL so they follow"
 echo "below scheme:"
 echo
-echo "/var/lib/pgsql/<version>/<name>"
+echo "/var/lib/postgresql/<version>/<name>"
 echo
 echo "where <version> means PostgreSQL version like 9.6 or 10 and name is cluster"
 echo "name of your choice. When done, be sure to update /etc/sysconfig/postgresql*"
@@ -785,7 +786,7 @@ fi
 
 %pre   -n postgresql-common
 %groupadd -g 88 -r postgres
-%useradd -M -o -r -u 88 -d /var/lib/pgsql -s /bin/sh -g postgres -c "PostgreSQL Server" postgres
+%useradd -M -o -r -u 88 -d /var/lib/postgresql -s /bin/sh -g postgres -c "PostgreSQL Server" postgres
 
 %posttrans     clients
 update-alternatives \
@@ -871,6 +872,7 @@ fi
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_test_fsync
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_test_timing
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_upgrade
+%attr(755,root,root) %{pgsqllibdir}/bin/pg_verify_checksums
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_waldump
 %attr(755,root,root) %{pgsqllibdir}/bin/pgbench
 %attr(755,root,root) %{pgsqllibdir}/bin/postgres
@@ -918,6 +920,7 @@ fi
 %{pgsqldatadir}/man/man1/pg_test_fsync.1*
 %{pgsqldatadir}/man/man1/pg_test_timing.1*
 %{pgsqldatadir}/man/man1/pg_upgrade.1*
+%{pgsqldatadir}/man/man1/pg_verify_checksums.1*
 %{pgsqldatadir}/man/man1/pgbench.1*
 %{pgsqldatadir}/man/man1/postgres.1*
 %{pgsqldatadir}/man/man1/postmaster.1*
@@ -926,7 +929,7 @@ fi
 %defattr(644,root,root,755)
 %dir %{_libdir}/postgresql
 %dir %{_datadir}/postgresql
-%attr(700,postgres,postgres) %dir /var/lib/pgsql
+%attr(700,postgres,postgres) %dir /var/lib/postgresql
 %attr(700,postgres,postgres) %dir /var/run/postgresql
 
 %files dirs
@@ -939,6 +942,7 @@ fi
 %dir %{pgsqldatadir}/man/man1
 %dir %{pgsqldatadir}/man/man3
 %dir %{pgsqldatadir}/man/man7
+%attr(700,postgres,postgres) %dir /var/lib/postgresql/%{pgsqlversion}
 
 %files doc
 %defattr(644,root,root,755)
@@ -1132,7 +1136,6 @@ fi
 %attr(755,root,root) %{moduledir}/bloom.so
 %attr(755,root,root) %{moduledir}/btree_gin.so
 %attr(755,root,root) %{moduledir}/btree_gist.so
-%attr(755,root,root) %{moduledir}/chkpass.so
 %attr(755,root,root) %{moduledir}/citext.so
 %attr(755,root,root) %{moduledir}/cube.so
 %attr(755,root,root) %{moduledir}/earthdistance.so
@@ -1166,8 +1169,6 @@ fi
 %{extensiondir}/btree_gin.control
 %{extensiondir}/btree_gist--*.sql
 %{extensiondir}/btree_gist.control
-%{extensiondir}/chkpass--*.sql
-%{extensiondir}/chkpass.control
 %{extensiondir}/citext--*.sql
 %{extensiondir}/citext.control
 %{extensiondir}/cube--*.sql