]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql.spec
- libpgport patch from debian
[packages/postgresql.git] / postgresql.spec
index 3306e812f93e585620d27a5703beb2c64e035a97..b5d0463a16d721024986b2057674aefcb35af837 100644 (file)
@@ -45,6 +45,7 @@ Patch3:               per-version-dirs.patch
 Patch4:                postgresql-disable_horology_test.patch
 Patch5:                postgresql-heimdal.patch
 Patch6:                postgresql-link.patch
+Patch7:                libpgport-pkglibdir.patch
 URL:           http://www.postgresql.org/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
@@ -552,6 +553,7 @@ Różne moduły dołączone do PostgreSQL-a.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 # force rebuild of bison/flex files
 find src -name \*.l -o -name \*.y | xargs touch
@@ -784,6 +786,15 @@ if [ $1 -eq 0 ]; then
        update-alternatives --remove vacuumdb %{pgsqllibdir}/bin/vacuumdb || :
 fi
 
+%post  -n postgresql-devel
+update-alternatives \
+       --install %{_bindir}/pg_config pg_config %{pgsqllibdir}/bin/pg_config %{pgver}%{pgminver} \
+       --slave %{_mandir}/man1/pg_config.1 pg_config.1 %{pgsqldatadir}/man/man1/pg_config.1* || :
+
+%postun        -n postgresql-devel
+       update-alternatives --remove pg_config %{pgsqllibdir}/bin/pg_config || :
+
+
 %post  -n postgresql-libs -p /sbin/ldconfig
 %postun        -n postgresql-libs -p /sbin/ldconfig
 
@@ -935,9 +946,9 @@ fi
 %files -n postgresql-static
 %defattr(644,root,root,755)
 %{_libdir}/libpq.a
-%{_libdir}/libpgcommon.a
-%{_libdir}/libpgfeutils.a
-%{_libdir}/libpgport.a
+%{pgsqllibdir}/lib/libpgcommon.a
+%{pgsqllibdir}/lib/libpgfeutils.a
+%{pgsqllibdir}/lib/libpgport.a
 
 %files clients -f clients.lang
 %defattr(644,root,root,755)