]> TLD Linux GIT Repositories - packages/postgresql.git/commitdiff
- updated to 14.0
authorMarcin Krol <hawk@tld-linux.org>
Mon, 1 Nov 2021 14:43:42 +0000 (15:43 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 1 Nov 2021 14:43:42 +0000 (15:43 +0100)
per-version-dirs.patch
postgresql-absolute_dbpaths.patch
postgresql-conf.patch
postgresql-heimdal.patch
postgresql-link.patch
postgresql-tests.patch
postgresql.spec
socket-dir-fixes.patch

index 46e8c453b4fdf1abb8a1a6d1e68618e464a69aa5..dbf4cf86137097a3e59a53b3c6cd6d8f7320a1ba 100644 (file)
@@ -1,35 +1,16 @@
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -120,7 +120,7 @@ libdir := @libdir@
- pkglibdir = $(libdir)
- ifeq "$(findstring pgsql, $(pkglibdir))" ""
- ifeq "$(findstring postgres, $(pkglibdir))" ""
--override pkglibdir := $(pkglibdir)/postgresql
-+override pkglibdir := $(pkglibdir)/postgresql/@PG_MAJORVERSION@/lib
- endif
- endif
-@@ -168,7 +168,7 @@ endif # PGXS
- # These derived path variables aren't separately configurable.
--includedir_server = $(pkgincludedir)/server
-+includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
- includedir_internal = $(pkgincludedir)/internal
- pgxsdir = $(pkglibdir)/pgxs
---- a/src/bin/pg_config/pg_config.c
-+++ b/src/bin/pg_config/pg_config.c
+diff -ur postgresql-14.0.orig/src/bin/pg_config/pg_config.c postgresql-14.0/src/bin/pg_config/pg_config.c
+--- postgresql-14.0.orig/src/bin/pg_config/pg_config.c 2021-11-01 14:48:22.654149731 +0100
++++ postgresql-14.0/src/bin/pg_config/pg_config.c      2021-11-01 14:49:14.747282545 +0100
 @@ -27,6 +27,8 @@
- #include "port.h"
  #include "common/config_info.h"
+ #include "port.h"
  
 +#include "../port/pg_config_paths.h"
 +
  static const char *progname;
  
  /*
-@@ -148,11 +150,7 @@ main(int argc, char **argv)
+@@ -149,11 +151,7 @@
                }
        }
  
  
        configdata = get_configdata(my_exec_path, &configdata_len);
        /* no arguments -> print everything */
+diff -ur postgresql-14.0.orig/src/Makefile.global.in postgresql-14.0/src/Makefile.global.in
+--- postgresql-14.0.orig/src/Makefile.global.in        2021-11-01 14:48:22.456149226 +0100
++++ postgresql-14.0/src/Makefile.global.in     2021-11-01 14:49:14.747282545 +0100
+@@ -119,7 +119,7 @@
+ pkglibdir = $(libdir)
+ ifeq "$(findstring pgsql, $(pkglibdir))" ""
+ ifeq "$(findstring postgres, $(pkglibdir))" ""
+-override pkglibdir := $(pkglibdir)/postgresql
++override pkglibdir := $(pkglibdir)/postgresql/@PG_MAJORVERSION@/lib
+ endif
+ endif
+@@ -167,7 +167,7 @@
+ # These derived path variables aren't separately configurable.
+-includedir_server = $(pkgincludedir)/server
++includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
+ includedir_internal = $(pkgincludedir)/internal
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
index 820b65fc9b3648c3f4ede3d649c5ee372aa8ac3d..9e06dbaab2aacd1a0096158a68be88ec7d18bf95 100644 (file)
@@ -1,5 +1,5 @@
---- postgresql-7.3.1/configure.in-orig Thu Jan 16 19:53:28 2003
-+++ postgresql-7.3.1/configure.in      Thu Jan 16 19:54:20 2003
+--- postgresql-7.3.1/configure.ac-orig Thu Jan 16 19:53:28 2003
++++ postgresql-7.3.1/configure.ac      Thu Jan 16 19:54:20 2003
 @@ -539,7 +539,7 @@
  
  
index 396bebe82e88c078d6f7467df4121d48ede10edf..ebedf2df4e5ef623d160aa7d354a0f40e761be19 100644 (file)
@@ -1,6 +1,6 @@
---- postgresql-13.1/src/backend/utils/misc/postgresql.conf.sample      2020-11-09 23:24:30.000000000 +0100
-+++ postgresql-13.1/src/backend/utils/misc/postgresql.conf.sample      2020-12-03 20:55:41.832778786 +0100
-@@ -422,23 +422,23 @@
+--- postgresql-14.0/src/backend/utils/misc/postgresql.conf.sample      2021-11-01 12:40:10.778965880 +0100
++++ postgresql-14.0/src/backend/utils/misc/postgresql.conf.sample      2021-11-01 14:01:02.459020587 +0100
+@@ -430,27 +430,27 @@
  
  # - Where to Log -
  
 +log_directory = '/var/log/postgresql' # directory where log files are written,
                                        # can be absolute or relative to PGDATA
 -#log_filename = 'postgresql-%Y-%m-%d_%H%M%S.log'      # log file name pattern,
-+log_filename = 'postgresql-13.log'    # log file name pattern,
++log_filename = 'postgresql-14.log'    # log file name pattern,
                                        # can include strftime() escapes
 -#log_file_mode = 0600                 # creation mode for log files,
 +log_file_mode = 0640                  # creation mode for log files,
                                        # begin with 0 to use octal notation
- #log_truncate_on_rotation = off               # If on, an existing log file with the
-                                       # same name as the new log file will be
-@@ -448,16 +448,16 @@
-                                       # or size-driven rotation.  Default is
-                                       # off, meaning append to existing files
-                                       # in all cases.
 -#log_rotation_age = 1d                        # Automatic rotation of logfiles will
 +log_rotation_age = 0                  # Automatic rotation of logfiles will
                                        # happen after that time.  0 disables.
 +log_rotation_size = 0                 # Automatic rotation of logfiles will
                                        # happen after that much log output.
                                        # 0 disables.
+ #log_truncate_on_rotation = off               # If on, an existing log file with the
+@@ -463,9 +463,9 @@
+                                       # in all cases.
  
  # These are relevant when logging to syslog:
 -#syslog_facility = 'LOCAL0'
 -#syslog_ident = 'postgres'
 -#syslog_sequence_numbers = on
 +syslog_facility = 'LOCAL0'
-+syslog_ident = 'postgresql-13'
++syslog_ident = 'postgresql-14'
 +syslog_sequence_numbers = on
  #syslog_split_messages = on
  
- # This is only relevant when logging to eventlog (win32):
-@@ -521,12 +521,12 @@
- #debug_print_plan = off
- #debug_pretty_print = on
+ # This is only relevant when logging to eventlog (Windows):
+@@ -534,12 +534,12 @@
+                                       # actions running at least this number
+                                       # of milliseconds.
  #log_checkpoints = off
 -#log_connections = off
 -#log_disconnections = off
index d4317c9e517d21fd950ba7523ab9c97adc0c62ea..c88045c49fa0f83f34b0471dab73750748ff8aac 100644 (file)
@@ -1,6 +1,7 @@
---- postgresql-9.4.0/configure.in~     2014-12-16 02:07:34.000000000 +0100
-+++ postgresql-9.4.0/configure.in      2014-12-24 13:10:18.706719940 +0100
-@@ -946,7 +946,7 @@
+diff -ur postgresql-14.0.orig/configure.ac postgresql-14.0/configure.ac
+--- postgresql-14.0.orig/configure.ac  2021-11-01 14:51:09.840575983 +0100
++++ postgresql-14.0/configure.ac       2021-11-01 14:52:27.718774543 +0100
+@@ -1217,7 +1217,7 @@
  
  if test "$with_gssapi" = yes ; then
    if test "$PORTNAME" != "win32"; then
index 84694890983041518a5ecb4dfe80fb49ee5b443e..cf79e14a979f67c9d38426f20c590f677639e9c6 100644 (file)
@@ -1,6 +1,7 @@
---- postgresql-9.5.0/configure.in.orig   2018-02-21 03:23:25.335399998 +0100
-+++ postgresql-9.5.0/configure.in        2018-02-21 03:28:24.392066743 +0100
-@@ -1203,6 +1203,7 @@
+diff -ur postgresql-14.0.orig/configure.ac postgresql-14.0/configure.ac
+--- postgresql-14.0.orig/configure.ac  2021-11-01 14:52:54.420842615 +0100
++++ postgresql-14.0/configure.ac       2021-11-01 14:53:49.104982037 +0100
+@@ -1494,6 +1494,7 @@
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
@@ -8,7 +9,7 @@
  dnl At some point we might add something like
  dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
  dnl but right now, what that would mainly accomplish is to encourage
-@@ -1210,6 +1211,7 @@
+@@ -1501,6 +1502,7 @@
  dnl If you want to use Apple's own Bonjour code on another platform,
  dnl just add -ldns_sd to LIBS manually.
  fi
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
-@@ -60,7 +60,7 @@
+diff -ur postgresql-14.0.orig/src/backend/Makefile postgresql-14.0/src/backend/Makefile
+--- postgresql-14.0.orig/src/backend/Makefile  2021-11-01 14:52:54.349842434 +0100
++++ postgresql-14.0/src/backend/Makefile       2021-11-01 14:53:49.105982039 +0100
+@@ -63,7 +63,7 @@
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
  
  endif
  endif
---- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
-@@ -216,6 +216,7 @@
- PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
- PTHREAD_LIBS          = @PTHREAD_LIBS@
+diff -ur postgresql-14.0.orig/src/Makefile.global.in postgresql-14.0/src/Makefile.global.in
+--- postgresql-14.0.orig/src/Makefile.global.in        2021-11-01 14:52:54.297842301 +0100
++++ postgresql-14.0/src/Makefile.global.in     2021-11-01 14:53:49.105982039 +0100
+@@ -172,6 +172,7 @@
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
  
 +BONJOUR_LIBS            = @BONJOUR_LIBS@
  
index f93142406dc546f7e4417e901adba49d80da83a4..95942ecddef476071fa71812f4171423707277e5 100644 (file)
@@ -1,6 +1,7 @@
---- ./src/test/regress/pg_regress.c.orig       2020-08-10 23:15:53.000000000 +0200
-+++ ./src/test/regress/pg_regress.c    2020-08-16 15:50:06.439293508 +0200
-@@ -2408,6 +2408,7 @@
+diff -ur postgresql-14.0.orig/src/test/regress/pg_regress.c postgresql-14.0/src/test/regress/pg_regress.c
+--- postgresql-14.0.orig/src/test/regress/pg_regress.c 2021-11-01 14:50:12.561429947 +0100
++++ postgresql-14.0/src/test/regress/pg_regress.c      2021-11-01 14:50:27.681468493 +0100
+@@ -2482,6 +2482,7 @@
                header(_("starting postmaster"));
                snprintf(buf, sizeof(buf),
                                 "\"%s%spostgres\" -D \"%s/data\" -F%s "
index d9b73c6012e475fdda1bec6e2b7357f4d0785e11..d535a5a2a422620cf0b6ab9015dcc4f42afd64d0 100644 (file)
@@ -14,8 +14,8 @@
 #
 
 %define beta %{nil}
-%define pgsqlversion 13
-%define pgsqlpriority 130
+%define pgsqlversion 14
+%define pgsqlpriority 140
 
 Summary:       PostgreSQL Data Base Management System
 Summary(de.UTF-8):     PostgreSQL Datenbankverwaltungssystem
@@ -28,12 +28,12 @@ Summary(tr.UTF-8):  Veri Tabanı Yönetim Sistemi
 Summary(uk.UTF-8):     PostgreSQL - система керування базами даних
 Summary(zh_CN.UTF-8):  PostgreSQL 客户端程序和库文件
 Name:          postgresql-%{pgsqlversion}
-Version:       %{pgsqlversion}.4
+Version:       %{pgsqlversion}.0
 Release:       1
 License:       BSD
 Group:         Applications/Databases
 Source0:       http://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
-# Source0-md5: 7bda65a37c46b8b2c1933d9d1cd677f2
+# Source0-md5: 26e85a23c6a0ef68e9755555aea31141
 Source1:       postgresql.init
 Source2:       pgsql-Database-HOWTO-html.tar.gz
 # Source2-md5: 5b656ddf1db41965761f85204a14398e
@@ -109,7 +109,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # omitted contribs:
 # spi, test_decoding, worker_spi - examples/tests
 # tsearch2 - old module for compatibility only
-%define        contrib_modules adminpack auth_delay auto_explain bloom btree_gin btree_gist citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn lo ltree %{?with_python:ltree_plpython} oid2name pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_standby pg_stat_statements pg_trgm pg_visibility pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
+%define        contrib_modules adminpack amcheck auth_delay auto_explain bloom %{?with_perl:bool_plperl} btree_gin btree_gist citext cube dblink dict_int dict_xsyn earthdistance file_fdw fuzzystrmatch hstore %{?with_perl:hstore_plperl} %{?with_python:hstore_plpython} intagg intarray isn %{?with_perl:jsonb_plperl} %{?with_python:jsonb_plpython} lo ltree %{?with_python:ltree_plpython} oid2name old_snapshot pageinspect passwordcheck pg_buffercache pg_freespacemap pg_prewarm pg_stat_statements pg_surgery pg_trgm pg_visibility pgcrypto pgrowlocks pgstattuple postgres_fdw seg %{?with_selinux:sepgsql} spi sslinfo tablefunc tcn tsm_system_rows tsm_system_time unaccent uuid-ossp vacuumlo xml2
 
 %description
 PostgreSQL Data Base Management System (formerly known as Postgres,
@@ -697,7 +697,7 @@ tar zxf %{SOURCE2} -C howto
 # find locales
 for f in libpq5 pgscripts postgres psql initdb ecpg ecpglib6 \
        plpgsql %{?with_perl:plperl} %{?with_python:plpython} \
-       pg_archivecleanup pg_basebackup pg_checksums pg_config pg_controldata pg_ctl pg_dump pg_resetwal pg_rewind pg_test_fsync pg_test_timing pg_upgrade pg_verifybackup pg_waldump; do
+       pg_amcheck pg_archivecleanup pg_basebackup pg_checksums pg_config pg_controldata pg_ctl pg_dump pg_resetwal pg_rewind pg_test_fsync pg_test_timing pg_upgrade pg_verifybackup pg_waldump; do
        %find_lang $f-%{pgsqlversion}
 done
 # merge locales
@@ -705,7 +705,7 @@ merge_lang() {
        cat $(for f in $@; do echo ${f}-%{pgsqlversion}.lang ; done)
 }
 merge_lang pgscripts postgres plpgsql \
-       pg_basebackup pg_checksums pg_config pg_controldata pg_resetwal pg_rewind pg_test_fsync pg_test_timing pg_upgrade pg_verifybackup pg_waldump > main.lang
+       pg_amcheck pg_basebackup pg_checksums pg_config pg_controldata pg_resetwal pg_rewind pg_test_fsync pg_test_timing pg_upgrade pg_verifybackup pg_waldump > main.lang
 merge_lang psql initdb \
        pg_archivecleanup pg_ctl pg_dump > clients.lang
 
@@ -862,6 +862,7 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postgresql-%{pgsqlversion}
 
 %attr(755,root,root) %{pgsqllibdir}/bin/initdb
+%attr(755,root,root) %{pgsqllibdir}/bin/pg_amcheck
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_basebackup
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_checksums
 %attr(755,root,root) %{pgsqllibdir}/bin/pg_controldata
@@ -905,6 +906,7 @@ fi
 %dir %{pgsqldatadir}/contrib
 
 %{pgsqldatadir}/man/man1/initdb.1*
+%{pgsqldatadir}/man/man1/pg_amcheck.1*
 %{pgsqldatadir}/man/man1/pg_basebackup.1*
 %{pgsqldatadir}/man/man1/pg_checksums.1*
 %{pgsqldatadir}/man/man1/pg_controldata.1*
@@ -1128,13 +1130,15 @@ fi
 %files contrib
 %defattr(644,root,root,755)
 %doc contrib/README
+%doc %{pgsqldatadir}/doc/extension/*.example
 %attr(755,root,root) %{pgsqllibdir}/bin/oid2name
-%attr(755,root,root) %{pgsqllibdir}/bin/pg_standby
 %attr(755,root,root) %{pgsqllibdir}/bin/vacuumlo
 %attr(755,root,root) %{moduledir}/_int.so
 %attr(755,root,root) %{moduledir}/adminpack.so
+%attr(755,root,root) %{moduledir}/amcheck.so
 %attr(755,root,root) %{moduledir}/auth_delay.so
 %attr(755,root,root) %{moduledir}/auto_explain.so
+%attr(755,root,root) %{moduledir}/autoinc.so
 %attr(755,root,root) %{moduledir}/bloom.so
 %attr(755,root,root) %{moduledir}/btree_gin.so
 %attr(755,root,root) %{moduledir}/btree_gist.so
@@ -1144,18 +1148,23 @@ fi
 %attr(755,root,root) %{moduledir}/file_fdw.so
 %attr(755,root,root) %{moduledir}/fuzzystrmatch.so
 %attr(755,root,root) %{moduledir}/hstore.so
+%attr(755,root,root) %{moduledir}/insert_username.so
 %attr(755,root,root) %{moduledir}/isn.so
 %attr(755,root,root) %{moduledir}/ltree.so
+%attr(755,root,root) %{moduledir}/moddatetime.so
+%attr(755,root,root) %{moduledir}/old_snapshot.so
 %attr(755,root,root) %{moduledir}/pageinspect.so
 %attr(755,root,root) %{moduledir}/passwordcheck.so
 %attr(755,root,root) %{moduledir}/pg_buffercache.so
 %attr(755,root,root) %{moduledir}/pg_freespacemap.so
 %attr(755,root,root) %{moduledir}/pg_prewarm.so
 %attr(755,root,root) %{moduledir}/pg_stat_statements.so
+%attr(755,root,root) %{moduledir}/pg_surgery.so
 %attr(755,root,root) %{moduledir}/pg_visibility.so
 %attr(755,root,root) %{moduledir}/pgrowlocks.so
 %attr(755,root,root) %{moduledir}/pgstattuple.so
 %attr(755,root,root) %{moduledir}/postgres_fdw.so
+%attr(755,root,root) %{moduledir}/refint.so
 %attr(755,root,root) %{moduledir}/seg.so
 %attr(755,root,root) %{moduledir}/sslinfo.so
 %attr(755,root,root) %{moduledir}/tcn.so
@@ -1165,6 +1174,10 @@ fi
 %attr(755,root,root) %{moduledir}/uuid-ossp.so
 %{extensiondir}/adminpack--*.sql
 %{extensiondir}/adminpack.control
+%{extensiondir}/amcheck--*.sql
+%{extensiondir}/amcheck.control
+%{extensiondir}/autoinc--*.sql
+%{extensiondir}/autoinc.control
 %{extensiondir}/bloom--*.sql
 %{extensiondir}/bloom.control
 %{extensiondir}/btree_gin--*.sql
@@ -1187,6 +1200,8 @@ fi
 %{extensiondir}/fuzzystrmatch.control
 %{extensiondir}/hstore--*.sql
 %{extensiondir}/hstore.control
+%{extensiondir}/insert_username--*.sql
+%{extensiondir}/insert_username.control
 %{extensiondir}/intarray--*.sql
 %{extensiondir}/intarray.control
 %{extensiondir}/intagg--*.sql
@@ -1195,6 +1210,10 @@ fi
 %{extensiondir}/isn.control
 %{extensiondir}/ltree--*.sql
 %{extensiondir}/ltree.control
+%{extensiondir}/moddatetime--*.sql
+%{extensiondir}/moddatetime.control
+%{extensiondir}/old_snapshot--*.sql
+%{extensiondir}/old_snapshot.control
 %{extensiondir}/pageinspect--*.sql
 %{extensiondir}/pageinspect.control
 %{extensiondir}/pg_buffercache--*.sql
@@ -1205,6 +1224,8 @@ fi
 %{extensiondir}/pg_prewarm.control
 %{extensiondir}/pg_stat_statements--*.sql
 %{extensiondir}/pg_stat_statements.control
+%{extensiondir}/pg_surgery--*.sql
+%{extensiondir}/pg_surgery.control
 %{extensiondir}/pg_visibility--*.sql
 %{extensiondir}/pg_visibility.control
 %{extensiondir}/pgrowlocks--*.sql
@@ -1213,6 +1234,8 @@ fi
 %{extensiondir}/pgstattuple.control
 %{extensiondir}/postgres_fdw--*.sql
 %{extensiondir}/postgres_fdw.control
+%{extensiondir}/refint--*.sql
+%{extensiondir}/refint.control
 %{extensiondir}/seg--*.sql
 %{extensiondir}/seg.control
 %{extensiondir}/sslinfo--*.sql
@@ -1228,14 +1251,25 @@ fi
 %{extensiondir}/uuid-ossp--*.sql
 %{extensiondir}/uuid-ossp.control
 %if %{with perl}
+%attr(755,root,root) %{moduledir}/bool_plperl.so
 %attr(755,root,root) %{moduledir}/hstore_plperl.so
+%attr(755,root,root) %{moduledir}/jsonb_plperl.so
+%{extensiondir}/bool_plperl--*.sql
+%{extensiondir}/bool_plperl.control
+%{extensiondir}/bool_plperlu--*.sql
+%{extensiondir}/bool_plperlu.control
 %{extensiondir}/hstore_plperl--*.sql
 %{extensiondir}/hstore_plperl.control
 %{extensiondir}/hstore_plperlu--*.sql
 %{extensiondir}/hstore_plperlu.control
+%{extensiondir}/jsonb_plperl--*.sql
+%{extensiondir}/jsonb_plperl.control
+%{extensiondir}/jsonb_plperlu--*.sql
+%{extensiondir}/jsonb_plperlu.control
 %endif
 %if %{with python}
 %attr(755,root,root) %{moduledir}/hstore_plpython2.so
+%attr(755,root,root) %{moduledir}/jsonb_plpython2.so
 %attr(755,root,root) %{moduledir}/ltree_plpython2.so
 %{extensiondir}/hstore_plpythonu--*.sql
 %{extensiondir}/hstore_plpythonu.control
@@ -1243,6 +1277,12 @@ fi
 %{extensiondir}/hstore_plpython2u.control
 %{extensiondir}/hstore_plpython3u--*.sql
 %{extensiondir}/hstore_plpython3u.control
+%{extensiondir}/jsonb_plpythonu--*.sql
+%{extensiondir}/jsonb_plpythonu.control
+%{extensiondir}/jsonb_plpython2u--*.sql
+%{extensiondir}/jsonb_plpython2u.control
+%{extensiondir}/jsonb_plpython3u--*.sql
+%{extensiondir}/jsonb_plpython3u.control
 %{extensiondir}/ltree_plpythonu--*.sql
 %{extensiondir}/ltree_plpythonu.control
 %{extensiondir}/ltree_plpython2u--*.sql
@@ -1251,5 +1291,4 @@ fi
 %{extensiondir}/ltree_plpython3u.control
 %endif
 %{pgsqldatadir}/man/man1/oid2name.1*
-%{pgsqldatadir}/man/man1/pg_standby.1*
 %{pgsqldatadir}/man/man1/vacuumlo.1*
index 3690d568fe51613e38c451c5a8ea8b27576d179d..380ac7310893646efe9718c0d7673ca56876c726 100644 (file)
@@ -1,7 +1,7 @@
-diff -urpa postgresql-13.1.orig/src/bin/pg_upgrade/option.c postgresql-13.1/src/bin/pg_upgrade/option.c
---- postgresql-13.1.orig/src/bin/pg_upgrade/option.c   2020-11-09 23:24:30.000000000 +0100
-+++ postgresql-13.1/src/bin/pg_upgrade/option.c        2020-12-03 20:58:30.431778786 +0100
-@@ -476,8 +476,14 @@ get_sock_dir(ClusterInfo *cluster, bool
+diff -ur postgresql-14.0.orig/src/bin/pg_upgrade/option.c postgresql-14.0/src/bin/pg_upgrade/option.c
+--- postgresql-14.0.orig/src/bin/pg_upgrade/option.c   2021-11-01 14:54:18.782057697 +0100
++++ postgresql-14.0/src/bin/pg_upgrade/option.c        2021-11-01 14:54:35.649100699 +0100
+@@ -476,8 +476,14 @@
         */
        if (GET_MAJOR_VERSION(cluster->major_version) >= 901)
        {
@@ -17,10 +17,10 @@ diff -urpa postgresql-13.1.orig/src/bin/pg_upgrade/option.c postgresql-13.1/src/
                else
                {
                        /*
-diff -urpa postgresql-13.1.orig/src/include/pg_config_manual.h postgresql-13.1/src/include/pg_config_manual.h
---- postgresql-13.1.orig/src/include/pg_config_manual.h        2020-11-09 23:24:30.000000000 +0100
-+++ postgresql-13.1/src/include/pg_config_manual.h     2020-12-03 20:59:32.262778786 +0100
-@@ -201,7 +201,7 @@
+diff -ur postgresql-14.0.orig/src/include/pg_config_manual.h postgresql-14.0/src/include/pg_config_manual.h
+--- postgresql-14.0.orig/src/include/pg_config_manual.h        2021-11-01 14:54:18.575057170 +0100
++++ postgresql-14.0/src/include/pg_config_manual.h     2021-11-01 14:54:35.767101001 +0100
+@@ -207,7 +207,7 @@
   * support them yet.
   */
  #ifndef WIN32