]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu-system-libcacard.patch
- updated to 2.4.0
[packages/qemu.git] / qemu-system-libcacard.patch
index e629fa827c5100de07718d81f9cfd63cf48a4aad..b5d9c066c6b093f7dad086f031825b04048207ea 100644 (file)
@@ -1,6 +1,7 @@
---- qemu-1.7.0/configure.orig  2013-12-15 08:38:07.584329114 +0100
-+++ qemu-1.7.0/configure       2013-12-15 08:54:19.730954984 +0100
-@@ -3543,9 +3543,11 @@
+diff -urNp qemu-2.4.0.orig/configure qemu-2.4.0/configure
+--- qemu-2.4.0.orig/configure  2015-08-25 06:46:52.000000000 +0000
++++ qemu-2.4.0/configure       2015-08-25 06:52:47.586593251 +0000
+@@ -3765,9 +3765,11 @@ if test "$smartcard_nss" != "no"; then
  int main(void) { PK11_FreeSlot(0); return 0; }
  EOF
      # FIXME: do not include $glib_* in here
@@ -13,7 +14,7 @@
      # The header files in nss < 3.13.3 have a bug which causes them to
      # emit a warning. If we're going to compile QEMU with -Werror, then
      # test that the headers don't have this bug. Otherwise we would pass
-@@ -3557,6 +3559,8 @@
+@@ -3779,6 +3781,8 @@ EOF
         $pkg_config --atleast-version=3.12.8 nss && \
        compile_prog "$test_cflags" "$nss_libs"; then
          smartcard_nss="yes"
@@ -21,8 +22,8 @@
 +        libs_softmmu="$libcacard_libs $nss_libs $libs_softmmu"
      else
          if test "$smartcard_nss" = "yes"; then
-             feature_not_found "nss"
-@@ -4574,6 +4578,8 @@
+             feature_not_found "nss" "Install nss devel >= 3.12.8"
+@@ -4933,6 +4937,8 @@ fi
  
  if test "$smartcard_nss" = "yes" ; then
    echo "CONFIG_SMARTCARD_NSS=y" >> $config_host_mak
    echo "NSS_LIBS=$nss_libs" >> $config_host_mak
    echo "NSS_CFLAGS=$nss_cflags" >> $config_host_mak
  fi
---- qemu-1.3.0/Makefile.orig   2012-12-03 20:37:05.000000000 +0100
-+++ qemu-1.3.0/Makefile        2012-12-16 11:08:58.001201236 +0100
-@@ -111,9 +111,6 @@
- include $(SRC_PATH)/Makefile.objs
+diff -urNp qemu-2.4.0.orig/hw/usb/ccid-card-passthru.c qemu-2.4.0/hw/usb/ccid-card-passthru.c
+--- qemu-2.4.0.orig/hw/usb/ccid-card-passthru.c        2015-08-11 19:11:07.000000000 +0000
++++ qemu-2.4.0/hw/usb/ccid-card-passthru.c     2015-08-25 06:52:53.709593251 +0000
+@@ -12,7 +12,7 @@
+ #include "qemu/error-report.h"
+ #include "qemu/sockets.h"
+ #include "ccid.h"
+-#include "libcacard/vscard_common.h"
++#include <cacard/vscard_common.h>
+ #define DPRINTF(card, lvl, fmt, ...)                    \
+ do {                                                    \
+diff -urNp qemu-2.4.0.orig/Makefile qemu-2.4.0/Makefile
+--- qemu-2.4.0.orig/Makefile   2015-08-11 19:11:05.000000000 +0000
++++ qemu-2.4.0/Makefile        2015-08-25 06:52:47.588593251 +0000
+@@ -157,9 +157,6 @@ dummy := $(call unnest-vars,, \
+ ifneq ($(wildcard config-host.mak),)
  include $(SRC_PATH)/tests/Makefile
  endif
 -ifeq ($(CONFIG_SMARTCARD_NSS),y)
 -include $(SRC_PATH)/libcacard/Makefile
 -endif
  
- all: $(DOCS) $(TOOLS) $(HELPERS-y) recurse-all
+ all: $(DOCS) $(TOOLS) $(HELPERS-y) recurse-all modules
  
---- qemu-1.5.0/Makefile.objs.orig      2013-05-20 17:34:39.000000000 +0200
-+++ qemu-1.5.0/Makefile.objs   2013-05-26 17:46:51.190865264 +0200
-@@ -74,8 +74,6 @@
+diff -urNp qemu-2.4.0.orig/Makefile.objs qemu-2.4.0/Makefile.objs
+--- qemu-2.4.0.orig/Makefile.objs      2015-08-11 19:11:05.000000000 +0000
++++ qemu-2.4.0/Makefile.objs   2015-08-25 06:54:03.092593251 +0000
+@@ -75,8 +75,6 @@ common-obj-y += backends/
  
  common-obj-$(CONFIG_SECCOMP) += qemu-seccomp.o
  
 -common-obj-$(CONFIG_SMARTCARD_NSS) += $(libcacard-y)
 -
- ######################################################################
- # qapi
+ common-obj-$(CONFIG_FDT) += device_tree.o
  
---- qemu-1.5.0/hw/usb/ccid-card-passthru.c.orig        2013-05-20 17:34:39.000000000 +0200
-+++ qemu-1.5.0/hw/usb/ccid-card-passthru.c     2013-05-26 17:58:20.660836330 +0200
-@@ -12,7 +12,7 @@
- #include "qemu/sockets.h"
- #include "monitor/monitor.h"
- #include "ccid.h"
--#include "libcacard/vscard_common.h"
-+#include <cacard/vscard_common.h>
- #define DPRINTF(card, lvl, fmt, ...)                    \
- do {                                                    \
+ ######################################################################