]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- updated to 2.6.1, partial PLD merge
[packages/qemu.git] / qemu.spec
index c5605808fa8de7f2ea9592237d3643d93d2580c5..2e80cb0e35b641f4df83fdafc22fa9ce0b59ee51 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,19 +1,21 @@
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
-%bcond_without glx             # OpenGL/GLX support
+%bcond_without gl              # Don't require gl deps
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
+%bcond_with    xseg            # Archipelago backend [non-distributable: GPLv3+ vs GPLv2-only]
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
-%bcond_without gtk3            # Do not build GTK UI
+%bcond_without gtk3            # Do not build GTK+ UI
+%bcond_without vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 %bcond_without oss             # OSS audio support
 %bcond_without pulseaudio      # PulseAudio audio support
 %bcond_without xen             # Xen backend driver support
 %bcond_without bluetooth       # bluetooth support
-%bcond_without brlapi          # brlapi support
+%bcond_with    brlapi          # brlapi support
 %bcond_without smartcard       # smartcard-nss support
 %bcond_without iscsi           # iscsi support
 %bcond_without libnfs          # NFS support
@@ -21,6 +23,8 @@
 %bcond_without usbredir        # usb network redirection support
 %bcond_without system_seabios  # system seabios binary
 %bcond_without snappy          # snappy compression library
+%bcond_with    lttng           # lttng-ust trace backend support
+%bcond_with    systemtap       # SystemTap/dtrace trace backend support
 
 %if %{with gtk2}
 %undefine with_gtk3
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.1.2
+Version:       2.6.1
 Release:       1
-License:       GPL v2+
+License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 0ff197c4ed4b695620bc4734e77c888f
-Source2:       %{name}.binfmt
+# Source0-md5: 6a183b192018192943b6781e1bb9b72f
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
 Source4:       80-kvm.rules
 # KSM control scripts
-Source5:       ksm.service
 Source6:       ksm.sysconfig
 Source7:       ksmctl.c
-Source8:       ksmtuned.service
 Source9:       ksmtuned
 Source10:      ksmtuned.conf
-Source11:      %{name}-guest-agent.service
 Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-system-libcacard.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
-# Proof of concept, for reference, do not remove
-Patch400:      %{name}-kde_virtual_workspaces_hack.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
+Patch5:                %{name}-sh.patch
 URL:           http://www.qemu-project.org/
-%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
-%{?with_sdl:BuildRequires:     SDL2-devel}
+%{?with_gl:BuildRequires:      OpenGL-GLX-devel}
+%{?with_gl:BuildRequires:      OpenGL-devel}
+%{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
-BuildRequires: bcc
+BuildRequires: bcc >= 0.16.21-2
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
+BuildRequires: bzip2-devel
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
-BuildRequires: glib2-devel >= 1:2.12
+BuildRequires: glib2-devel >= 1:2.22
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
 BuildRequires: gnutls-devel > 2.10.0
 BuildRequires: libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
+%{?with_gl:BuildRequires:      libepoxy-devel}
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
 %{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
@@ -82,15 +83,19 @@ BuildRequires:      libjpeg-devel
 %{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.0}
+%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.1}
 BuildRequires: libssh2-devel >= 1.2.8
 BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
+%{?with_xseg:BuildRequires:    libxseg-devel}
+%{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
-%{?with_smartcard:BuildRequires:       nss-devel >= 3.12.8}
+%{?with_smartcard:BuildRequires:       nss-devel >= 1:3.12.8}
+BuildRequires: numactl-devel
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
+BuildRequires: pixman-devel >= 0.21.8
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.644
@@ -101,9 +106,11 @@ BuildRequires:     sed >= 4.0
 BuildRequires: spice-protocol >= 0.12.3
 BuildRequires: spice-server-devel >= 0.12.0
 %endif
+%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
 BuildRequires: texi2html
 BuildRequires: texinfo
 %{?with_usbredir:BuildRequires:        usbredir-devel >= 0.6}
+%{?with_lttng:BuildRequires:   userspace-rcu-devel}
 BuildRequires: vde2-devel
 BuildRequires: which
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
@@ -112,11 +119,11 @@ BuildRequires:    xorg-lib-libX11-devel
 BuildRequires: zlib-devel
 %if %{with gtk2}
 BuildRequires: gtk+2-devel >= 2:2.18.0
-BuildRequires: vte0-devel >= 0.24.0
+%{?with_vte:BuildRequires:     vte0-devel >= 0.24.0}
 %endif
 %if %{with gtk3}
 BuildRequires: gtk+3-devel >= 3.0.0
-BuildRequires: vte-devel >= 0.32.0
+%{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-aarch64 = %{version}-%{release}
@@ -133,6 +140,7 @@ Requires:   %{name}-system-ppc = %{version}-%{release}
 Requires:      %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-sparc = %{version}-%{release}
+Requires:      %{name}-system-tricore = %{version}-%{release}
 Requires:      %{name}-system-unicore32 = %{version}-%{release}
 Requires:      %{name}-system-x86 = %{version}-%{release}
 Requires:      %{name}-system-xtensa = %{version}-%{release}
@@ -148,20 +156,22 @@ Requires: SDL2 \
 Requires:      libseccomp >= 2.1.0 \
 %endif \
 Requires:      libusb >= 1.0.13 \
+Requires:      pixman >= 0.21.8 \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
 %if %{with gtk2} \
 Requires:      gtk+2 >= 2:2.18.0 \
-Requires:      vte0 >= 0.24.0 \
+%{?with_vte:Requires:  vte0 >= 0.24.0} \
 %endif \
 %if %{with gtk3} \
 Requires:      gtk+3 >= 3.0.0 \
-Requires:      vte >= 0.32.0 \
+%{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
-# some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
+# don't strip/chrpath anything in there; these are boot images, roms etc
+%define                _noautostrip    .*%{_datadir}/qemu/.*
+%define                _noautochrpath  .*%{_datadir}/qemu/.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -198,17 +208,15 @@ aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 Summary:       QEMU common files needed by all QEMU targets
 Summary(pl.UTF-8):     Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
 Group:         Development/Tools
-Requires(post,preun,postun):   systemd-units >= 38
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      glib2 >= 1:2.12
+Requires:      glib2 >= 1:2.22
 %{?with_libnfs:Requires:       libnfs >= 1.9.3}
 Requires:      libssh2 >= 1.2.8
-Requires:      systemd-units >= 38
 Provides:      group(qemu)
 Provides:      user(qemu)
 Obsoletes:     qemu-kvm-common
@@ -242,13 +250,24 @@ images.
 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
 na obrazach dysków.
 
+%package ivshmem
+Summary:       Client and server for QEMU ivshmem device
+Summary(pl.UTF-8):     Klient i serwer dla urządzeia ivshmem QEMU
+Group:         Development/Tools
+
+%description ivshmem
+This package provides client and server tools for QEMU's ivshmem
+device.
+
+%description ivshmem -l pl.UTF-8
+Ten pakiet udostępnia działające z linii poleceń narzędzia dla
+urządzenia ivshmem QEMU.
+
 %package user
 Summary:       QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
-Requires(post,postun): systemd-units >= 38
-Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-user
 
 %description user
@@ -542,6 +561,25 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
 
+%package system-tricore
+Summary:       QEMU system emulator for TriCore
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem TriCore
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-tricore
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with TriCore CPU.
+
+%description system-sparc -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem TriCore.
+
 %package system-unicore32
 Summary:       QEMU system emulator for UniCore32
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem UniCore32
@@ -604,9 +642,7 @@ Ten pakiet zawiera emulator systemu z procesorem Xtensa.
 Summary:       QEMU guest agent
 Summary(pl.UTF-8):     Agent gościa QEMU
 Group:         Daemons
-Requires(post,preun,postun):   systemd-units >= 38
-Requires:      glib2 >= 1:2.12
-Requires:      systemd-units >= 38
+Requires:      glib2 >= 1:2.22
 Obsoletes:     qemu-kvm-guest-agent
 
 %description guest-agent
@@ -629,6 +665,18 @@ systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
 
 Ten pakiet nie musi być zainstalowany w systemie hosta.
 
+%package module-block-archipelago
+Summary:       QEMU module for Archipelago block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych Archipelago
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-archipelago
+Archipelago block device support for QEMU.
+
+%description module-block-archipelago -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych Archipelago.
+
 %package module-block-curl
 Summary:       QEMU module for 'curl' block devices
 Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'curl'
@@ -641,6 +689,18 @@ Requires:  %{name}-common = %{version}-%{release}
 %description module-block-curl -l pl.UTF-8
 Moduł QEMU dla urządeń blokowych typu 'curl'.
 
+%package module-block-dmg
+Summary:       QEMU module for 'dmg' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'dmg'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-dmg
+'dmg' block device support for QEMU.
+
+%description module-block-dmg -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'dmg'.
+
 %package module-block-gluster
 Summary:       QEMU module for 'gluster' block devices
 Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'gluster'
@@ -659,7 +719,7 @@ Summary:    QEMU module for 'iscsi' block devices
 Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'iscsi'
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      libiscsi >= 1.4.0
+Requires:      libiscsi >= 1.9.0
 
 %description module-block-iscsi
 'iscsi' block device support for QEMU.
@@ -695,20 +755,18 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p0
+%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
 
-%{__mv} libcacard libcacard-use-system-lib
-
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
 %build
 ./configure \
-       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
-       --extra-ldflags="%{rpmldflags}" \
+       --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
+       --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
@@ -716,6 +774,7 @@ ln -s ../error.h qapi/error.h
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --disable-strip \
+       %{__enable_disable xseg archipelago} \
        --enable-attr \
        %{__enable_disable bluetooth bluez} \
        %{__enable_disable brlapi} \
@@ -726,15 +785,15 @@ ln -s ../error.h qapi/error.h
        --enable-fdt \
        %{__enable_disable glusterfs} \
        %{__enable_disable iscsi libiscsi} \
-       %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       %{__enable_disable smartcard smartcard-nss} \
+       %{__enable_disable smartcard smartcard} \
        --enable-tpm \
+       --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
        %{__enable_disable usbredir usb-redir} \
        --enable-uuid \
        --enable-vde \
@@ -742,7 +801,7 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       --enable-vnc-tls \
+       %{!?with_vte:--disable-vte} \
        --enable-kvm \
        %{__enable_disable xen} \
        --enable-modules \
@@ -750,13 +809,11 @@ ln -s ../error.h qapi/error.h
        %{__enable_disable libnfs} \
        --enable-lzo \
        %{__enable_disable snappy} \
-       --enable-quorum \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
        --interp-prefix=%{_libdir}/qemu/lib-%%M \
 %if %{without gtk2} && %{without gtk3}
        --disable-gtk
 %else
-       --enable-gtk \
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
@@ -771,14 +828,16 @@ ln -s ../error.h qapi/error.h
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
-       $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
+install -d \
+       $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %{__make} install \
        %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
        DESTDIR=$RPM_BUILD_ROOT
 
+echo "#allow br0" > $RPM_BUILD_ROOT/etc/qemu/bridge.conf
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
@@ -793,40 +852,14 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 %endif
 
-install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
 
-install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 
-# For the qemu-guest-agent subpackage install the systemd
-# service and udev rules.
-install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
-for i in dummy \
-%ifnarch %{ix86} %{x8664}
-       qemu-i386 \
-%endif
-%ifnarch arm
-       qemu-arm \
-%endif
-%ifnarch ppc ppc64
-       qemu-ppc \
-%endif
-%ifnarch sparc sparc64
-       qemu-sparc \
-%endif
-%ifnarch sh4
-       qemu-sh4 \
-%endif
-; do
-       test $i = dummy && continue
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
-done < %{SOURCE2}
-
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
@@ -861,55 +894,25 @@ rm -rf $RPM_BUILD_ROOT
 %groupadd -g 276 qemu
 %useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
 
-%post common
-%systemd_post ksm.service
-%systemd_post ksmtuned.service
-
-%preun common
-%systemd_preun ksm.service
-%systemd_preun ksmtuned.service
-
 %postun common
 if [ "$1" = "0" ]; then
        %userremove qemu
        %groupremove qemu
        %groupremove kvm
 fi
-%systemd_reload
-
-%triggerpostun common -- qemu-common < 1.6.1-4
-%systemd_trigger ksm.service
-%systemd_trigger ksmtuned.service
-
-%post user
-%systemd_service_restart systemd-binfmt.service
-
-%postun user
-%systemd_service_restart systemd-binfmt.service
-
-%post guest-agent
-%systemd_reload
-
-%preun guest-agent
-%systemd_preun qemu-guest-agent.service
-
-%postun guest-agent
-%systemd_reload
 
 %files
 %defattr(644,root,root,755)
 
 %files common -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html qmp-commands.txt
+%doc LICENSE README qemu-doc.html qemu-tech.html qmp-commands.txt
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
-%{systemdunitdir}/ksm.service
-%{systemdunitdir}/ksmtuned.service
-%dir %{_sysconfdir}/qemu
+%dir /etc/qemu
+%attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
@@ -922,6 +925,7 @@ fi
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
+%{_datadir}/%{name}/trace-events
 
 # various bios images
 # all should be probably moved to the right system subpackage
@@ -951,16 +955,15 @@ fi
 %{_datadir}/%{name}/pxe-virtio.rom
 %{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/s390-ccw.img
-%{_datadir}/%{name}/s390-zipl.rom
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
-%{_datadir}/%{name}/u-boot.e500
+%{_datadir}/%{name}/vgabios.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
+%{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
-%{_datadir}/%{name}/vgabios.bin
 
 %dir %{_libdir}/%{name}
 
@@ -969,9 +972,13 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-img
 %{_mandir}/man1/qemu-img.1*
 
+%files ivshmem
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ivshmem-client
+%attr(755,root,root) %{_bindir}/ivshmem-server
+
 %files user
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
@@ -999,6 +1006,7 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
+%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_bindir}/qemu-unicore32
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
@@ -1050,7 +1058,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
+#%attr(755,root,root) %{_bindir}/qemu-system-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+%{_datadir}/%{name}/u-boot.e500
 
 %files system-s390x
 %defattr(644,root,root,755)
@@ -1066,6 +1076,10 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-system-sparc
 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
 
+%files system-tricore
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-tricore
+
 %files system-unicore32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
@@ -1082,7 +1096,6 @@ fi
 %{_datadir}/%{name}/bios.bin
 %{_datadir}/%{name}/bios-256k.bin
 %{_datadir}/%{name}/acpi-dsdt.aml
-%{_datadir}/%{name}/q35-acpi-dsdt.aml
 
 %files system-xtensa
 %defattr(644,root,root,755)
@@ -1092,13 +1105,23 @@ fi
 %files guest-agent
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
-%{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man8/qemu-ga.8*
+
+%if %{with xseg}
+%files module-block-archipelago
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-archipelago.so
+%endif
 
 %files module-block-curl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/block-curl.so
 
+%files module-block-dmg
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-dmg.so
+
 %if %{with glusterfs}
 %files module-block-gluster
 %defattr(644,root,root,755)