]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- merged 3.0.0 from PLD
[packages/qemu.git] / qemu.spec
index 240d5b1fe38499b094fb493e764f948f0e4c40fb..61e8d3e45d0f96aa31d6d4f9aeb28d49b353084b 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.12.0
+Version:       3.0.0
 Release:       1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.xz
-# Source0-md5: ca553eb04c933f58111c304452fc4cc5
-Source2:       %{name}.binfmt
+# Source0-md5: 6a5c8df583406ea24ef25b239c3243e0
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -55,12 +54,11 @@ Source9:    ksmtuned
 Source10:      ksmtuned.conf
 Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
-Patch1:                vgabios-widescreens.patch
-Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-user-execve.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
-Patch6:                x32.patch
+Patch1:                %{name}-whitelist.patch
+Patch2:                %{name}-user-execve.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
+Patch5:                x32.patch
 URL:           http://www.qemu-project.org/
 %{?with_gl:BuildRequires:      OpenGL-GLX-devel}
 %{?with_gl:BuildRequires:      OpenGL-devel}
@@ -840,7 +838,6 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
@@ -940,14 +937,11 @@ build static \
 
 %endif
 
-# rebuild patched vesa tables with additional widescreen modes.
-%{__make} -C roms/vgabios stdvga-bios
-
 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/usr/lib/binfmt.d \
+install -d \
        $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
@@ -991,64 +985,9 @@ install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 # For the qemu-guest-agent subpackage install the udev rules.
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
-# Install binfmt
-for i in dummy \
-%ifnarch %{ix86} %{x8664} x32
-       qemu-i386 \
-%endif
-%ifnarch alpha
-       qemu-alpha \
-%endif
-%ifnarch %{arm}
-       qemu-arm \
-%endif
-       qemu-armeb \
-       qemu-cris \
-       qemu-microblaze qemu-microblazeel \
-%ifnarch mips64
-       qemu-mips64 \
-%ifnarch mips
-       qemu-mips \
-%endif
-%endif
-%ifnarch mips64el
-       qemu-mips64el \
-%ifnarch mipsel
-       qemu-mipsel \
-%endif
-%endif
-%ifnarch m68k
-       qemu-m68k \
-%endif
-%ifnarch ppc ppc64 ppc64le
-       qemu-ppc qemu-ppc64abi32 qemu-ppc64 \
-%endif
-%ifnarch sparc sparc64
-       qemu-sparc qemu-sparc32plus qemu-sparc64 \
-%endif
-%ifnarch s390 s390x
-       qemu-s390x \
-%endif
-%ifnarch sh4
-       qemu-sh4 \
-%endif
-       qemu-sh4eb \
-; do
-       test $i = dummy && continue
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-dynamic.conf
-
-       %if %{with user_static}
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-static.conf
-       %{__sed} -i -e "s/$i/$i-static/" $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-static.conf
-       %endif
-done < %{SOURCE2}
-
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
 
-# install patched vesa tables with additional widescreen modes.
-cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
-
 %if %{with system_seabios}
 ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios-256k.bin
 # bios.bin provided by qemu is stripped to 128k, with no Xen support, keep it
@@ -1181,7 +1120,6 @@ fi
 
 %files user
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*-dynamic.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-aarch64_be
 %attr(755,root,root) %{_bindir}/qemu-alpha
@@ -1221,7 +1159,6 @@ fi
 %if %{with user_static}
 %files user-static
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*-static.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64-static
 %attr(755,root,root) %{_bindir}/qemu-aarch64_be-static
 %attr(755,root,root) %{_bindir}/qemu-alpha-static