]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- updated to 2.3.0
[packages/qemu.git] / qemu.spec
index 93c033965e76573f7046a59908a4c61fd532aada..b2b95c2d5cc32575dbe559d031cc2bbed1e3073d 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,12 +1,11 @@
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
-%bcond_without glx             # OpenGL/GLX support
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
-%bcond_with    gtk3            # Do not build GTK+ UI
+%bcond_without gtk3            # Do not build GTK+ UI
 %bcond_with    vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.2.0
+Version:       2.3.0
 Release:       1
 License:       GPL v2+
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: f7a5e2da22d057eb838a91da7aff43c8
+# Source0-md5: 2fab3ea4460de9b57192e5b8b311f221
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
 Source4:       80-kvm.rules
 # KSM control scripts
-Source5:       ksm.service
 Source6:       ksm.sysconfig
 Source7:       ksmctl.c
-Source8:       ksmtuned.service
 Source9:       ksmtuned
 Source10:      ksmtuned.conf
-Source11:      %{name}-guest-agent.service
-Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
@@ -61,7 +56,6 @@ Patch5:               libjpeg-boolean.patch
 # Proof of concept, for reference, do not remove
 Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
-%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
 BuildRequires: bcc
@@ -169,6 +163,7 @@ Requires:   gtk+3 >= 3.0.0 \
 
 # some PPC/SPARC boot image in ELF format
 %define                _noautostrip    .*%{_datadir}/qemu/.*-.*
+%define                _noautochrpath  .*%{_datadir}/qemu/.*-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -205,7 +200,6 @@ aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 Summary:       QEMU common files needed by all QEMU targets
 Summary(pl.UTF-8):     Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
 Group:         Development/Tools
-Requires(post,preun,postun):   systemd-units >= 38
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
@@ -215,7 +209,6 @@ Requires(pre):      /usr/sbin/useradd
 Requires:      glib2 >= 1:2.12
 %{?with_libnfs:Requires:       libnfs >= 1.9.3}
 Requires:      libssh2 >= 1.2.8
-Requires:      systemd-units >= 38
 Provides:      group(qemu)
 Provides:      user(qemu)
 Obsoletes:     qemu-kvm-common
@@ -254,8 +247,6 @@ Summary:    QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
-Requires(post,postun): systemd-units >= 38
-Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-user
 
 %description user
@@ -630,9 +621,7 @@ Ten pakiet zawiera emulator systemu z procesorem Xtensa.
 Summary:       QEMU guest agent
 Summary(pl.UTF-8):     Agent gościa QEMU
 Group:         Daemons
-Requires(post,preun,postun):   systemd-units >= 38
 Requires:      glib2 >= 1:2.12
-Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-guest-agent
 
 %description guest-agent
@@ -752,7 +741,6 @@ ln -s ../error.h qapi/error.h
        --enable-fdt \
        %{__enable_disable glusterfs} \
        %{__enable_disable iscsi libiscsi} \
-       %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
@@ -798,7 +786,7 @@ ln -s ../error.h qapi/error.h
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
+install -d $RPM_BUILD_ROOT/usr/lib/binfmt.d \
        $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
@@ -820,19 +808,12 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 %endif
 
-install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
 install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
 
-install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 
-# For the qemu-guest-agent subpackage install the systemd
-# service and udev rules.
-install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
-install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
-
 for i in dummy \
 %ifnarch %{ix86} %{x8664}
        qemu-i386 \
@@ -888,40 +869,14 @@ rm -rf $RPM_BUILD_ROOT
 %groupadd -g 276 qemu
 %useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
 
-%post common
-%systemd_post ksm.service
-%systemd_post ksmtuned.service
-
-%preun common
-%systemd_preun ksm.service
-%systemd_preun ksmtuned.service
-
 %postun common
 if [ "$1" = "0" ]; then
        %userremove qemu
        %groupremove qemu
        %groupremove kvm
 fi
-%systemd_reload
 
 %triggerpostun common -- qemu-common < 1.6.1-4
-%systemd_trigger ksm.service
-%systemd_trigger ksmtuned.service
-
-%post user
-%systemd_service_restart systemd-binfmt.service
-
-%postun user
-%systemd_service_restart systemd-binfmt.service
-
-%post guest-agent
-%systemd_reload
-
-%preun guest-agent
-%systemd_preun qemu-guest-agent.service
-
-%postun guest-agent
-%systemd_reload
 
 %files
 %defattr(644,root,root,755)
@@ -934,8 +889,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
-%{systemdunitdir}/ksm.service
-%{systemdunitdir}/ksmtuned.service
 %dir %{_sysconfdir}/qemu
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
@@ -1124,8 +1077,6 @@ fi
 
 %files guest-agent
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
-%{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
 
 %files module-block-curl