]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- merged 3.1.0 from PLD
[packages/qemu.git] / qemu.spec
index 93ce3a9b13244b9c740c1d7a56f2485db100b924..c208d8ace406e064236e109a4ff46369edc2eacb 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -5,7 +5,6 @@
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
-%bcond_with    gtk2            # GTK+ 2.x instead of 3.x
 %bcond_without gtk3            # Do not build GTK+ UI
 %bcond_without vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_with    virgl           # build virgl support
 %bcond_without xkbcommon       # xkbcommon support
 
-%if %{with gtk2}
-%undefine with_gtk3
-%endif
-
 %ifarch x32
 %undefine      with_xen
 %endif
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       3.0.0
+Version:       3.1.0
 Release:       1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.xz
-# Source0-md5: 6a5c8df583406ea24ef25b239c3243e0
+# Source0-md5: fb687ce0b02d3bf4327e36d3b99427a8
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -76,7 +71,7 @@ BuildRequires:        cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: glib2-devel >= 1:2.22
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
-BuildRequires: gnutls-devel > 2.10.0
+BuildRequires: gnutls-devel >= 3.1.18
 BuildRequires: libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
@@ -90,7 +85,7 @@ BuildRequires:        libjpeg-devel
 %{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.1}
+%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.2.0}
 BuildRequires: libssh2-devel >= 1.2.8
 BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
@@ -125,12 +120,8 @@ BuildRequires:     xfsprogs-devel
 %{?with_xkbcommon:BuildRequires:       xorg-lib-libxkbcommon-devel}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: zlib-devel
-%if %{with gtk2}
-BuildRequires: gtk+2-devel >= 2:2.18.0
-%{?with_vte:BuildRequires:     vte0-devel >= 0.24.0}
-%endif
 %if %{with gtk3}
-BuildRequires: gtk+3-devel >= 3.0.0
+BuildRequires: gtk+3-devel >= 3.14.0
 %{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
 %if %{with user_static}
@@ -172,19 +163,15 @@ Requires: SDL2 \
 %endif \
 Requires:      libfdt >= 1.4.2 \
 %if %{with seccomp} \
-Requires:      libseccomp >= 2.1.0 \
+Requires:      libseccomp >= 2.2.0 \
 %endif \
 Requires:      libusb >= 1.0.13 \
 Requires:      pixman >= 0.21.8 \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
-%if %{with gtk2} \
-Requires:      gtk+2 >= 2:2.18.0 \
-%{?with_vte:Requires:  vte0 >= 0.24.0} \
-%endif \
 %if %{with gtk3} \
-Requires:      gtk+3 >= 3.0.0 \
+Requires:      gtk+3 >= 3.14.0 \
 %{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
@@ -912,10 +899,8 @@ build dynamic \
        --enable-lzo \
        %{__enable_disable snappy} \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
-%if %{without gtk2} && %{without gtk3}
+%if %{without gtk3}
        --disable-gtk
-%else
-       --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
 %if %{with user_static}
@@ -987,9 +972,6 @@ install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 
-# For the qemu-guest-agent subpackage install the udev rules.
-install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
-
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
 
@@ -1004,7 +986,7 @@ for f in $RPM_BUILD_ROOT%{_datadir}/%{name}/*.aml ; do
 done
 %endif
 
-%if %{with gtk2} || %{with gtk3}
+%if %{with gtk3}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
 %find_lang %{name}
@@ -1094,8 +1076,10 @@ fi
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
 %{_datadir}/%{name}/vgabios.bin
+%{_datadir}/%{name}/vgabios-bochs-display.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
+%{_datadir}/%{name}/vgabios-ramfb.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
 %{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
@@ -1110,7 +1094,7 @@ fi
 %{?with_pulseaudio:%attr(755,root,root) %{_libdir}/%{name}/audio-pa.so}
 %{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/audio-sdl.so}
 %attr(755,root,root) %{_libdir}/%{name}/ui-curses.so
-%if %{with gtk2} || %{with gtk3}
+%if %{with gtk3}
 %attr(755,root,root) %{_libdir}/%{name}/ui-gtk.so
 %endif
 %{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/ui-sdl.so}
@@ -1260,7 +1244,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
-%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
 %{_datadir}/%{name}/canyonlands.dtb
 %{_datadir}/%{name}/qemu_vga.ndrv
 %{_datadir}/%{name}/u-boot.e500