]> TLD Linux GIT Repositories - packages/qemu.git/blobdiff - qemu.spec
- ceph no longer supports 32-bit archs
[packages/qemu.git] / qemu.spec
index 240d5b1fe38499b094fb493e764f948f0e4c40fb..edaf0bd300dc46ede79cc8212c67f8b9646182ae 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -5,7 +5,6 @@
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
-%bcond_with    gtk2            # GTK+ 2.x instead of 3.x
 %bcond_without gtk3            # Do not build GTK+ UI
 %bcond_without vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_without user_static     # build linux-user static packages
 %bcond_with    lttng           # lttng-ust trace backend support
 %bcond_with    systemtap       # SystemTap/dtrace trace backend support
-
-%if %{with gtk2}
-%undefine with_gtk3
-%endif
+%bcond_with    virgl           # build virgl support
+%bcond_without xkbcommon       # xkbcommon support
 
 %ifarch x32
 %undefine      with_xen
 %endif
 
+# ceph >= 14.0 no longer support 32-bit archs
+%ifarch %{ix86}
+%undefine      with_ceph
+%endif
+
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.12.0
+Version:       4.0.0
 Release:       1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.xz
-# Source0-md5: ca553eb04c933f58111c304452fc4cc5
-Source2:       %{name}.binfmt
+# Source0-md5: 0afeca336fd57ae3d3086ec07f59d708
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -53,14 +54,12 @@ Source6:    ksm.sysconfig
 Source7:       ksmctl.c
 Source9:       ksmtuned
 Source10:      ksmtuned.conf
-Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
-Patch1:                vgabios-widescreens.patch
-Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-user-execve.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
-Patch6:                x32.patch
+Patch1:                %{name}-whitelist.patch
+Patch2:                %{name}-user-execve.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
+Patch5:                x32.patch
 URL:           http://www.qemu-project.org/
 %{?with_gl:BuildRequires:      OpenGL-GLX-devel}
 %{?with_gl:BuildRequires:      OpenGL-devel}
@@ -76,7 +75,7 @@ BuildRequires:        cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: glib2-devel >= 1:2.22
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
-BuildRequires: gnutls-devel > 2.10.0
+BuildRequires: gnutls-devel >= 3.1.18
 BuildRequires: libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
@@ -90,7 +89,7 @@ BuildRequires:        libjpeg-devel
 %{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.1}
+%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.2.0}
 BuildRequires: libssh2-devel >= 1.2.8
 BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
@@ -119,16 +118,14 @@ BuildRequires:    texinfo
 %{?with_lttng:BuildRequires:   userspace-rcu-devel}
 BuildRequires: vde2-devel
 BuildRequires: which
+%{?with_virgl:BuildRequires:   virglrenderer-devel}
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
 BuildRequires: xfsprogs-devel
+%{?with_xkbcommon:BuildRequires:       xorg-lib-libxkbcommon-devel}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: zlib-devel
-%if %{with gtk2}
-BuildRequires: gtk+2-devel >= 2:2.18.0
-%{?with_vte:BuildRequires:     vte0-devel >= 0.24.0}
-%endif
 %if %{with gtk3}
-BuildRequires: gtk+3-devel >= 3.0.0
+BuildRequires: gtk+3-devel >= 3.14.0
 %{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
 %if %{with user_static}
@@ -170,19 +167,15 @@ Requires: SDL2 \
 %endif \
 Requires:      libfdt >= 1.4.2 \
 %if %{with seccomp} \
-Requires:      libseccomp >= 2.1.0 \
+Requires:      libseccomp >= 2.2.0 \
 %endif \
 Requires:      libusb >= 1.0.13 \
 Requires:      pixman >= 0.21.8 \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
-%if %{with gtk2} \
-Requires:      gtk+2 >= 2:2.18.0 \
-%{?with_vte:Requires:  vte0 >= 0.24.0} \
-%endif \
 %if %{with gtk3} \
-Requires:      gtk+3 >= 3.0.0 \
+Requires:      gtk+3 >= 3.14.0 \
 %{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
@@ -840,7 +833,6 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
@@ -891,7 +883,6 @@ build dynamic \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
-       --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
        %{__enable_disable smartcard smartcard} \
@@ -903,6 +894,7 @@ build dynamic \
        --enable-vnc-png \
        --enable-vnc-sasl \
        %{!?with_vte:--disable-vte} \
+       %{__enable_disable virgl virglrenderer} \
        %{__enable_disable xen} \
        --enable-modules \
        --disable-netmap \
@@ -910,10 +902,8 @@ build dynamic \
        --enable-lzo \
        %{__enable_disable snappy} \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
-%if %{without gtk2} && %{without gtk3}
+%if %{without gtk3}
        --disable-gtk
-%else
-       --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
 %if %{with user_static}
@@ -940,14 +930,11 @@ build static \
 
 %endif
 
-# rebuild patched vesa tables with additional widescreen modes.
-%{__make} -C roms/vgabios stdvga-bios
-
 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/usr/lib/binfmt.d \
+install -d \
        $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
@@ -988,67 +975,9 @@ install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 
-# For the qemu-guest-agent subpackage install the udev rules.
-install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
-
-# Install binfmt
-for i in dummy \
-%ifnarch %{ix86} %{x8664} x32
-       qemu-i386 \
-%endif
-%ifnarch alpha
-       qemu-alpha \
-%endif
-%ifnarch %{arm}
-       qemu-arm \
-%endif
-       qemu-armeb \
-       qemu-cris \
-       qemu-microblaze qemu-microblazeel \
-%ifnarch mips64
-       qemu-mips64 \
-%ifnarch mips
-       qemu-mips \
-%endif
-%endif
-%ifnarch mips64el
-       qemu-mips64el \
-%ifnarch mipsel
-       qemu-mipsel \
-%endif
-%endif
-%ifnarch m68k
-       qemu-m68k \
-%endif
-%ifnarch ppc ppc64 ppc64le
-       qemu-ppc qemu-ppc64abi32 qemu-ppc64 \
-%endif
-%ifnarch sparc sparc64
-       qemu-sparc qemu-sparc32plus qemu-sparc64 \
-%endif
-%ifnarch s390 s390x
-       qemu-s390x \
-%endif
-%ifnarch sh4
-       qemu-sh4 \
-%endif
-       qemu-sh4eb \
-; do
-       test $i = dummy && continue
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-dynamic.conf
-
-       %if %{with user_static}
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-static.conf
-       %{__sed} -i -e "s/$i/$i-static/" $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-static.conf
-       %endif
-done < %{SOURCE2}
-
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
 
-# install patched vesa tables with additional widescreen modes.
-cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
-
 %if %{with system_seabios}
 ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios-256k.bin
 # bios.bin provided by qemu is stripped to 128k, with no Xen support, keep it
@@ -1060,7 +989,7 @@ for f in $RPM_BUILD_ROOT%{_datadir}/%{name}/*.aml ; do
 done
 %endif
 
-%if %{with gtk2} || %{with gtk3}
+%if %{with gtk3}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
 %find_lang %{name}
@@ -1068,6 +997,8 @@ done
 : > qemu.lang
 %endif
 
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1096,8 +1027,10 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
 %dir /etc/qemu
 %attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
+%attr(755,root,root) %{_bindir}/elf2dmp
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
-%attr(755,root,root) %{_bindir}/qemu-keymap
+%attr(755,root,root) %{_bindir}/qemu-edid
+%{?with_xkbcommon:%attr(755,root,root) %{_bindir}/qemu-keymap}
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_bindir}/qemu-pr-helper
 %attr(755,root,root) %{_bindir}/qemu-tilegx
@@ -1106,12 +1039,12 @@ fi
 %attr(755,root,root) %{_sbindir}/ksmtuned
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/virtfs-proxy-helper.1*
+%{_mandir}/man7/qemu-cpu-models.7*
 %{_mandir}/man7/qemu-block-drivers.7*
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
-%{_datadir}/%{name}/qemu-icon.bmp
 %{_datadir}/%{name}/trace-events-all
 
 # various bios images
@@ -1135,6 +1068,7 @@ fi
 %{_datadir}/%{name}/petalogix-ml605.dtb
 %{_datadir}/%{name}/petalogix-s3adsp1800.dtb
 %{_datadir}/%{name}/ppc_rom.bin
+%{_datadir}/%{name}/pvh.bin
 %{_datadir}/%{name}/pxe-e1000.rom
 %{_datadir}/%{name}/pxe-eepro100.rom
 %{_datadir}/%{name}/pxe-ne2k_pci.rom
@@ -1142,7 +1076,6 @@ fi
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
 %{_datadir}/%{name}/QEMU,cgthree.bin
-%{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/QEMU,tcx.bin
 %{_datadir}/%{name}/s390-ccw.img
 %{_datadir}/%{name}/sgabios.bin
@@ -1150,8 +1083,10 @@ fi
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
 %{_datadir}/%{name}/vgabios.bin
+%{_datadir}/%{name}/vgabios-bochs-display.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
+%{_datadir}/%{name}/vgabios-ramfb.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
 %{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
@@ -1160,14 +1095,16 @@ fi
 
 # modules without too many external dependencies
 %attr(755,root,root) %{_libdir}/%{name}/block-dmg-bz2.so
-%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so
+%{?with_libnfs:%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so}
 
 %attr(755,root,root) %{_libdir}/%{name}/audio-alsa.so
-%attr(755,root,root) %{_libdir}/%{name}/audio-pa.so
-%attr(755,root,root) %{_libdir}/%{name}/audio-sdl.so
+%{?with_pulseaudio:%attr(755,root,root) %{_libdir}/%{name}/audio-pa.so}
+%{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/audio-sdl.so}
 %attr(755,root,root) %{_libdir}/%{name}/ui-curses.so
+%if %{with gtk3}
 %attr(755,root,root) %{_libdir}/%{name}/ui-gtk.so
-%attr(755,root,root) %{_libdir}/%{name}/ui-sdl.so
+%endif
+%{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/ui-sdl.so}
 
 %files img
 %defattr(644,root,root,755)
@@ -1181,7 +1118,6 @@ fi
 
 %files user
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*-dynamic.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-aarch64_be
 %attr(755,root,root) %{_bindir}/qemu-alpha
@@ -1221,7 +1157,6 @@ fi
 %if %{with user_static}
 %files user-static
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*-static.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64-static
 %attr(755,root,root) %{_bindir}/qemu-aarch64_be-static
 %attr(755,root,root) %{_bindir}/qemu-alpha-static
@@ -1316,7 +1251,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
-%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
 %{_datadir}/%{name}/canyonlands.dtb
 %{_datadir}/%{name}/qemu_vga.ndrv
 %{_datadir}/%{name}/u-boot.e500
@@ -1371,8 +1305,8 @@ fi
 
 %files guest-agent
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man7/qemu-ga-ref.7*
 %{_mandir}/man8/qemu-ga.8*
 
 %files module-block-curl