]> TLD Linux GIT Repositories - packages/qemu.git/commitdiff
- updated to 5.2.0
authorMarcin Krol <hawk@tld-linux.org>
Sun, 3 Jan 2021 10:57:00 +0000 (11:57 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 3 Jan 2021 10:57:00 +0000 (11:57 +0100)
qemu-cflags.patch
qemu-vxhs.patch [deleted file]
qemu-whitelist.patch [deleted file]
qemu.spec

index ed5ce2a7a2e81a4f946a2450910d5e70e7812de0..f5dab3ec1480e30b2d958819811038b0ec3042ba 100644 (file)
@@ -1,16 +1,17 @@
---- qemu-5.0.0/configure.orig  2020-05-25 07:18:02.653298508 +0200
-+++ qemu-5.0.0/configure       2020-05-25 07:23:20.044912383 +0200
-@@ -6258,12 +6258,8 @@
+diff -ur qemu-5.2.0.orig/configure qemu-5.2.0/configure
+--- qemu-5.2.0.orig/configure  2021-01-02 17:56:31.497947511 +0100
++++ qemu-5.2.0/configure       2021-01-02 18:11:17.004206582 +0100
+@@ -5664,13 +5664,6 @@
  write_c_skeleton
  
- if test "$gcov" = "yes" ; then
--  QEMU_CFLAGS="-fprofile-arcs -ftest-coverage -g $QEMU_CFLAGS"
-+  QEMU_CFLAGS="-fprofile-arcs -ftest-coverage $QEMU_CFLAGS"
-   QEMU_LDFLAGS="-fprofile-arcs -ftest-coverage $QEMU_LDFLAGS"
+-if test "$gcov" = "yes" ; then
+-  :
 -elif test "$fortify_source" = "yes" ; then
--  CFLAGS="-O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $CFLAGS"
--elif test "$debug" = "no"; then
--  CFLAGS="-O2 $CFLAGS"
- fi
- if test "$have_asan" = "yes"; then
+-  QEMU_CFLAGS="-U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $QEMU_CFLAGS"
+-  debug=no
+-fi
+-
+ case "$ARCH" in
+ alpha)
+   # Ensure there's only a single GP
diff --git a/qemu-vxhs.patch b/qemu-vxhs.patch
deleted file mode 100644 (file)
index 00a50b7..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- qemu-4.2.0/block/vxhs.c.orig       2019-12-12 19:20:47.000000000 +0100
-+++ qemu-4.2.0/block/vxhs.c    2020-05-23 22:56:39.361009319 +0200
-@@ -18,6 +18,7 @@
- #include "qapi/qmp/qstring.h"
- #include "trace.h"
- #include "qemu/module.h"
-+#include "qemu/option.h"
- #include "qemu/uri.h"
- #include "qapi/error.h"
- #include "qemu/uuid.h"
diff --git a/qemu-whitelist.patch b/qemu-whitelist.patch
deleted file mode 100644 (file)
index 318b990..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- scripts/create_config.org  2011-02-16 15:44:05.000000000 +0100
-+++ scripts/create_config      2011-03-21 21:26:16.136615526 +0100
-@@ -33,7 +33,9 @@
-  CONFIG_BDRV_WHITELIST=*)
-     echo "#define CONFIG_BDRV_WHITELIST \\"
-     for drv in ${line#*=}; do
--      echo "    \"${drv}\",\\"
-+      if [ ! -z "$drv" ]; then
-+        echo "    \"${drv}\",\\"
-+      fi
-     done
-     echo "    NULL"
-     ;;
index 36a34cd5cdfefb645491e5aa44fbc4c0e8f836ae..9ba92b7f5ba36ca327184777d7671865c8fed6dc 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -27,7 +27,6 @@
 %bcond_with    lttng           # lttng-ust trace backend support [needs update]
 %bcond_without systemtap       # SystemTap/dtrace trace backend support
 %bcond_without virgl           # build virgl support
-%bcond_with    vxhs            # Veritas HyperScale vDisk backend support (builtin; module not supported)
 %bcond_without xkbcommon       # xkbcommon support
 
 %if %{without gtk}
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       5.0.0
-Release:       4
+Version:       5.2.0
+Release:       1
 License:       GPL v2, BSD (edk2 firmware files)
 Group:         Applications/Emulators
 Source0:       https://download.qemu.org/%{name}-%{version}.tar.xz
-# Source0-md5: ede6005d7143fe994dd089d31dc2cf6c
+# Source0-md5: 179f86928835da857c237b42f4b2df73
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -63,12 +62,10 @@ Source12:   99-%{name}-guest-agent.rules
 Source13:      %{name}-guest-agent.init
 Source14:      %{name}-guest-agent.logrotate
 Patch0:                %{name}-cflags.patch
-Patch1:                %{name}-whitelist.patch
 Patch2:                %{name}-user-execve.patch
 Patch3:                %{name}-xattr.patch
 Patch4:                libjpeg-boolean.patch
 Patch5:                x32.patch
-Patch6:                %{name}-vxhs.patch
 URL:           https://www.qemu.org/
 %{?with_opengl:BuildRequires:  Mesa-libgbm-devel}
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
@@ -108,7 +105,6 @@ BuildRequires:      libslirp-devel >= 4.0.0
 BuildRequires: libusb-devel >= 1.0.22
 BuildRequires: liburing-devel
 BuildRequires: libuuid-devel
-%{?with_vxhs:BuildRequires:    libvxhs-devel}
 BuildRequires: libxml2-devel >= 2.0
 %{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzfse-devel
@@ -164,9 +160,9 @@ Requires:   %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
 Requires:      %{name}-system-arm = %{version}-%{release}
+Requires:      %{name}-system-avr = %{version}-%{release}
 Requires:      %{name}-system-cris = %{version}-%{release}
 Requires:      %{name}-system-hppa = %{version}-%{release}
-Requires:      %{name}-system-lm32 = %{version}-%{release}
 Requires:      %{name}-system-m68k = %{version}-%{release}
 Requires:      %{name}-system-microblaze = %{version}-%{release}
 Requires:      %{name}-system-mips = %{version}-%{release}
@@ -181,7 +177,6 @@ Requires:   %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-sparc = %{version}-%{release}
 Requires:      %{name}-system-tricore = %{version}-%{release}
-Requires:      %{name}-system-unicore32 = %{version}-%{release}
 Requires:      %{name}-system-x86 = %{version}-%{release}
 Requires:      %{name}-system-xtensa = %{version}-%{release}
 Requires:      %{name}-user = %{version}-%{release}
@@ -261,6 +256,8 @@ Provides:   group(qemu)
 Provides:      user(qemu)
 Obsoletes:     qemu-kvm-common
 Obsoletes:     qemu-module-block-archipelago < 2.9.0
+Obsoletes:     qemu-system-lm32
+Obsoletes:     qemu-system-unicore32
 Conflicts:     qemu < 1.0-2
 
 %description common
@@ -291,19 +288,6 @@ images.
 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
 na obrazach dysków.
 
-%package ivshmem
-Summary:       Client and server for QEMU ivshmem device
-Summary(pl.UTF-8):     Klient i serwer dla urządzeia ivshmem QEMU
-Group:         Development/Tools
-
-%description ivshmem
-This package provides client and server tools for QEMU's ivshmem
-device.
-
-%description ivshmem -l pl.UTF-8
-Ten pakiet udostępnia działające z linii poleceń narzędzia dla
-urządzenia ivshmem QEMU.
-
 %package user
 Summary:       QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
@@ -402,6 +386,26 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z 32-bitowym procesorem ARM.
 
+%package system-avr
+Summary:       QEMU system emulator for AVR
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem AVR
+Group:         Applications/Emulators
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+Obsoletes:     qemu-kvm-system-avr
+
+%description system-avr
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for AVR.
+
+%description system-avr -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem AVR.
+
 %package system-cris
 Summary:       QEMU system emulator for CRIS
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem CRIS
@@ -441,26 +445,6 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem HP/PA (PA-RISC).
 
-%package system-lm32
-Summary:       QEMU system emulator for LM32
-Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem LM32
-Group:         Applications/Emulators
-Requires:      %{name}-common = %{version}-%{release}
-%systempkg_req
-Obsoletes:     qemu-kvm-system-lm32
-
-%description system-lm32
-QEMU is a generic and open source processor emulator which achieves a
-good emulation speed by using dynamic translation.
-
-This package provides the system emulator with LM32 CPU.
-
-%description system-lm32 -l pl.UTF-8
-QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
-dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
-
-Ten pakiet zawiera emulator systemu z procesorem LM32.
-
 %package system-m68k
 Summary:       QEMU system emulator for m68k
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem m68k
@@ -738,26 +722,6 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem TriCore.
 
-%package system-unicore32
-Summary:       QEMU system emulator for UniCore32
-Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem UniCore32
-Group:         Applications/Emulators
-Requires:      %{name}-common = %{version}-%{release}
-%systempkg_req
-Obsoletes:     qemu-kvm-system-unicore32
-
-%description system-unicore32
-QEMU is a generic and open source processor emulator which achieves a
-good emulation speed by using dynamic translation.
-
-This package provides the system emulator with UniCore32 CPU.
-
-%description system-unicore32 -l pl.UTF-8
-QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
-dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
-
-Ten pakiet zawiera emulator systemu z procesorem UniCore32.
-
 %package system-x86
 Summary:       QEMU system emulator for x86
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
@@ -952,12 +916,10 @@ Sondy systemtap/dtrace dla QEMU.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p0
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 %{__sed} -i '1s,/usr/bin/env python3,%{__python3},' scripts/qemu-trace-stap
 
@@ -997,8 +959,8 @@ build() {
 }
 
 build dynamic \
-       --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
-       --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
+       --extra-cflags="%{rpmcflags} %{rpmcppflags}" \
+       --extra-ldflags="%{rpmldflags} -Wl,-z,relro -Wl,-z,now" \
        --audio-drv-list="alsa%{?with_oss:,oss}%{?with_sdl:,sdl}%{?with_pulseaudio:,pa}" \
        --enable-attr \
        %{__enable_disable brlapi} \
@@ -1034,7 +996,6 @@ build dynamic \
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       %{__enable_disable vxhs} \
        %{!?with_vte:--disable-vte} \
        %{__enable_disable xen} \
        %{__enable_disable xkbcommon}
@@ -1062,7 +1023,6 @@ build static \
        --disable-system \
        --disable-tcmalloc \
        --disable-tools \
-       --disable-vxhs \
        --enable-user \
        --disable-xkbcommon \
        --disable-zstd \
@@ -1149,8 +1109,6 @@ done
 
 # cleanup Sphinx files
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/{interop,specs,system,tools,user}/{.buildinfo,objects.inv}
-# leave just HTML version
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{ga,qmp}-ref.txt
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -1197,13 +1155,13 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_bindir}/qemu-pr-helper
 %attr(755,root,root) %{_bindir}/qemu-storage-daemon
-%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_sbindir}/ksmctl
 %attr(755,root,root) %{_sbindir}/ksmtuned
 %attr(755,root,root) %{_libexecdir}/qemu-bridge-helper
 %if %{with virgl}
 %attr(755,root,root) %{_libexecdir}/vhost-user-gpu
 %endif
+%attr(755,root,root) %{_libexecdir}/virtfs-proxy-helper
 %attr(755,root,root) %{_libexecdir}/virtiofsd
 %dir %{_libdir}/%{name}
 # modules without too many external dependencies
@@ -1216,9 +1174,24 @@ fi
 %if %{with pulseaudio}
 %attr(755,root,root) %{_libdir}/%{name}/audio-pa.so
 %endif
+%if %{with spice}
+%attr(755,root,root) %{_libdir}/%{name}/audio-spice.so
+%attr(755,root,root) %{_libdir}/%{name}/chardev-spice.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-qxl.so
+%endif
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-virtio-gpu-pci.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-virtio-gpu.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-virtio-vga.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-usb-redirect.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-usb-smartcard.so
 %attr(755,root,root) %{_libdir}/%{name}/ui-curses.so
+%attr(755,root,root) %{_libdir}/%{name}/ui-egl-headless.so
+%if %{with opengl}
+%attr(755,root,root) %{_libdir}/%{name}/ui-opengl.so
+%endif
 %if %{with spice}
 %attr(755,root,root) %{_libdir}/%{name}/ui-spice-app.so
+%attr(755,root,root) %{_libdir}/%{name}/ui-spice-core.so
 %endif
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/firmware
@@ -1240,6 +1213,7 @@ fi
 %{_mandir}/man7/qemu-cpu-models.7*
 %{_mandir}/man7/qemu-qmp-ref.7*
 %{_mandir}/man8/qemu-nbd.8*
+%{_mandir}/man8/qemu-pr-helper.8*
 %{_docdir}/qemu
 
 %files img
@@ -1247,11 +1221,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-img
 %{_mandir}/man1/qemu-img.1*
 
-%files ivshmem
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/ivshmem-client
-%attr(755,root,root) %{_bindir}/ivshmem-server
-
 %files user
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-aarch64
@@ -1276,7 +1245,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-or1k
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
-%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
 %attr(755,root,root) %{_bindir}/qemu-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-riscv32
 %attr(755,root,root) %{_bindir}/qemu-riscv64
@@ -1286,7 +1254,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
-%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 %attr(755,root,root) %{_bindir}/qemu-xtensa
 %attr(755,root,root) %{_bindir}/qemu-xtensaeb
@@ -1315,7 +1282,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-or1k-static
 %attr(755,root,root) %{_bindir}/qemu-ppc-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64-static
-%attr(755,root,root) %{_bindir}/qemu-ppc64abi32-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64le-static
 %attr(755,root,root) %{_bindir}/qemu-riscv32-static
 %attr(755,root,root) %{_bindir}/qemu-riscv64-static
@@ -1325,7 +1291,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc-static
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus-static
 %attr(755,root,root) %{_bindir}/qemu-sparc64-static
-%attr(755,root,root) %{_bindir}/qemu-tilegx-static
 %attr(755,root,root) %{_bindir}/qemu-x86_64-static
 %attr(755,root,root) %{_bindir}/qemu-xtensa-static
 %attr(755,root,root) %{_bindir}/qemu-xtensaeb-static
@@ -1349,6 +1314,11 @@ fi
 %{_datadir}/%{name}/edk2-arm-code.fd
 %{_datadir}/%{name}/edk2-arm-vars.fd
 %{_datadir}/%{name}/firmware/60-edk2-arm.json
+%{_datadir}/%{name}/npcm7xx_bootrom.bin
+
+%files system-avr
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-avr
 
 %files system-cris
 %defattr(644,root,root,755)
@@ -1359,10 +1329,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-system-hppa
 %{_datadir}/%{name}/hppa-firmware.img
 
-%files system-lm32
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/qemu-system-lm32
-
 %files system-m68k
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-m68k
@@ -1409,14 +1375,14 @@ fi
 %files system-riscv32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-riscv32
-%{_datadir}/%{name}/opensbi-riscv32-sifive_u-fw_jump.bin
-%{_datadir}/%{name}/opensbi-riscv32-virt-fw_jump.bin
+%{_datadir}/%{name}/opensbi-riscv32-generic-fw_dynamic.bin
+%{_datadir}/%{name}/opensbi-riscv32-generic-fw_dynamic.elf
 
 %files system-riscv64
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-riscv64
-%{_datadir}/%{name}/opensbi-riscv64-sifive_u-fw_jump.bin
-%{_datadir}/%{name}/opensbi-riscv64-virt-fw_jump.bin
+%{_datadir}/%{name}/opensbi-riscv64-generic-fw_dynamic.bin
+%{_datadir}/%{name}/opensbi-riscv64-generic-fw_dynamic.elf
 
 %files system-rx
 %defattr(644,root,root,755)
@@ -1446,10 +1412,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-tricore
 
-%files system-unicore32
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/qemu-system-unicore32
-
 %files system-x86
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
@@ -1485,6 +1447,7 @@ fi
 %{_datadir}/%{name}/pxe-pcnet.rom
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/qboot.rom
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/vgabios.bin
 %{_datadir}/%{name}/vgabios-ati.bin