]> TLD Linux GIT Repositories - packages/rc-scripts.git/commitdiff
- fix "intteger expression expected" error when run with bash
authorMarcin Krol <hawk@tld-linux.org>
Sun, 11 May 2014 15:09:37 +0000 (15:09 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 11 May 2014 15:09:37 +0000 (15:09 +0000)
rc-scripts-sh_fixes.patch [new file with mode: 0644]
rc-scripts.spec

diff --git a/rc-scripts-sh_fixes.patch b/rc-scripts-sh_fixes.patch
new file mode 100644 (file)
index 0000000..4827cde
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur rc-scripts-0.4.11.orig/rc.d/rc.sysinit rc-scripts-0.4.11/rc.d/rc.sysinit
+--- rc-scripts-0.4.11.orig/rc.d/rc.sysinit     2014-03-02 10:02:29.000000000 +0000
++++ rc-scripts-0.4.11/rc.d/rc.sysinit  2014-05-11 15:06:33.166000019 +0000
+@@ -927,7 +927,7 @@
+               . /etc/rc.d/rc.serial
+       fi
+-      if [ -n "$PANIC_REBOOT_TIME" -a "$PANIC_REBOOT_TIME" -gt "0" -a -f /proc/sys/kernel/panic ]; then
++      if [ -n "$PANIC_REBOOT_TIME" ] && [ "$PANIC_REBOOT_TIME" -gt "0" ] && [ -f /proc/sys/kernel/panic ]; then
+               show 'Setting %s seconds for kernel reboot after panic' "$PANIC_REBOOT_TIME"; busy
+               # DEPRECATED: use /etc/sysctl.conf or kernel commandline instead
+               if sysctl -q -w kernel.panic=$PANIC_REBOOT_TIME; then ok; else fail; fi
index 798d12381b39793a12d03144d07792bf1f3e158d..c506940df3e0522aa61caaf18059568f209022e6 100644 (file)
@@ -1,5 +1,5 @@
 # Conditional build:
-%bcond_without static  # link binaries with glib dynamically
+%bcond_without static          # link binaries with glib dynamically
 
 Summary:       inittab and /etc/rc.d scripts
 Summary(de.UTF-8):     inittab und /etc/rc.d Scripts
@@ -8,7 +8,7 @@ Summary(pl.UTF-8):      inittab i skrypty startowe z katalogu /etc/rc.d
 Summary(tr.UTF-8):     inittab ve /etc/rc.d dosyaları
 Name:          rc-scripts
 Version:       0.4.11
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -19,6 +19,7 @@ Source3:      %{name}.tmpfiles
 Patch100:      %{name}-tld.patch
 Patch101:      %{name}-no_tmpfs_root_fsck.patch
 Patch102:      %{name}-selinuxfs_mount.patch
+Patch103:      %{name}-sh_fixes.patch
 URL:           http://svn.pld-linux.org/trac/svn/wiki/packages/rc-scripts
 BuildRequires: autoconf
 BuildRequires: automake
@@ -113,6 +114,7 @@ programcıklar içerir.
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
+%patch103 -p1
 
 # hack, currently this results in errno@@GLIBC_PRIVATE symbol in ppp-watch:
 #GLIB_LIBS="-Wl,-static `$PKG_CONFIG --libs --static glib-2.0` -Wl,-Bdynamic"