]> TLD Linux GIT Repositories - packages/rpm-build-tools.git/blobdiff - adapter.awk
- PLD merge... hope nothing will got broken
[packages/rpm-build-tools.git] / adapter.awk
index fad5240b1b6804fd8c216ceb4e55f0063d55e489..adbe5ae4fe44e7f104b1d12795170621974f10f7 100644 (file)
@@ -2,7 +2,7 @@
 #
 # Adapter adapts .spec files for PLD Linux.
 #
-# Copyright (C) 1999-2012 PLD-Team <feedback@pld-linux.org>
+# Copyright (C) 1999-2013 PLD-Team <feedback@pld-linux.org>
 # Authors:
 #      Michał Kuratczyk <kura@pld.org.pl>
 #      Sebastian Zagrodzki <s.zagrodzki@mimuw.edu.pl>
@@ -12,7 +12,7 @@
 #      Jakub Bogusz <qboosh@pld-linux.org>
 #      Elan Ruusamäe <glen@pld-linux.org>
 #
-# See cvs log adapter{,.awk} for list of contributors
+# See git log adapter{,.awk} for list of contributors
 #
 # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
 
@@ -33,16 +33,14 @@ BEGIN {
        RPM_SECTIONS = "package|build|changelog|clean|description|install|post|posttrans|postun|pre|prep|pretrans|preun|triggerin|triggerpostun|triggerun|verifyscript|check"
        SECTIONS = "^%(" RPM_SECTIONS ")"
 
-       RCSID = "$Id$"
-       rev = RCSID # TODO: parse from RCSID
-       VERSION = "0.35/" rev
+       rev = "1.514"
+       VERSION = "0.36/" rev
 
        PREAMBLE_TAGS = "(R|BR|Summary|Name|Version|Release|Epoch|License|Group|URL|BuildArch|BuildRoot|Obsoletes|Conflicts|Provides|ExclusiveArch|ExcludeArch|Pre[Rr]eq|(Build)?Requires|Suggests|Auto(Req|Prov))"
 
        usedigest = 0   # Enable to switch to rpm 4.4.6+ md5 digests
 
        preamble = 1    # Is it part of preamble? Default - yes
-       boc = 4                 # Beginning of %changelog
        bod = 0                 # Beginning of %description
        tw = 70                 # Descriptions width
 
@@ -60,25 +58,9 @@ BEGIN {
        import_rpm_macros()
 
        packages_dir = topdir
-       groups_file = packages_dir "/rpm.groups"
+       groups_file = packages_dir "/../rpm-build-tools/rpm.groups"
 
-       system("cd "packages_dir"; [ -f rpm.groups ] || cvs up rpm.groups > /dev/null")
        system("[ -d ../PLD-doc ] && cd ../PLD-doc && ([ -f BuildRequires.txt ] || cvs up BuildRequires.txt >/dev/null)");
-
-       # Temporary file for changelog section
-       changelog_file = mktemp("adapter.changelogXXXXXX")
-}
-
-# There should be a comment with CVS keywords on the first line of file.
-FNR == 1 {
-       if (!/^# \$[R]evision: .* \$, \$[D]ate: .* \$$/) {      # If this line is already OK?
-               print "# $" "Revision:$, " "$" "Date:$" # No
-               if ( /^#.*([rR]evision|[dD]ate)/ ) # There was something similar, but incorrect
-                        next
-       } else {
-               print $0                                # Yes
-               next            # It is enough for first line
-       }
 }
 
 # If the latest line matched /%files/
@@ -166,8 +148,9 @@ function b_makekey(a, b,    s) {
        if ($2 == "_applnkdir") {
                next
        }
+
+       # FIXME: this section will likely never match after cvs->git migration
        if ($2 == "date") {
-               date = 1
                if (did_files == 0) {
                        print "%files"
                        print ""
@@ -427,7 +410,7 @@ function b_makekey(a, b,    s) {
        if (/CC=%{__cc} /) {
                sub("CC=%{__cc}", "CC=\"%{__cc}\"")
        }
-       
+
        # use PLD Linux macros
        $0 = fixedsub("glib-gettextize --copy --force","%{__glib_gettextize}", $0);
        $0 = fixedsub("intltoolize --copy --force", "%{__intltoolize}", $0);
@@ -539,65 +522,6 @@ function b_makekey(a, b,   s) {
        }
 }
 
-##############
-# %changelog #
-##############
-/^%changelog/, (!/^%changelog/ && $0 ~ SECTIONS) {
-       preamble = 0
-       has_changelog = 1
-       skip = 0
-       # There should be some CVS keywords on the first line of %changelog.
-       if (boc == 3) {
-               if ($0 !~ _cvsmailfeedback) {
-                       print "* %{date} " _cvsmailfeedback > changelog_file
-               } else {
-                       skip = 1
-               }
-               boc = 2
-       }
-       if (boc == 2 && !skip) {
-               if (!/All persons listed below/) {
-                       printf "All persons listed below can be reached at " > changelog_file
-                       print "<cvs_login>" _cvsmaildomain "\n" > changelog_file
-               } else {
-                       skip = 1
-               }
-               boc = 1
-       }
-       if (boc == 1 && !skip) {
-               if (!/^$/) {
-                       if (!/\$.*Log:.*\$/) {
-                               print "$" "Log:$" > changelog_file
-                       }
-                       boc = 0
-               }
-       }
-       # Define date macro.
-       if (boc == 4) {
-               if (date == 0) {
-                       printf "%%define date\t%%(echo `LC_ALL=\"C\"" > changelog_file
-                       print " date +\"%a %b %d %Y\"`)" > changelog_file
-                       date = 1
-               }
-               boc = 3
-       }
-
-       sub(/[ \t]+$/, "");
-       if (!/^%[a-z]+$/ || /changelog/) {
-               # stop changelog if "real" changelog starts
-               if (boc == 0 && /^\* /) {
-                       boc = -1
-               }
-               if (boc == -1) {
-                       next;
-               }
-               print > changelog_file
-       } else {
-               print
-       }
-       next
-}
-
 ###########
 # SCRIPTS #
 ###########
@@ -708,22 +632,31 @@ preamble == 1 {
                release = "0." fixedsub(".%{disttag}.at", "", $4)
        }
 
+       # deprecated. currently just resolves to name in $2
+       if (/^%pyrequires_eq.+/) {
+               $1 = "Requires:";
+       }
+
+       # F<16 had requires(hint)
+       if (/^Requires\(hint\):/) {
+               $1 = "Suggests:";
+       }
+
        field = tolower($1)
        if (field ~ /summary:/ && !/etc\.$/ && !/Inc\.$/) {
                sub(/\.$/, "", $0);
        }
-       if (field ~ /group(\([^)]+\)):/)
+       if (field ~ /group(\([^)]+\)):/) {
                next
-       if (field ~ /group:/) {
+       }
+
+       if (field == "group:") {
                format_preamble()
                group = $0;
                sub(/^[^ \t]*[ \t]*/, "", group);
                group = replace_groupnames(group);
                $0 = "Group:\t\t" group
 
-               if (group ~ /^X11/ && x11 == 0) # Is it X11 application?
-                       x11 = 1
-
                byl_plik_z_groupmi = 0
                byl_opis_grupy = 0
                while ((getline linia_grup < groups_file) > 0) {
@@ -743,7 +676,7 @@ preamble == 1 {
                did_groups = 1
        }
 
-       if (field ~ /prereq:/) {
+       if (field == "prereq:") {
                sub(/Pre[Rr]eq:/, "Requires:", $1);
        }
 
@@ -754,7 +687,7 @@ preamble == 1 {
        }
 
        # BR: tar (and others) is to common (rpm-build requires it)
-       if (field ~ /^buildrequires:/) {
+       if (field == "buildrequires:") {
                l = substr($0, index($0, $2));
                if (l == "awk" ||
                        l == "binutils" ||
@@ -776,11 +709,11 @@ preamble == 1 {
                        next
                }
 
-               replace_requires();
+               replace_requires(field);
        }
 
-       if (field ~ /^requires:/ || field ~ /^requires\(/) {
-               replace_requires();
+       if (field == "requires:" || field ~ /^requires\(/) {
+               replace_requires(field);
        }
 
 
@@ -818,7 +751,13 @@ preamble == 1 {
                if (l == "Python Software Foundation License") {
                        l = "PSF"
                }
-               if (l == "Apache License 2.0" || l == "Apache 2.0" || l == "Apache License Version 2.0" || l == "Apache License, Version 2.0" || l == "Apache Software License v2") {
+               if (l == "Apache License 2.0" || \
+                          l == "Apache 2.0" || \
+                          l == "Apache License Version 2.0" || \
+                          l == "Apache License, Version 2.0" || \
+                          l == "Apache Software License v2" || \
+                          l == "ASL 2.0" \
+                       ) {
                        l = "Apache v2.0"
                }
                if (l == "Apache Group License" || l == "Apache Software License" || l == "Apache License") {
@@ -1082,36 +1021,11 @@ END {
                }
        }
 
-       close(changelog_file)
-       while ((getline < changelog_file) > 0)
-               print
-       system("rm -f " changelog_file)
-
        if (did_clean == 0) {
                print ""
                print "%clean"
                print "rm -rf $RPM_BUILD_ROOT"
        }
-
-       if (date == 0) {
-               print ""
-               print "%define date\t%(echo `LC_ALL=\"C\" date +\"%a %b %d %Y\"`)"
-       }
-
-       if (has_changelog == 0) {
-               print "%changelog"
-       }
-
-       if (boc > 2) {
-               print "* %{date} PLD Team <feedback@pld-linux.org>"
-       }
-       if (boc > 1) {
-               printf "All persons listed below can be reached at "
-               print "<cvs_login>@pld-linux.org\n"
-       }
-       if (boc > 0) {
-               print "$" "Log:$"
-       }
 }
 
 # substitutes fixed strings (not regexps)
@@ -1160,6 +1074,7 @@ function use_macros()
        }
 
        sub("%{_defaultdocdir}", "%{_docdir}");
+       sub("%{_datadir}/doc", "%{_docdir}");
        sub("%{_bindir}/perl", "%{__perl}");
        sub("%{_bindir}/python", "%{__python}");
 
@@ -1171,7 +1086,7 @@ function use_macros()
        gsub(perl_vendorlib, "%{perl_vendorlib}")
        gsub(perl_vendorarch, "%{perl_vendorarch}")
        gsub(perl_sitelib, "%{perl_sitelib}")
-       
+
        gsub(py_sitescriptdir, "%{py_sitescriptdir}")
        gsub(py_sitedir, "%{py_sitedir}")
        gsub(py_scriptdir, "%{py_scriptdir}")
@@ -1179,14 +1094,23 @@ function use_macros()
        gsub(py3_sitescriptdir, "%{py3_sitescriptdir}")
        gsub(py3_sitedir, "%{py3_sitedir}")
        gsub(py3_scriptdir, "%{py3_scriptdir}")
+       gsub("%{python3_sitelib}", "%{py3_sitescriptdir}")
+       gsub("%{python3_version}", "%{py3_ver}")
 
        gsub(ruby_archdir, "%{ruby_archdir}")
-       gsub(ruby_ridir, "%{ruby_ridir}")
-       gsub(ruby_rubylibdir, "%{ruby_rubylibdir}")
+       gsub(ruby_libdir, "%{ruby_libdir}")
+
        gsub(ruby_sitearchdir, "%{ruby_sitearchdir}")
        gsub(ruby_sitelibdir, "%{ruby_sitelibdir}")
+       gsub(ruby_sitedir, "%{ruby_sitedir}")
+       gsub(ruby_vendorarchdir, "%{ruby_vendorarchdir}")
+       gsub(ruby_vendorlibdir, "%{ruby_vendorlibdir}")
+       gsub(ruby_vendordir, "%{ruby_vendordir}")
+       gsub(ruby_rubylibdir, "%{ruby_rubylibdir}") # deprecated
        gsub(ruby_rdocdir, "%{ruby_rdocdir}")
+       gsub(ruby_ridir, "%{ruby_ridir}")
 
+       gsub("%{_unitdir}", "%{systemdunitdir}")
        gsub(systemdunitdir, "%{systemdunitdir}")
        gsub(systemdtmpfilesdir, "%{systemdtmpfilesdir}")
 
@@ -1293,6 +1217,8 @@ function use_macros()
                        continue;
                if ($c ~ sysconfdir "/apm")
                        continue;
+               if ($c ~ sysconfdir "/modules-load\.d")
+                       continue;
                gsub(sysconfdir, "%{_sysconfdir}", $c)
        }
 
@@ -1910,11 +1836,6 @@ function import_rpm_macros(  v) {
                exit(rc = 1);
        }
 
-       # get cvsaddress for changelog section
-       # using rpm macros as too lazy to add ~/.adapterrc parsing support.
-       _cvsmaildomain = ENVIRON["_cvsmaildomain"]
-       _cvsmailfeedback = ENVIRON["_cvsmailfeedback"]
-
        prefix = ENVIRON["_prefix"]
        bindir = ENVIRON["_bindir"]
        sbindir = ENVIRON["_sbindir"]
@@ -1953,11 +1874,16 @@ function import_rpm_macros(  v) {
        py3_ver = ENVIRON["py3_ver"]
 
        ruby_archdir = ENVIRON["ruby_archdir"]
-       ruby_ridir = ENVIRON["ruby_ridir"]
-       ruby_rubylibdir = ENVIRON["ruby_rubylibdir"]
+       ruby_libdir = ENVIRON["ruby_libdir"]
+       ruby_sitedir = ENVIRON["ruby_sitedir"]
        ruby_sitearchdir = ENVIRON["ruby_sitearchdir"]
        ruby_sitelibdir = ENVIRON["ruby_sitelibdir"]
+       ruby_vendordir = ENVIRON["ruby_vendordir"]
+       ruby_vendorarchdir = ENVIRON["ruby_vendorarchdir"]
+       ruby_vendorlibdir = ENVIRON["ruby_vendorlibdir"]
+       ruby_rubylibdir = ENVIRON["ruby_rubylibdir"] # deprecated
        ruby_rdocdir = ENVIRON["ruby_rdocdir"]
+       ruby_ridir = ENVIRON["ruby_ridir"]
 
        php_pear_dir = ENVIRON["php_pear_dir"]
        php_data_dir = ENVIRON["php_data_dir"]
@@ -1968,27 +1894,29 @@ function import_rpm_macros(  v) {
 }
 
 # php virtual deps as discussed in devel-en
-function replace_php_virtual_deps() {
+function replace_php_virtual_deps(field) {
        pkg = $2
 #      if (pkg == "php-program") {
 #              $0 = $1 "\t/usr/bin/php"
 #              return
 #      }
 
-#      if (pkg ~ /^php-[a-z]/ && pkg !~ /^php-(pear|common|cli|devel|fcgi|cgi|dirs|program|pecl-)/) {
-#              sub(/^php-/, "php(", pkg);
-#              sub(/$/, ") # verify this correctness -- it may be wanted to use specific not virtual dep", pkg);
-#              $2 = pkg
-#      }
+       if (field == "requires:") {
+               if (pkg ~ /^php-(bcmath|bz2|calendar|ctype|curl|dba|date|dom|enchant|exif|fileinfo|filter|fpm|ftp|gd|gettext|gmp|hash|iconv|imap|interbase|intl|json|ldap|mbstring|mcrypt|mssql|mysql|mysqli|odbc|openssl|pcntl|pcre|pdo|pdo-dblib|pdo-firebird|pdo-mysql|pdo-odbc|pdo-pgsql|pdo-sqlite|pgsql|phar|posix|pspell|readline|recode|session|shmop|simplexml|snmp|soap|sockets|spl|sqlite|sqlite3|sybase-ct|sysvmsg|sysvsem|sysvshm|tidy|tokenizer|wddx|xml|xmlreader|xmlrpc|xmlwriter|xsl|zip|zlib)/) {
+                       sub(/^php-/, "php(", pkg);
+                       sub(/$/, ")", pkg);
+                       $2 = pkg
+               }
+       }
 
-       if (pkg ~/^php$/) {
-               $2 = "webserver(php)";
+       if (pkg == "php" || pkg == "php-common") {
+               $2 = "php(core)";
                if ($4 ~ /^[0-9]:/) {
                        $4 = substr($4, 3);
                }
        }
 
-       if (pkg ~/^php4$/) {
+       if (pkg == "php4") {
                $2 = "webserver(php)";
                if ($4 ~ /^[0-9]:/) {
                        $4 = substr($4, 3);
@@ -1996,6 +1924,7 @@ function replace_php_virtual_deps() {
        }
 }
 
+# {{{ replace_groupnames(group)
 function replace_groupnames(group) {
        group = replace(group, "Amusements/Games", "Applications/Games");
        group = replace(group, "Amusements/Games/Strategy/Real Time", "X11/Applications/Games/Strategy");
@@ -2035,6 +1964,7 @@ function replace_groupnames(group) {
        group = replace(group, "Productivity/Databases/Servers", "Applications/Databases");
        group = replace(group, "Productivity/Multimedia/Other", "X11/Applications/Multimedia");
        group = replace(group, "Productivity/Networking/Web/Servers", "Networking/Daemons/HTTP");;
+       group = replace(group, "Python/Libraries", "Libraries/Python");
        group = replace(group, "Shells", "Applications/Shells");
        group = replace(group, "System Environment/Base", "Base");
        group = replace(group, "System Environment/Daemons", "Daemons");
@@ -2065,8 +1995,55 @@ function replace_groupnames(group) {
 
        return group;
 }
+# }}}
 
-function replace_requires() {
+# {{{ replace_pkgconfig(pkg)
+function replace_pkgconfig(pkg,    cmd, path, n, i, line) {
+       n = split("/usr/lib64/pkgconfig /usr/lib/pkgconfig /usr/share/pkgconfig", path, / /);
+       for (i = 1; i <= n; i++) {
+               cmd = "rpm -qf --qf '%{N}' " path[i] "/" pkg ".pc";
+               # Getline returns 0 on end-of-file, -1 on error, otherwise 1.
+               if ((cmd | getline line) <= 0) {
+                       continue;
+               }
+
+               if (line !~ /No such file or directory/) {
+                       # @modifies global $2
+                       $2 = line;
+                       return
+               }
+       }
+}
+# }}}
+
+# {{{ replace_pythonegg(pkg)
+function replace_pythonegg(pkg,    cmd, line) {
+       cmd = "rpm -q --qf '%{N}' --whatprovides 'pythonegg(" pkg ")'";
+       # Getline returns 0 on end-of-file, -1 on error, otherwise 1.
+       if ((cmd | getline line) <= 0) {
+               return;
+       }
+
+       if (line !~ /no package provides/) {
+               # @modifies global $2
+               $2 = line;
+               return;
+       }
+}
+# }}}
+
+function replace_requires(field,   pkg) {
+       # pkg-config -> package names
+       if (match($2, /pkgconfig\(([^)]+)\)/)) {
+               pkg = substr($2, RSTART + 10, RLENGTH - 11);
+               replace_pkgconfig(pkg);
+       }
+
+       # pythonegg -> package names
+       if (match($2, /pythonegg\(([^)]+)\)/)) {
+               pkg = substr($2, RSTART + 10, RLENGTH - 11);
+               replace_pythonegg(pkg);
+       }
 
        sub(/^python-setuptools-devel$/, "python-distribute", $2);
        sub(/^gcc-g77/, "gcc-fortran", $2);
@@ -2077,7 +2054,7 @@ function replace_requires() {
        # bad package.xml, see http://pear.php.net/bugs/bug.php?id=17779
        sub(/^php-php-gtk/, "php-gtk2", $2);
 
-       # jpackages / fedora java packages
+       # {{{ jpackages / fedora java packages
        sub(/^antlr3$/, "java-antlr3", $2);
        sub(/^aqute-bnd$/, "java-bnd", $2);
        sub(/^avalon-framework$/, "java-avalon-framework", $2);
@@ -2152,17 +2129,24 @@ function replace_requires() {
        sub(/^xml-commons-resolver$/, "java-xml-commons-resolver", $2);
        sub(/^xmldb-api$/, "java-xmldb", $2);
        sub(/^xmldb-api-sdk$/, "java-xmldb-sdk", $2);
+       # }}}
 
-       # fedora / redhat
+       # {{{ fedora / redhat
        sub(/^Django$/, "python-django", $2);
        sub(/^GitPython$/, "python-git", $2);
+       sub(/^MySQL-python$/, "python-MySQLdb", $2);
+       sub(/^NetworkManager-glib-devel$/, "NetworkManager-devel", $2);
        sub(/^PyQt4-devel$/, "python-PyQt4-devel", $2);
        sub(/^PyQwt-devel$/, "python-PyQwt-devel", $2);
+       sub(/^PyYAML$/, "python-PyYAML", $2);
        sub(/^ccid$/, "pcsc-driver-ccid", $2);
        sub(/^chkconfig$/, "/sbin/chkconfig", $2);
        sub(/^db4-devel$/, "db-devel", $2);
        sub(/^dbus-python$/, "python-dbus", $2);
        sub(/^desktop-notification-daemon$/, "dbus(org.freedesktop.Notifications)", $2);
+       sub(/^device-mapper-multipath$/, "multipath-tools", $2);
+       sub(/^django-tagging$/, "python-django_tagging", $2);
+       sub(/^elfutils-libelf-devel$/, "elfutils-devel", $2);
        sub(/^file-devel$/, "libmagic-devel", $2);
        sub(/^freetype2-devel$/, "freetype-devel", $2);
        sub(/^fuse-devel$/, "libfuse-devel", $2);
@@ -2176,6 +2160,7 @@ function replace_requires() {
        sub(/^gtk-sharp2-devel$/, "dotnet-gtk-sharp2-devel", $2);
        sub(/^gtk2$/, "gtk+2", $2);
        sub(/^gtk2-devel$/, "gtk+2-devel", $2);
+       sub(/^gtk3$/, "gtk+3", $2);
        sub(/^gtk3-devel$/, "gtk+3-devel", $2);
        sub(/^initscripts$/, "rc-scripts", $2);
        sub(/^iproute$/, "iproute2", $2);
@@ -2193,6 +2178,10 @@ function replace_requires() {
        sub(/^libXinerama-devel$/, "xorg-lib-libXinerama-devel", $2);
        sub(/^libXrandr-devel$/, "xorg-lib-libXrandr-devel", $2);
        sub(/^libXrender-devel$/, "xorg-lib-libXrender-devel", $2);
+       sub(/^libXt-devel$/, "xorg-lib-libXt-devel", $2);
+       sub(/^libXtst-devel$/, "xorg-lib-libXtst-devel", $2);
+       sub(/^libXv-devel$/, "xorg-lib-libXv-devel", $2);
+       sub(/^libXxf86misc-devel$/, "xorg-lib-libXxf86misc-devel", $2);
        sub(/^libXxf86vm-devel$/, "xorg-lib-libXxf86vm-devel", $2);
        sub(/^libacl-devel$/, "acl-devel", $2);
        sub(/^libcurl-devel$/, "curl-devel", $2);
@@ -2205,6 +2194,8 @@ function replace_requires() {
        sub(/^libtevent$/, "tevent", $2);
        sub(/^libtevent-devel$/, "tevent-devel", $2);
        sub(/^libusb1-devel$/, "libusb-devel", $2);
+       sub(/^libuser-python$/, "python-libuser", $2);
+       sub(/^libxkbfile-devel$/, "xorg-lib-libxkbfile", $2);
        sub(/^mod_wsgi$/, "apache-mod_wsgi", $2);
        sub(/^newt-python$/, "python-snack", $2);
        sub(/^notify-python$/, "python-pynotify", $2);
@@ -2214,13 +2205,18 @@ function replace_requires() {
        sub(/^pycairo$/, "python-pycairo", $2);
        sub(/^pyflakes$/, "python-pyflakes", $2);
        sub(/^pygobject2$/, "python-pygobject", $2);
+       sub(/^pygobject3$/, "python-pygobject3", $2);
        sub(/^pygobject3-devel$/, "python-pygobject3-common-devel", $2);
        sub(/^pygtk2$/, "python-pygtk", $2);
        sub(/^pygtk2-devel$/, "python-pygtk-devel", $2);
        sub(/^pygtk2-libglade$/, "python-pygtk-glade", $2);
+       sub(/^pykickstart$/, "python-pykickstart", $2);
+       sub(/^pyparsing$/, "python-pyparsing", $2);
+       sub(/^pyparted$/, "python-parted", $2);
        sub(/^pysvn$/, "python-pysvn", $2);
        sub(/^pytalloc$/, "python-talloc", $2);
        sub(/^pytalloc-devel$/, "python-talloc-devel", $2);
+       sub(/^pytest$/, "python-pytest", $2);
        sub(/^python-cups$/, "python-pycups", $2);
        sub(/^python-enchant$/, "python-pyenchant", $2);
        sub(/^python-imaging$/, "python-PIL", $2);
@@ -2233,6 +2229,7 @@ function replace_requires() {
        sub(/^python-twisted-names$/, "python-TwistedNames", $2);
        sub(/^python2-devel$/, "python-devel", $2);
        sub(/^pytz$/, "python-pytz", $2);
+       sub(/^pyxdg$/, "python-pyxdg", $2);
        sub(/^qt4-devel$/, "qt4-build", $2);
        sub(/^qt4-webkit-devel$/, "QtWebKit-devel", $2);
        sub(/^qtlockedfile-devel$/, "QtLockedFile-devel", $2);
@@ -2245,8 +2242,9 @@ function replace_requires() {
        sub(/^webkitgtk3-devel$/, "gtk-webkit3-devel", $2);
        sub(/^xapian-bindings-python$/, "python-xapian", $2);
        sub(/^xorg-x11-server-sdk$/, "xorg-xserver-server-devel", $2);
+       # }}}
 
-       # mandriva
+       # {{{ mandriva
        sub(/^python-gobject-devel$/, "python-pygobject-devel", $2);
        sub(/^python-pyrex$/, "python-Pyrex", $2);
        sub(/^webkitgtk-devel$/, "gtk-webkit-devel", $2);
@@ -2254,8 +2252,9 @@ function replace_requires() {
        sub(/^python-webkitgtk$/, "python-pywebkitgtk", $2);
        sub(/^pygtk2.0$/, "python-pygtk-gtk", $2);
        sub(/^gnome-python-gconf$/, "python-gnome-gconf", $2);
+       # }}}
 
-       # debian / ubuntu
+       # {{{ debian / ubuntu
        sub(/^blkid-dev$/, "libblkid-devel", $2);
        sub(/^ext2fs-dev$/, "e2fsprogs-devel", $2);
        sub(/^libao-dev$/, "libao-devel", $2);
@@ -2292,8 +2291,9 @@ function replace_requires() {
        sub(/^tcp_wrappers-devel$/, "libwrap-devel", $2);
        sub(/^vala-tools$/, "vala", $2);
        sub(/^vala-devel$/, "vala", $2);
+       # }}}
 
-       # altlinux
+       # {{{ altlinux
        sub(/^libatk-devel$/, "atk-devel", $2);
        sub(/^libgit-devel$/, "git-core-devel", $2);
        sub(/^libgtk\+2-devel$/, "gtk+2-devel", $2);
@@ -2303,8 +2303,9 @@ function replace_requires() {
        sub(/^libpcre-devel$/, "pcre-devel", $2);
        sub(/^libpopt-devel$/, "popt-devel", $2);
        sub(/^libssl-devel$/, "openssl-devel", $2);
+       # }}}
 
-       # suse
+       # {{{ suse/opensuse
        sub(/^alsa-devel$/, "alsa-lib-devel", $2);
        sub(/^gtk-sharp2$/, "dotnet-gtk-sharp2", $2);
        sub(/^gtkmm2-devel$/, "gtkmm-devel", $2);
@@ -2313,9 +2314,14 @@ function replace_requires() {
        sub(/^libopenssl-devel$/, "openssl-devel", $2);
        sub(/^libpulse-devel$/, "pulseaudio-devel", $2);
        sub(/^monodoc-core$/, "mono-monodoc", $2);
+       sub(/^python-cairo$/, "python-pycairo", $2);
+       sub(/^python-gobject$/, "python-pygobject", $2);
+       sub(/^python-gstreamer-0_10$/, "python-gstreamer", $2);
        sub(/^python-gtk$/, "python-pygtk-gtk", $2);
+       sub(/^python-xdg$/, "python-pyxdg", $2);
+       # }}}
 
-       replace_php_virtual_deps()
+       replace_php_virtual_deps(field)
 }
 
-# vim:ts=4:sw=4
+# vim:ts=4:sw=4 fdm=marker