]> TLD Linux GIT Repositories - packages/rpm-build-tools.git/blobdiff - builder.sh
- drop attic distfiles support, attic no longer exists
[packages/rpm-build-tools.git] / builder.sh
index 99c11d96c95df60d74137660831e6ddddf96d2d2..056cdf4f660b79b2bce31762258dbf95362d19d2 100755 (executable)
@@ -124,17 +124,15 @@ PKGREVS_URL="http://pkgrevs.tld-linux.org"
 
 # TLD git/df config
 TLD_GIT_SERVER="git://git.tld-linux.org"
-TLD_GIT_PUSH="git@git.tld-linux.org"
+TLD_GIT_PUSH="git@git.tld-linux.org:7272"
 TLD_PACKAGES_DIR="packages"
 TLD_DISTFILES_SERVER="://df.tld-linux.org"
-TLD_ATTICDISTFILES_SERVER=""
 
 # PLD git/df config
 PLD_GIT_SERVER="git://git.pld-linux.org"
 PLD_GIT_PUSH="git@git.pld-linux.org"
 PLD_PACKAGES_DIR="packages"
 PLD_DISTFILES_SERVER="://distfiles.pld-linux.org"
-PLD_ATTICDISTFILES_SERVER="://attic-distfiles.pld-linux.org"
 
 CVS_FORCE=""
 CVSIGNORE_DF="yes"
@@ -151,7 +149,6 @@ NEW_REPO=""
 RES_FILE=""
 
 DISTFILES_SERVER=${TLD_DISTFILES_SERVER}
-ATTICDISTFILES_SERVER=${TLD_ATTICDISTFILES_SERVER}
 
 DEF_NICE_LEVEL=19
 SCHEDTOOL="auto"
@@ -320,7 +317,7 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 [{-Tp|--tag-prefix} <prefix>] [{-tt|--test-tag}]
 [-nu|--no-urls] [-v|--verbose] [--opts <rpm opts>] [--short-circuit]
 [--show-bconds] [--with/--without <feature>] [--define <macro> <value>]
-[--git-pld|--git-tld] [--pkgrev]
+[--git-pld|--git-tld] [--pkgrev] [-lp]
 <package>[.spec][:tag]
 
 -4                  - force IPv4 when transferring files
@@ -466,8 +463,9 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 --git-pld           - force use of PLD git and distfiles
 --git-tld           - force use of TLD git and distfiles (note: it will fall
                       back to PLD git/df if package doesn't exist in TLD git)
---pkgrev            - write git revision of package being built into rsync repo
+--pkgrev            - save git revision of package being built into pkgrevs
                       (note: only official TLD source builders are allowed to do so)
+-lp                 - list pkgrevs for specified package
 "
 }
 
@@ -1120,11 +1118,7 @@ distfiles_path() {
 }
 
 distfiles_url() {
-       echo "$PROTOCOL$DISTFILES_SERVER/distfiles/$(distfiles_path "$1")"
-}
-
-distfiles_attic_url() {
-       echo "$PROTOCOL$ATTICDISTFILES_SERVER/distfiles/Attic/$(distfiles_path "$1")"
+       echo "$PROTOCOL$DISTFILES_SERVER/$(distfiles_path "$1")"
 }
 
 good_md5() {
@@ -1298,7 +1292,6 @@ get_files() {
                                                url=$(distfiles_url "$i")
                                        fi
 
-                                       url_attic=$(distfiles_attic_url "$i")
                                        FROM_DISTFILES=1
                                        # is $url local file?
                                        if [[ "$url" = [./]* ]]; then
@@ -1307,9 +1300,8 @@ get_files() {
                                        else
                                                local uri=${url}
                                                # make shorter message for distfiles urls
-                                               if [[ "$uri" = ${PROTOCOL}${DISTFILES_SERVER}* ]] || [[ "$uri" = ${PROTOCOL}${ATTICDISTFILES_SERVER}* ]]; then
-                                                       uri=${uri#${PROTOCOL}${DISTFILES_SERVER}/distfiles/by-md5/?/?/*/}
-                                                       uri=${uri#${PROTOCOL}${ATTICDISTFILES_SERVER}/distfiles/by-md5/?/?/*/}
+                                               if [[ "$uri" = ${PROTOCOL}${DISTFILES_SERVER}* ]]; then
+                                                       uri=${uri#${PROTOCOL}${DISTFILES_SERVER}/by-md5/?/?/*/}
                                                        uri="df: $uri"
                                                fi
                                                update_shell_title "${GETURI%% *}: $uri"
@@ -1320,23 +1312,6 @@ get_files() {
                                                fi
                                        fi
 
-                                       # is it empty file?
-                                       if [ ! -s "$target" ]; then
-                                               rm -f "$target"
-                                               if [ `echo $url_attic | grep -E '^(\.|/)'` ]; then
-                                                       update_shell_title "${GETLOCAL%% *}: $url_attic"
-                                                       ${GETLOCAL} $url_attic $target
-                                               else
-                                                       update_shell_title "${GETURI%% *}: $url_attic"
-                                                       ${GETURI} ${OUTFILEOPT} "$target" "$url_attic" || \
-                                                       if [ "`echo $url_attic | grep -E 'ftp://'`" ]; then
-                                                               update_shell_title "${GETURI2%% *}: $url_attic"
-                                                               ${GETURI2} ${OUTFILEOPT} "$target" "$url_attic"
-                                                       fi
-                                                       test -s "$target" || rm -f "$target"
-                                               fi
-                                       fi
-
                                        if [ -s "$target" ]; then
                                                cvsignore_df $target
                                        else
@@ -1386,15 +1361,6 @@ get_files() {
                                        update_shell_title "${GETURI2%% *}: $url"
                                        ${GETURI2} ${OUTFILEOPT} "$target" "$url"
                                fi
-                               if [ ! -s "$target" ]; then
-                                       rm -f "$target"
-                                       update_shell_title "${GETURI%% *}: $url_attic"
-                                       ${GETURI} ${OUTFILEOPT} "$target" "$url_attic" || \
-                                       if [ "`echo $url_attic | grep -E 'ftp://'`" ]; then
-                                               update_shell_title "${GETURI2%% *}: $url_attic"
-                                               ${GETURI2} ${OUTFILEOPT} "$target" "$url_attic"
-                                       fi
-                               fi
                                test -s "$target" || rm -f "$target"
                        fi
                done
@@ -1514,6 +1480,14 @@ set_pkgrev() {
        Exit_error err_pkgrev_set
 }
 
+list_pkgrev() {
+       local _tmp=$(mktemp /tmp/.builder-XXXX)
+       rm $_tmp 2>/dev/null
+       $GETURI $OUTFILEOPT $_tmp $PKGREVS_URL/list/$PACKAGE_NAME 1>/dev/null 2>&1
+       cat $_tmp
+       rm $_tmp 2>/dev/null
+}
+
 branch_files() {
        TAG=$1
        echo "Git branch: $TAG"
@@ -2476,7 +2450,6 @@ while [ $# -gt 0 ]; do
                        GIT_PUSH=${PLD_GIT_PUSH}
                        PACKAGES_DIR=${PLD_PACKAGES_DIR}
                        DISTFILES_SERVER=${PLD_DISTFILES_SERVER}
-                       ATTICDISTFILES_SERVER=${PLD_ATTICDISTFILES_SERVER}
                        ;;
                --git-tld)
                        shift
@@ -2484,11 +2457,13 @@ while [ $# -gt 0 ]; do
                        GIT_PUSH=${TLD_GIT_PUSH}
                        PACKAGES_DIR=${TLD_PACKAGES_DIR}
                        DISTFILES_SERVER=${TLD_DISTFILES_SERVER}
-                       ATTICDISTFILES_SERVER=${TLD_ATTICDISTFILES_SERVER}
                        ;;
                --pkgrev)
                        COMMAND="set_pkgrev"
                        shift;;
+               -lp)
+                       COMMAND="list_pkgrev"
+                       shift;;
                -*)
                        Exit_error err_invalid_cmdline "$1"
                        ;;
@@ -2512,7 +2487,6 @@ if ! git ls-remote --heads ${GIT_SERVER}/${PACKAGES_DIR}/${ASSUMED_NAME} 1>/dev/
        GIT_PUSH=${PLD_GIT_PUSH}
        PACKAGES_DIR=${PLD_PACKAGES_DIR}
        DISTFILES_SERVER=${PLD_DISTFILES_SERVER}
-       ATTICDISTFILES_SERVER=${PLD_ATTICDISTFILES_SERVER}
 fi
 
 if [ "$CVSTAG" ]; then
@@ -2843,6 +2817,15 @@ case "$COMMAND" in
                display_bconds
                set_pkgrev
                ;;
+       "list_pkgrev" )
+               init_builder
+               if [ -z "$SPECFILE" ]; then
+                       Exit_error err_no_spec_in_cmdl
+               fi
+               get_spec > /dev/null
+               parse_spec
+               list_pkgrev
+               ;;
 esac
 if [ -f "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES" -a "$REMOVE_BUILD_REQUIRES" != "" ]; then
        rm "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES"