]> TLD Linux GIT Repositories - packages/rpm-build-tools.git/blobdiff - builder.sh
- url fix
[packages/rpm-build-tools.git] / builder.sh
index 99c11d96c95df60d74137660831e6ddddf96d2d2..9f62964809ea7b71f016c3ccb2e6d6468386b955 100755 (executable)
@@ -124,7 +124,7 @@ PKGREVS_URL="http://pkgrevs.tld-linux.org"
 
 # TLD git/df config
 TLD_GIT_SERVER="git://git.tld-linux.org"
-TLD_GIT_PUSH="git@git.tld-linux.org"
+TLD_GIT_PUSH="git@git.tld-linux.org:7272"
 TLD_PACKAGES_DIR="packages"
 TLD_DISTFILES_SERVER="://df.tld-linux.org"
 TLD_ATTICDISTFILES_SERVER=""
@@ -320,7 +320,7 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 [{-Tp|--tag-prefix} <prefix>] [{-tt|--test-tag}]
 [-nu|--no-urls] [-v|--verbose] [--opts <rpm opts>] [--short-circuit]
 [--show-bconds] [--with/--without <feature>] [--define <macro> <value>]
-[--git-pld|--git-tld] [--pkgrev]
+[--git-pld|--git-tld] [--pkgrev] [-lp]
 <package>[.spec][:tag]
 
 -4                  - force IPv4 when transferring files
@@ -466,8 +466,9 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 --git-pld           - force use of PLD git and distfiles
 --git-tld           - force use of TLD git and distfiles (note: it will fall
                       back to PLD git/df if package doesn't exist in TLD git)
---pkgrev            - write git revision of package being built into rsync repo
+--pkgrev            - save git revision of package being built into pkgrevs
                       (note: only official TLD source builders are allowed to do so)
+-lp                 - list pkgrevs for specified package
 "
 }
 
@@ -1514,6 +1515,14 @@ set_pkgrev() {
        Exit_error err_pkgrev_set
 }
 
+list_pkgrev() {
+       local _tmp=$(mktemp /tmp/.builder-XXXX)
+       rm $_tmp 2>/dev/null
+       $GETURI $OUTFILEOPT $_tmp $PKGREVS_URL/list/$PACKAGE_NAME 1>/dev/null 2>&1
+       cat $_tmp
+       rm $_tmp 2>/dev/null
+}
+
 branch_files() {
        TAG=$1
        echo "Git branch: $TAG"
@@ -2489,6 +2498,9 @@ while [ $# -gt 0 ]; do
                --pkgrev)
                        COMMAND="set_pkgrev"
                        shift;;
+               -lp)
+                       COMMAND="list_pkgrev"
+                       shift;;
                -*)
                        Exit_error err_invalid_cmdline "$1"
                        ;;
@@ -2843,6 +2855,15 @@ case "$COMMAND" in
                display_bconds
                set_pkgrev
                ;;
+       "list_pkgrev" )
+               init_builder
+               if [ -z "$SPECFILE" ]; then
+                       Exit_error err_no_spec_in_cmdl
+               fi
+               get_spec > /dev/null
+               parse_spec
+               list_pkgrev
+               ;;
 esac
 if [ -f "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES" -a "$REMOVE_BUILD_REQUIRES" != "" ]; then
        rm "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES"