]> TLD Linux GIT Repositories - packages/rpm-tld-macros.git/commitdiff
- merged 2.029 from PLD master
authorMarcin Krol <hawk@tld-linux.org>
Sat, 2 Dec 2023 21:30:04 +0000 (22:30 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 2 Dec 2023 21:30:04 +0000 (22:30 +0100)
find-lang.sh
macros.arch
macros.java
macros.tld
rpm-tld-macros.spec

index fa120e8c695a52dad703b9354f8b6b37b03d6830..5339946b68b7e9bd4cf21ccbae1d6df5a447880b 100755 (executable)
@@ -36,7 +36,7 @@
 #   * start support for KDE help files
 
 PROG=${0##*/}
-VERSION=1.41
+VERSION=1.42
 
 usage () {
 cat <<EOF
@@ -237,12 +237,12 @@ s:%lang(C) ::' >> $MO_NAME
                cat __qm.files
        fi
 ) | sed '
-'"$NO_ALL_NAME$QM"'s:\(.*/'"$NAME"'_\([a-zA-Z]\{2\}\([_@].*\)\?\)\.qm$\):%lang(\2) \1:
+'"$NO_ALL_NAME$QM"'s:\(.*/'"$NAME"'_\([a-zA-Z]\{2,3\}\([_@].*\)\?\)\.qm$\):%lang(\2) \1:
 '"$NO_ALL_NAME$QM"'s:\(.*/share/locale/\)\([^/@]\+\)\(@quot\|@boldquot\)\?\(@[^/]*\)\?\(/.*/'"$NAME"'\.qm$\):%lang(\2\4) \1\2\3\4\5:
-'"$ALL_NAME$QM"'s:\(.*/[^/_]\+_\([a-zA-Z]\{2\}[_@].*\)\.qm$\):%lang(\2) \1:
-'"$ALL_NAME$QM"'s:\(.*/[^/_]\+_\([a-zA-Z]\{2\}\)\.qm$\):%lang(\2) \1:
-'"$ALL_NAME$QM"'s:^\([^%].*/[^/]\+_\([a-zA-Z]\{2\}[_@].*\)\.qm$\):%lang(\2) \1:
-'"$ALL_NAME$QM"'s:^\([^%].*/[^/]\+_\([a-zA-Z]\{2\}\)\.qm$\):%lang(\2) \1:
+'"$ALL_NAME$QM"'s:\(.*/[^/_]\+_\([a-zA-Z]\{2,3\}[_@].*\)\.qm$\):%lang(\2) \1:
+'"$ALL_NAME$QM"'s:\(.*/[^/_]\+_\([a-zA-Z]\{2,3\}\)\.qm$\):%lang(\2) \1:
+'"$ALL_NAME$QM"'s:^\([^%].*/[^/]\+_\([a-zA-Z]\{2,3\}[_@].*\)\.qm$\):%lang(\2) \1:
+'"$ALL_NAME$QM"'s:^\([^%].*/[^/]\+_\([a-zA-Z]\{2,3\}\)\.qm$\):%lang(\2) \1:
 s:^[^%].*::
 /^[^%]/d
 s:%lang(C) ::' >> $MO_NAME
index 88e6f462ce5b9878cbb7b8fcdc88feb613775aa0..bc22441c862689799fc023f5d521839f5fd447e0 100644 (file)
@@ -22,3 +22,6 @@
 
 # architectures with support for 8-byte (64 bits) atomics
 %arch_with_atomics64   i586 i686 athlon pentium2 pentium3 pentium4 %{x8664} x32 %{armv7} %{armv8} aarch64 mips64 ppc64 sparcv9 sparc64
+
+# architectures with support for 16-byte (128 bits) atomics
+%arch_with_atomics128  x86_64_v2 x86_64_v3 x86_64_v4
index 9af46e4d7e4a410a60c0b8c49d27b214e83bdfa3..cdaa677cfe979893fbf488f6ce7471094ced2fb7 100644 (file)
@@ -49,7 +49,7 @@
 
 # Default JDK provider and version
 %default_jdk_provider  openjdk
-%default_jdk_version   %min_jdk_version
+%default_jdk_version   11
 
 # Name of default JDK, takes requested minimum version as argument or if not
 # given defaults to %default_jdk_version. Result is is either:
index 06111e3b454770828c8a37f72aff3cd5799c0bbe..d993c2bc70e0b8805dce3095540a53b271fcad66 100644 (file)
@@ -41,7 +41,7 @@
 
 # Location of pkgconfig files
 %_pkgconfigdir /usr/%{_lib}/pkgconfig
-# noarch pkgconfig files
+# noarch pkgconfig files (since 1.446)
 %_npkgconfigdir        /usr/share/pkgconfig
 
 # Location of desktop files
 # Location of fonts directories
 %_fontsdir     /usr/share/fonts
 
-# Location of Gtk and associated libraries documentation
+# Location of Gtk and associated libraries documentation (since 1.98)
 %_gtkdocdir    %{_defaultdocdir}/gtk-doc/html
 
-# Location of KDE documentation
+# Common subdirectory for gi-docgen generated libraries documentation (since 2.029)
+%_gidocdir     %{_defaultdocdir}/gi-doc
+
+# Location of KDE documentation (since 1.129)
 %_kdedocdir    %{_defaultdocdir}/kde/HTML
 
 # unsermake script
@@ -489,6 +492,7 @@ CPPFLAGS="${CPPFLAGS:-%{rpmcppflags}}" \\\
        -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \\\
        -DCMAKE_BUILD_TYPE=%{!?debug:TLD}%{?debug:Debug} \\\
        -DCMAKE_SYSTEM_NAME=Linux \\\
+       -DCMAKE_SYSTEM_VERSION="%(uname -r)" \\\
        -DCMAKE_CROSSCOMPILING:BOOL=FALSE \\\
 %ifarch x32\
        -DCMAKE_SYSTEM_PROCESSOR=x86_64 \\\
@@ -527,6 +531,7 @@ CPPFLAGS="${CPPFLAGS:-%{rpmcppflags}}" \\\
        -DBUILD_SHARED_LIBS:BOOL=ON \\\
 %{nil}
 
+# scons (since 1.385)
 %scons { \
 %{__scons} \
        LDFLAGS="${LDFLAGS:-%rpmldflags}" \
@@ -540,7 +545,7 @@ CPPFLAGS="${CPPFLAGS:-%{rpmcppflags}}" \\\
        prefix=%{_prefix} \
 }
 
-# waf. see waf.spec
+# waf. see waf.spec (since 1.336)
 %waf { \
 CC="%{__cc}" \
 CXX="%{__cxx}" \
@@ -551,7 +556,7 @@ LINKFLAGS="%{rpmldflags}" \
 %{__waf} \
 }
 
-# meson
+# meson (since 1.727)
 %meson { \
 %{?__cc:CC="${CC:-%{__cc}}"} \
 %{?__cxx:CXX="${CXX:-%{__cxx}}"} \
@@ -585,7 +590,7 @@ LC_ALL=C.UTF-8 %{__meson} \
 %meson_install %___meson_deprecate meson_install ninja_install
 %meson_test %___meson_deprecate meson_test ninja_test
 
-# ninja
+# ninja (since 1.736)
 %ninja_build LC_ALL=C.UTF-8 %{__ninja} %{__ninja_common_opts}
 %ninja_install LC_ALL=C.UTF-8 DESTDIR=%{buildroot} %{__ninja} install %{__ninja_common_opts}
 %ninja_test LC_ALL=C.UTF-8 %{__ninja} test %{__ninja_common_opts}
@@ -659,11 +664,11 @@ LC_ALL=C.UTF-8 %{__meson} \
 %__without_if() %{expand:%%{?with_%{1}:--without-%{?2}%{!?2:%{1}}}}
 %__with_without_not() %{expand:%%{!?with_%{1}:--with-%{?2}%{!?2:%{1}}%{?3:=%{3}}}%%{?with_%{1}:--without-%{?2}%{!?2:%{1}}}}
 
-# expands to true or false based on bcond; for use with meson or cmake
+# expands to true or false based on bcond; for use with meson or cmake (since 1.729)
 %__true_false() %{expand:%%{?with_%{1}:true}%%{!?with_%{1}:false}}
 %__true_false_not() %{expand:%%{?with_%{1}:false}%%{!?with_%{1}:true}}
 
-# expands to enabled or disabled based on bcond; for use with meson or cmake
+# expands to enabled or disabled based on bcond; for use with meson or cmake (since 2.000)
 %__enabled_disabled() %{expand:%%{?with_%{1}:enabled}%%{!?with_%{1}:disabled}}
 %__enabled_disabled_not() %{expand:%%{?with_%{1}:disabled}%%{!?with_%{1}:enabled}}
 
@@ -835,7 +840,7 @@ if [ -d "$RPM_BUILD_ROOT" ]; then \
                        echo "DONE"; \
                fi; \
        fi; \
-       filelist=$(find $RPM_BUILD_ROOT -type f ! -regex ".*/usr/lib[x0-9]*/debug/.*\.debug" ! -regex ".*/usr/lib[x0-9]*.*/guile/.*\.go" ! -regex ".*/lib/modules/.*" ! -regex ".*%{_docdir}/.*" ! -regex ".*%{_includedir}/.*" %{?_noautostrip:! -regex "%{_noautostrip}"} %{?_autostripall:! -regex "%{_autostripall}"} %{?_autostripunneeded:! -regex "%{_autostripunneeded}"} %{?_autostripdebug:! -regex "%{_autostripdebug}"}); \
+       filelist=$(find $RPM_BUILD_ROOT  ! \( -path "*/usr/src/debug" -prune \) -type f ! -regex ".*/usr/lib[x0-9]*/debug/.*\.debug" ! -regex ".*/usr/lib[x0-9]*.*/guile/.*\.go" ! -regex ".*/lib/modules/.*" ! -regex ".*%{_docdir}/.*" ! -regex ".*%{_includedir}/.*" %{?_noautostrip:! -regex "%{_noautostrip}"} %{?_autostripall:! -regex "%{_autostripall}"} %{?_autostripunneeded:! -regex "%{_autostripunneeded}"} %{?_autostripdebug:! -regex "%{_autostripdebug}"}); \
        if [ -n "$filelist" ]; then \
                filetypes=`echo "$filelist" | xargs -r -d'\\n' file`; \
                elfexelist=`echo "$filetypes" | awk -F: '/ELF.*executable/ {print $1}'`; \
@@ -1035,7 +1040,7 @@ __spec_install_post_check_shebangs() { \
 %_soname_prov() %(echo "%{1}()%{_soname_tag}" | sed -e 's/^\\([^(]*([^)]\\+)\\)()%{_soname_tag}$/\\1%{_soname_tag}/;s/()$//')
 
 #-----------------------------------------------------------------
-# Update GConf2 schemas
+# Update GConf2 schemas (since 1.198)
 #
 # Requires: GConf2
 #
@@ -1054,7 +1059,7 @@ fi; \
 %{nil}
 
 #-----------------------------------------------------------------
-# Update desktop MIME database
+# Update desktop MIME database (since 1.198)
 # requires: desktop-file-utils
 %update_desktop_database() {{ \
        umask 022; \
@@ -1072,7 +1077,7 @@ fi; \
 %{nil}
 
 #-----------------------------------------------------------------
-# Update shared MIME info database
+# Update shared MIME info database (since 1.311)
 # requires: shared-mime-info
 # Note:        https://bugs.freedesktop.org/show_bug.cgi?id=70366#c19
 #      https://bugzilla.redhat.com/show_bug.cgi?id=1052173
@@ -1103,7 +1108,7 @@ fi; \
 %{nil}
 
 #-----------------------------------------------------------------
-# Update scrollkeeper database
+# Update scrollkeeper database (since 1.198)
 # requires: scrollkeeper
 #
 %scrollkeeper_update_post() \
@@ -1117,7 +1122,7 @@ fi; \
 %{nil}
 
 #-----------------------------------------------------------------
-# Compile GSettings schemas
+# Compile GSettings schemas (since 1.592)
 # requires: glib2 >= 1:2.26.0
 #
 %glib_compile_schemas() {{ \
@@ -1243,7 +1248,7 @@ fi; \
 # BuildRequires:       rpmbuild(macros) >= 1.719
 %zsh_compdir           /usr/share/zsh/site-functions
 
-# depmod macro
+# depmod macro (since 1.184)
 %depmod() { \
 umask 022; \
 if [ -e /boot/System.map-%1 ]; then \
@@ -1257,7 +1262,7 @@ else \
 fi; \
 }
 
-# user/group checking macros
+# user/group checking macros (since 1.202)
 #
 # Usage:
 #      %userremove myuser
@@ -1287,7 +1292,7 @@ fi; \
 %addusertogroup(q)     quiet=%{-q:1} /usr/lib/rpm/user_group.sh user addtogroup %*; \
 %{nil}
 
-# banner support (useful in {pre,post}{,un} and triggers)
+# banner support (useful in {pre,post}{,un} and triggers) (since 1.194)
 #
 # Usage:
 #      %banner name [-a] [-e] [-n] [-tn] [-o] <<EOF
@@ -1301,7 +1306,7 @@ fi; \
 # -e   - send to stderr instead of stdout
 # -n   - don't show banner (overrides -t)
 # -t   - show only, if RPM_SCRIPTVERBOSITY >= n; default n=5
-# -o   - show only once, i.e when package is installed for the first time
+# -o   - show only once, i.e when package is installed for the first time (since 1.595)
 #
 # Tests:
 # (rpm -E '%banner -e banner <<EOF'; echo -e 'hi\nEOF') > m; sh -x m
@@ -1321,7 +1326,7 @@ fi \
 eval $CMD %{?2:%2}%{?3: %3})%{-o:)} \
 %{nil}
 
-# useradd/groupadd macros
+# useradd/groupadd macros (since 1.202)
 # Author: Elan Ruusamäe <glen@pld-linux.org>
 #
 # Usage:
index 49ade3397b2b020b71d667627ee335b6fb9e56f1..0201b7b168cb2b0aa75b4c49dfe7ec40c91c8e87 100644 (file)
@@ -1,5 +1,5 @@
-%define                rpm_macros_rev  2.025
-%define                find_lang_rev   1.41
+%define                rpm_macros_rev  2.029
+%define                find_lang_rev   1.42
 # split into individual X_prov_ver if there is a reason to desync
 %define                prov_ver        4.15
 Summary:       TLD Linux RPM macros