]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- oops, patch for previous commit
[packages/rpm.git] / rpm.spec
index 5fa200ddeda1089396cb9388c8c3767e818ea476..0ba234f9368b9f927686c04a9c850c46262c3559 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -16,7 +16,7 @@
 #
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
-%bcond_without apidocs         # don't generate documentation with doxygen
+%bcond_with    apidocs         # don't generate documentation with doxygen
 %bcond_with    internal_db     # internal db (db 4.5.20)
 %bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
 %bcond_without nptl            # internal db: don't use process-shared POSIX mutexes (NPTL provides full interface)
@@ -27,8 +27,8 @@
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library). NOTE: neon libs are in /usr!
 
 # versions of required libraries
-%define        reqdb_pkg       db4.5
-%define        reqdb_ver       4.5.20
+%define        reqdb_pkg       db4.7
+%define        reqdb_ver       4.7.25
 %define        reqpopt_ver     1.10.8
 %define        beecrypt_ver    2:4.1.2-4
 %define        sover           4.5
@@ -42,7 +42,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       74
+Release:       80.1
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -167,12 +167,15 @@ Patch106: %{name}-automake_1.12.patch
 Patch107:      %{name}-debugedit-dwarf4.patch
 Patch108:      %{name}-changelog_order_check_nonfatal.patch
 Patch109:      %{name}-installplatform.patch
+Patch110:      %{name}-xz.patch
+Patch111:      %{name}-shrink.patch
+Patch112:      notrans.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1.4
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
-%{!?with_internal_db:BuildRequires:    db-devel >= %{reqdb_ver}}
+%{!?with_internal_db:BuildRequires:    %{reqdb_pkg}-devel >= %{reqdb_ver}}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: keyutils-devel
@@ -210,6 +213,7 @@ BuildRequires:      elfutils-static
 BuildRequires: glibc-static >= 2.2.94
 %{?with_system_libmagic:BuildRequires: libmagic-static}
 %{?with_selinux:BuildRequires: libselinux-static >= 1.18}
+BuildRequires: ossp-uuid-static >= 1.6.2-8
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static >= 1.2.3.3
 %endif
@@ -785,6 +789,9 @@ install %{SOURCE13} scripts/perl.prov
 %patch107 -p1
 %patch108 -p1
 %patch109 -p1
+%patch110 -p1
+%patch111 -p1
+%patch112 -p1
 
 mv -f po/{sr,sr@Latn}.po
 rm -rf sqlite zlib popt
@@ -1168,7 +1175,7 @@ rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/RPM.pm
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/.packlist
-%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/RPM.bs
+%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/RPM.bs
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/RPM.so
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/RPM.3pm
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{,ja,pl}/man8/rpm{cache,graph}.8