]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- merged rpm-4_5 branch from PLD
[packages/rpm.git] / rpm.spec
index dc7d79af8b4e015ef17908af9244fb255cc3c9df..21b6ed9a28755a00addc5b8b20d72b714f482512 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 %bcond_without system_libmagic # don't use system libmagic
 %bcond_without suggest_tags    # build without Suggest tag (bootstrapping)
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library). NOTE: neon libs are in /usr!
-# force_cc             - force using __cc other than "%{_target_cpu}-tld-linux-gcc"
-# force_cxx            - force using __cxx other than "%{_target_cpu}-tld-linux-g++"
-# force_cpp            - force using __cpp other than "%{_target_cpu}-tld-linux-gcc -E"
-
-#%%define      force_cc "%{_target_cpu}-tld-linux-gcc"
-#%%define      force_cxx "%{_target_cpu}-tld-linux-g++"
-#%%define      force_cpp '%{_target_cpu}-tld-linux-gcc -E'
 
 # versions of required libraries
 %define        reqdb_pkg       db4.5
@@ -49,7 +42,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       62
+Release:       70
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -75,8 +68,6 @@ Source19:     %{name}-macros.gstreamer
 Source20:      macros.php
 Source21:      %{name}-php-requires.php
 Patch1000:     %{name}-new-debuginfo.patch
-#Patch1067:    %{name}-disable-features.patch
-#Patch1070:    %{name}-rpmrc-ac.patch
 #Patch0:       %{name}-pl.po.patch
 Patch1:                %{name}-rpmrc.patch
 Patch2:                %{name}-arch.patch
@@ -252,10 +243,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags       -fno-strict-aliasing
 
-#%%define              _host_alias            %{_target_cpu}-tld-linux%{nil}
-#%%define              _host_vendor           tld
-#%%define              _vendor                tld
-
 %description
 RPM is a powerful package manager, which can be used to build,
 install, query, verify, update, and uninstall individual software
@@ -533,8 +520,8 @@ Requires:   elfutils
 Requires:      file >= 4.17
 Requires:      fileutils
 Requires:      findutils
-# rpmrc patch adds flags specific to gcc >= 3.4
-Requires:      gcc >= 5:3.4
+# rpmrc patch adds flags specific to gcc >= 4.7
+Requires:      gcc >= 6:4.7.0
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
@@ -689,10 +676,11 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 
 %prep
 %setup -q
+cp -p %{SOURCE15} .
 %patch1000 -p1
 #%patch0 -p1
-%patch1 -p1
 %patch2 -p1
+%patch1 -p1
 %patch3 -p1
 %patch4 -p1
 %patch6 -p1
@@ -1023,7 +1011,7 @@ install -p scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
 cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
 install -p %{SOURCE18} $RPM_BUILD_ROOT%{_bindir}/banner.sh
-cp -a %{SOURCE15} $RPM_BUILD_ROOT/etc/sysconfig/rpm
+cp -p %{name}.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/rpm
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
 touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname