]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- finnally works
[packages/rpm.git] / rpm.spec
index 401584ff32bd8d79d55a254912c70864811f8da8..707c9b9d5bc6118017a64201fae783db38e3a388 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
 # force_cc             - force using __cc other than "%{_target_cpu}-tld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-tld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-tld-linux-gcc -E"
+#%%define      force_cc "%{_target_cpu}-tld-linux-gcc"
+#%%define      force_cxx "%{_target_cpu}-tld-linux-g++"
+#%%define      force_cpp '%{_target_cpu}-tld-linux-gcc -E'
 
 # versions of required libraries
 %define        reqdb_ver       4.5.20
 %define        reqpopt_ver     1.10.8
 %define        beecrypt_ver    2:4.1.2-4
 %define        sover           4.5
+
 Summary:       RPM Package Manager
 Summary(de.UTF-8):     RPM Packet-Manager
 Summary(es.UTF-8):     Gestor de paquetes RPM
@@ -43,11 +47,11 @@ Summary(ru.UTF-8):  Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       55
+Release:       57
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: 6b4cda21de59dc250d2e33e4187fd166
+# Source0-md5: 4e69ab971f682c87625dc0f65d9e16bc
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -239,6 +243,10 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags       -fno-strict-aliasing
 
+%define                _host_alias            %{_target_cpu}-tld-linux%{nil}
+%define                _host_vendor           tld
+%define                _vendor                tld
+
 %description
 RPM is a powerful package manager, which can be used to build,
 install, query, verify, update, and uninstall individual software
@@ -859,9 +867,9 @@ CPPFLAGS="%{rpmcppflags} -I/usr/include/ossp-uuid"
        --without-db
 
 %{__make} \
-       CC="%{__cc}" \
-       CXX="%{__cxx}" \
-       CPP="%{__cpp}" \
+       CC="%{__newcc}" \
+       CXX="%{__newcxx}" \
+       CPP="%{__newcpp}" \
        libdb_la=%{_libdir}/libdb.la \
        pylibdir=%{py_libdir} \
        myLDFLAGS="%{rpmldflags}" \