]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- backported from PLD rpm 5.x changes required to build from .gem sources
[packages/rpm.git] / rpm.spec
index c7232e03fa00b66e86032c3dee378703c6c11aba..c2f5b3863fdd7c4bc825358506ddc4e409cb7503 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -27,8 +27,8 @@
 %bcond_with    neon            # build with HTTP/WebDAV support (neon library). NOTE: neon libs are in /usr!
 
 # versions of required libraries
-%define        reqdb_pkg       db4.5
-%define        reqdb_ver       4.5.20.2
+%define        reqdb_pkg       db4.7
+%define        reqdb_ver       4.7.25
 %define        reqpopt_ver     1.10.8
 %define        beecrypt_ver    2:4.1.2-4
 %define        sover           4.5
@@ -42,7 +42,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       77
+Release:       82
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -67,6 +67,8 @@ Source18:     banner.sh
 Source19:      %{name}-macros.gstreamer
 Source20:      macros.php
 Source21:      %{name}-php-requires.php
+Source22:      rubygems.rb
+Source23:      gem_helper.rb
 Patch1000:     %{name}-new-debuginfo.patch
 #Patch0:       %{name}-pl.po.patch
 Patch1:                %{name}-rpmrc.patch
@@ -168,12 +170,16 @@ Patch107: %{name}-debugedit-dwarf4.patch
 Patch108:      %{name}-changelog_order_check_nonfatal.patch
 Patch109:      %{name}-installplatform.patch
 Patch110:      %{name}-xz.patch
+Patch111:      %{name}-shrink.patch
+Patch112:      notrans.patch
+Patch113:      %{name}-rubyprov.patch
+Patch114:      %{name}-ruby-gem-build.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake >= 1.4
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
 BuildRequires: bzip2-devel >= 1.0.2-17
-%{!?with_internal_db:BuildRequires:    db-devel >= %{reqdb_ver}}
+%{!?with_internal_db:BuildRequires:    %{reqdb_pkg}-devel >= %{reqdb_ver}}
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-devel >= 0.11.4-2
 BuildRequires: keyutils-devel
@@ -211,6 +217,7 @@ BuildRequires:      elfutils-static
 BuildRequires: glibc-static >= 2.2.94
 %{?with_system_libmagic:BuildRequires: libmagic-static}
 %{?with_selinux:BuildRequires: libselinux-static >= 1.18}
+BuildRequires: ossp-uuid-static >= 1.6.2-8
 BuildRequires: popt-static >= %{reqpopt_ver}
 BuildRequires: zlib-static >= 1.2.3.3
 %endif
@@ -631,6 +638,23 @@ packages.
 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
 pakietach RPM.
 
+%package rubyprov
+Summary:       Ruby tools, which simplify creation of RPM packages with Ruby software
+Summary(pl.UTF-8):     Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
+Group:         Applications/File
+Requires:      %{name} = %{version}-%{release}
+Requires:      ruby
+Requires:      ruby-modules
+Requires:      ruby-rubygems
+
+%description rubyprov
+Ruby tools, which simplifies creation of RPM packages with Ruby
+software.
+
+%description rubyprov -l pl.UTF-8
+Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
+Ruby.
+
 %package -n python-rpm
 Summary:       Python interface to RPM library
 Summary(pl.UTF-8):     Pythonowy interfejs do biblioteki RPM-a
@@ -787,6 +811,10 @@ install %{SOURCE13} scripts/perl.prov
 %patch108 -p1
 %patch109 -p1
 %patch110 -p1
+%patch111 -p1
+%patch112 -p1
+%patch113 -p1
+%patch114 -p1
 
 mv -f po/{sr,sr@Latn}.po
 rm -rf sqlite zlib popt
@@ -802,6 +830,9 @@ sed -i -e 's,AM_PTHREADS_SHARED("POSIX/.*,:,' db/dist/aclocal/mutex.ac
 rm -rf db3 db rpmdb/db.h
 %endif
 
+cp -p %{SOURCE22} scripts/rubygems.rb
+cp -p %{SOURCE23} scripts/gem_helper.rb
+
 # generate Group translations to *.po
 awk -f %{SOURCE6} %{SOURCE1}
 
@@ -1170,7 +1201,7 @@ rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/RPM.pm
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/.packlist
-#%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/RPM.bs
+%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/RPM.bs
 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/RPM/RPM.so
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/RPM.3pm
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{,ja,pl}/man8/rpm{cache,graph}.8
@@ -1422,6 +1453,11 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_rpmlibdir}/php*
 
+%files rubyprov
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
+%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
+
 %if %{with python}
 %files -n python-rpm
 %defattr(644,root,root,755)