]> TLD Linux GIT Repositories - packages/rpm.git/blobdiff - rpm.spec
- release 61
[packages/rpm.git] / rpm.spec
index 707c9b9d5bc6118017a64201fae783db38e3a388..d5fa02c3e33c4db24f5d3b747ebecbc4a7ce7733 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -28,6 +28,7 @@
 # force_cc             - force using __cc other than "%{_target_cpu}-tld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-tld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-tld-linux-gcc -E"
+
 #%%define      force_cc "%{_target_cpu}-tld-linux-gcc"
 #%%define      force_cxx "%{_target_cpu}-tld-linux-g++"
 #%%define      force_cpp '%{_target_cpu}-tld-linux-gcc -E'
@@ -47,7 +48,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.5
-Release:       57
+Release:       61
 License:       LGPL
 Group:         Base
 Source0:       %{name}-%{version}.tar.gz
@@ -71,8 +72,8 @@ Source17:     %{name}-java-requires
 Source18:      banner.sh
 Source19:      %{name}-macros.gstreamer
 Patch1000:     %{name}-new-debuginfo.patch
-Patch1067:     %{name}-disable-features.patch
-Patch1070:     %{name}-rpmrc-ac.patch
+#Patch1067:    %{name}-disable-features.patch
+#Patch1070:    %{name}-rpmrc-ac.patch
 #Patch0:       %{name}-pl.po.patch
 Patch1:                %{name}-rpmrc.patch
 Patch2:                %{name}-arch.patch
@@ -243,9 +244,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags       -fno-strict-aliasing
 
-%define                _host_alias            %{_target_cpu}-tld-linux%{nil}
-%define                _host_vendor           tld
-%define                _vendor                tld
+#%%define              _host_alias            %{_target_cpu}-tld-linux%{nil}
+#%%define              _host_vendor           tld
+#%%define              _vendor                tld
 
 %description
 RPM is a powerful package manager, which can be used to build,
@@ -867,9 +868,9 @@ CPPFLAGS="%{rpmcppflags} -I/usr/include/ossp-uuid"
        --without-db
 
 %{__make} \
-       CC="%{__newcc}" \
-       CXX="%{__newcxx}" \
-       CPP="%{__newcpp}" \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       CPP="%{__cpp}" \
        libdb_la=%{_libdir}/libdb.la \
        pylibdir=%{py_libdir} \
        myLDFLAGS="%{rpmldflags}" \