]> TLD Linux GIT Repositories - packages/seabios.git/blob - seabios.spec
d2a48a4b1e52f26c42b4cf0e4cf3131468fc9cc1
[packages/seabios.git] / seabios.spec
1 Summary:        Open source implementation of a 16-bit x86 BIOS
2 Summary(pl.UTF-8):      Implementacja 16-bitowego BIOS-u x86 o otwartych źródłach
3 Name:           seabios
4 Version:        1.7.5
5 Release:        2
6 License:        LGPL v3
7 Group:          Applications/System
8 Source0:        http://code.coreboot.org/p/seabios/downloads/get/%{name}-%{version}.tar.gz
9 # Source0-md5:  3f1e17485ca327b245ae5938d9aa02d9
10 # binary for non-x86 archs
11 Source1:        http://code.coreboot.org/p/seabios/downloads/get/bios.bin-%{version}.gz
12 # Source1-md5:  f14eccbad35cd802ef785bde48a43519
13 URL:            http://seabios.org/
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 SeaBIOS is an open source implementation of a 16-bit X86 BIOS. SeaBIOS
18 can run in an emulator or it can run natively on X86 hardware with the
19 use of coreboot.
20
21 SeaBIOS is the default BIOS for QEMU, KVM and Xen HVM.
22
23 %description -l pl.UTF-8
24 SeaBIOS to mająca otwarte źródła implementacją 16-bitowego BIOS-u X86.
25 SeaBIOS może działać pod kontrolą emulatora lub natywnie na sprzęcie
26 X86 przy użyciu bootloadera coreboot.
27
28 SeaBIOS to domyślny BIOS dla narzędzi QEMU, KVM i Xen HVM.
29
30 %prep
31 %setup -q
32
33 %build
34 %ifarch %{ix86} %{x8664}
35 %{__make}
36 %endif
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
42
43 %ifarch %{ix86} %{x8664}
44 install out/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios.bin
45 install out/src/fw/*.aml $RPM_BUILD_ROOT%{_datadir}/%{name}
46 %else
47 gunzip -c %{SOURCE1} > $RPM_BUILD_ROOT%{_datadir}/%{name}/bios.bin
48 %endif
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README TODO
56 %dir %{_datadir}/%{name}
57 %{_datadir}/%{name}/bios.bin
58 %ifarch %{ix86} %{x8664}
59 %{_datadir}/%{name}/*.aml
60 %endif