]> TLD Linux GIT Repositories - packages/seabios.git/blobdiff - seabios.spec
- 1.16.2 from PLD
[packages/seabios.git] / seabios.spec
index 81cfba39d15544786474fb354551f36b596c5793..46d8249970672d719fc178b4f9e7592be0019d7c 100644 (file)
@@ -1,16 +1,24 @@
 Summary:       Open source implementation of a 16-bit x86 BIOS
 Summary(pl.UTF-8):     Implementacja 16-bitowego BIOS-u x86 o otwartych źródłach
 Name:          seabios
-Version:       1.9.1
+Version:       1.16.2
 Release:       1
 License:       LGPL v3
 Group:         Applications/System
-Source0:       http://code.coreboot.org/p/seabios/downloads/get/%{name}-%{version}.tar.gz
-# Source0-md5: e21b6f3e54d492be837ef20d66617f81
-URL:           http://seabios.org/
-ExclusiveArch: %{ix86} %{x8664}
+Source0:       https://www.seabios.org/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: ef52bf37a78e78a082688a244300ab86
+URL:           https://www.seabios.org/SeaBIOS
+BuildRequires: acpica
+%ifnarch %{ix86} %{x8664} x32
+# i386 crosscompiler could be used as well, but we have only x86_64 as more universal
+BuildRequires: crossx8664-binutils
+BuildRequires: crossx8664-gcc
+%endif
+BuildRequires: python3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _enable_debug_packages  0
+
 %description
 SeaBIOS is an open source implementation of a 16-bit X86 BIOS. SeaBIOS
 can run in an emulator or it can run natively on X86 hardware with the
@@ -29,15 +37,17 @@ SeaBIOS to domyślny BIOS dla narzędzi QEMU, KVM i Xen HVM.
 %setup -q
 
 %build
-%{__make}
+%{__make} \
+       V=1 PYTHON=%{__python3} \
+%ifnarch %{ix86} %{x8664} x32
+       CROSS_PREFIX=x86_64-tld-linux
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 install out/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios.bin
-install out/src/fw/*.aml $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -47,4 +57,3 @@ rm -rf $RPM_BUILD_ROOT
 %doc README docs/{Debugging.md,Mailinglist.md,Memory_Model.md,Releases.md,Runtime_config.md,SeaBIOS.md,SeaVGABIOS.md}
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/bios.bin
-%{_datadir}/%{name}/*.aml