]> TLD Linux GIT Repositories - packages/shorewall.git/blobdiff - shorewall.spec
- perl >= 5.28 fixes
[packages/shorewall.git] / shorewall.spec
index 8fb11f048288080fbdcafac665edfe0a518b33fe..9dec2f2cf00851d22b176afa382fc1e462e46c6f 100644 (file)
@@ -1,33 +1,35 @@
 # NOTE:
 # A very helpful document for packaging Shorewall is "Anatomy of Shorewall 4.0"
 # which is found at http://www.shorewall.net/Anatomy.html
-# TODO
-# - rc-script inits
+#
 Summary:       Shoreline Firewall - an iptables-based firewall for Linux systems
 Summary(pl.UTF-8):     Shoreline Firewall - zapora sieciowa oparta na iptables
 Name:          shorewall
-Version:       5.2.0.4
-Release:       0.2
+Version:       5.2.0.5
+Release:       2
 License:       GPL
 Group:         Networking/Utilities
 Source0:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-%{version}.tar.bz2
-# Source0-md5: b8702d14846f890d263f5ea2447b5bed
+# Source0-md5: 3fb5f8c1f0012c0221681bc6d62b84a3
 Source1:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-lite-%{version}.tar.bz2
-# Source1-md5: 0dd43f44f7555418ae2f153fbf7ce1ef
+# Source1-md5: 821f5b69ba22fb9950195647ff3ad223
 Source2:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}6-%{version}.tar.bz2
-# Source2-md5: 14c87b9880bc69c82792854af45335e6
+# Source2-md5: 7f8a9fcc0227e50b21da553acb99f764
 Source3:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}6-lite-%{version}.tar.bz2
-# Source3-md5: 9f03407f5f7dac39f286bdaf3ec051e8
+# Source3-md5: 57fbbf639a3351212c02026ba0e7b89d
 Source4:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-init-%{version}.tar.bz2
-# Source4-md5: cf6b2a6c1a8827a99c1b3e717d42ccff
+# Source4-md5: 87cc6453104a65fac36996a86469157e
 Source5:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-core-%{version}.tar.bz2
-# Source5-md5: be73e2f76b2438e7813f62873a50c203
+# Source5-md5: 16e6505831f5c1bc19c08d8982a4becc
 Source10:      %{name}.init
+Source11:      %{name}.logrotate
 Patch0:                %{name}-config.patch
-Patch1:                tld.patch
-Patch2:                man.patch
-Patch3:                init.patch
-Patch4:                shell-fix.patch
+Patch1:                %{name}-logging.patch
+Patch2:                tld.patch
+Patch3:                man.patch
+Patch4:                init.patch
+Patch5:                shell-fix.patch
+Patch6:                perl.patch
 URL:           http://www.shorewall.net/
 BuildRequires: perl
 BuildRequires: perl(Digest::SHA)
@@ -107,6 +109,7 @@ rule compiler installed.
 %package core
 Summary:       Core libraries for Shorewall
 Group:         Applications/System
+Requires:      logrotate
 
 %description core
 This package contains the core libraries for Shorewall.
@@ -143,6 +146,8 @@ done
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 # Remove hash-bang from files which are not directly executed as shell
 # scripts. This silences some rpmlint errors.
@@ -166,17 +171,28 @@ done
 
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/shorewall
+install -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/shorewall
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+/sbin/chkconfig --add shorewall
+%service shorewall restart "Shorewall"
+
+%preun
+if [ "$1" = "0" ]; then
+       %service shorewall stop
+       /sbin/chkconfig --del shorewall
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc shorewall-%{version}/{COPYING,changelog.txt,releasenotes.txt,Samples}
 %attr(755,root,root) %{_sbindir}/shorewall
 %dir %{_sysconfdir}/shorewall
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall/*
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall-init
 %{_datadir}/shorewall/action.*
 %{_datadir}/shorewall/actions.std
 %{_datadir}/shorewall/configfiles/
@@ -208,7 +224,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/shorewall-lite
 %dir %{_sysconfdir}/shorewall-lite
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall-lite/shorewall-lite.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall-lite
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall-lite-init
 %{_datadir}/shorewall-lite
 %{_libexecdir}/shorewall-lite
 %{_mandir}/man5/shorewall-lite*
@@ -222,7 +238,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/shorewall6
 %dir %{_sysconfdir}/shorewall6
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall6/*
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall6
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall6-init
 %{_mandir}/man5/shorewall6*
 %exclude %{_mandir}/man5/shorewall6-lite*
 %{_mandir}/man8/shorewall6*
@@ -237,7 +253,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/shorewall6-lite
 %dir %{_sysconfdir}/shorewall6-lite
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall6-lite/shorewall6-lite.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall6-lite
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall6-lite-init
 %{_mandir}/man5/shorewall6-lite*
 %{_mandir}/man8/shorewall6-lite*
 %{_datadir}/shorewall6-lite
@@ -249,6 +265,7 @@ rm -rf $RPM_BUILD_ROOT
 %files core
 %defattr(644,root,root,755)
 %doc shorewall-core-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall
 %dir %{_datadir}/shorewall/
 %{_datadir}/shorewall/coreversion
 %{_datadir}/shorewall/functions
@@ -265,7 +282,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/shorewall-init
 %attr(755,root,root) %{_sysconfdir}/NetworkManager/dispatcher.d/01-shorewall
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/shorewall-init
-/etc/logrotate.d/shorewall-init
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall-ifupdown
 %{_mandir}/man8/shorewall-init.8.*
 %{_datadir}/shorewall-init
 %dir %{_libexecdir}/shorewall-init