]> TLD Linux GIT Repositories - packages/shorewall.git/blobdiff - shorewall.spec
- updated to 5.2.3.4
[packages/shorewall.git] / shorewall.spec
index 70c35387078110dd58a0c0597bde7ca9d65107f2..b6dcfc88848a6dba6450db89d10d36699bad9449 100644 (file)
@@ -1,27 +1,29 @@
 # NOTE:
 # A very helpful document for packaging Shorewall is "Anatomy of Shorewall 4.0"
 # which is found at http://www.shorewall.net/Anatomy.html
-# TODO
-# - rc-script inits
+#
+%define                ver     5.2.3
+%define                rel     .4
+
 Summary:       Shoreline Firewall - an iptables-based firewall for Linux systems
 Summary(pl.UTF-8):     Shoreline Firewall - zapora sieciowa oparta na iptables
 Name:          shorewall
-Version:       5.2.0.4
-Release:       3
+Version:       %{ver}%{rel}
+Release:       1
 License:       GPL
 Group:         Networking/Utilities
-Source0:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-%{version}.tar.bz2
-# Source0-md5: b8702d14846f890d263f5ea2447b5bed
-Source1:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-lite-%{version}.tar.bz2
-# Source1-md5: 0dd43f44f7555418ae2f153fbf7ce1ef
-Source2:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}6-%{version}.tar.bz2
-# Source2-md5: 14c87b9880bc69c82792854af45335e6
-Source3:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}6-lite-%{version}.tar.bz2
-# Source3-md5: 9f03407f5f7dac39f286bdaf3ec051e8
-Source4:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-init-%{version}.tar.bz2
-# Source4-md5: cf6b2a6c1a8827a99c1b3e717d42ccff
-Source5:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-core-%{version}.tar.bz2
-# Source5-md5: be73e2f76b2438e7813f62873a50c203
+Source0:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-%{version}.tar.bz2
+# Source0-md5: 9f3e6ebfa32f2fb752d20a6c6394c397
+Source1:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-lite-%{version}.tar.bz2
+# Source1-md5: ccc95c5589a8c5c1edda508759aebcba
+Source2:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}6-%{version}.tar.bz2
+# Source2-md5: 1cfccf231f697a65ff112863c98f74a8
+Source3:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}6-lite-%{version}.tar.bz2
+# Source3-md5: e43bf15daf46ccb4fbd045a3689ea308
+Source4:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-init-%{version}.tar.bz2
+# Source4-md5: 63d61b6855d29e985d3e0e6fcf6b1106
+Source5:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-core-%{version}.tar.bz2
+# Source5-md5: 44337f9484303f855df527ffb09e8087
 Source10:      %{name}.init
 Source11:      %{name}.logrotate
 Patch0:                %{name}-config.patch
@@ -138,8 +140,9 @@ and shutdown.
 %setup -qcT -a0 -a1 -a2 -a3 -a4 -a5
 targets="shorewall-core shorewall shorewall-lite shorewall6 shorewall6-lite shorewall-init"
 for i in $targets; do
-       cp -p $i-%{version}/shorewallrc.{redhat,tld}
-       %{__sed} -i -r -e 's!RedHat/Fedora!TLD !; s/^HOST\=redhat/HOST\=tld/; /^(SERVICEDIR|SERVICEFILE)/d;' $i-%{version}/shorewallrc.tld
+        mv $i-%{version} $i
+       cp -p $i/shorewallrc.{redhat,tld}
+       %{__sed} -i -r -e 's!RedHat/Fedora!TLD !; s/^HOST\=redhat/HOST\=tld/; /^(SERVICEDIR|SERVICEFILE)/d;' $i/shorewallrc.tld
 done
 %patch0 -p1
 %patch1 -p1
@@ -157,7 +160,7 @@ rm -rf $RPM_BUILD_ROOT
 
 targets="shorewall-core shorewall shorewall-lite shorewall6 shorewall6-lite shorewall-init"
 for i in $targets; do
-       cd $i-%{version}
+       cd $i
        ./configure \
                VENDOR=tld \
                LIBEXECDIR=%{_libexecdir} \
@@ -187,7 +190,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc shorewall-%{version}/{COPYING,changelog.txt,releasenotes.txt,Samples}
+%doc shorewall/{COPYING,changelog.txt,releasenotes.txt,Samples}
 %attr(755,root,root) %{_sbindir}/shorewall
 %dir %{_sysconfdir}/shorewall
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall/*
@@ -201,7 +204,6 @@ fi
 %{_datadir}/shorewall/lib.core
 %{_datadir}/shorewall/lib.runtime
 %{_datadir}/shorewall/macro.*
-%{_datadir}/shorewall/modules*
 %{_datadir}/shorewall/prog.*
 %{_datadir}/shorewall/version
 %attr(755,root,root) %{_libexecdir}/shorewall/compiler.pl
@@ -219,7 +221,7 @@ fi
 
 %files lite
 %defattr(644,root,root,755)
-%doc shorewall-lite-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall-lite/{COPYING,changelog.txt,releasenotes.txt}
 %attr(755,root,root) %{_sbindir}/shorewall-lite
 %dir %{_sysconfdir}/shorewall-lite
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall-lite/shorewall-lite.conf
@@ -233,7 +235,7 @@ fi
 
 %files -n shorewall6
 %defattr(644,root,root,755)
-%doc shorewall6-%{version}/{COPYING,changelog.txt,releasenotes.txt,Samples6}
+%doc shorewall6/{COPYING,changelog.txt,releasenotes.txt,Samples6}
 %attr(755,root,root) %{_sbindir}/shorewall6
 %dir %{_sysconfdir}/shorewall6
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall6/*
@@ -248,7 +250,7 @@ fi
 
 %files -n shorewall6-lite
 %defattr(644,root,root,755)
-%doc shorewall6-lite-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall6-lite/{COPYING,changelog.txt,releasenotes.txt}
 %attr(755,root,root) %{_sbindir}/shorewall6-lite
 %dir %{_sysconfdir}/shorewall6-lite
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall6-lite/shorewall6-lite.conf
@@ -263,7 +265,7 @@ fi
 
 %files core
 %defattr(644,root,root,755)
-%doc shorewall-core-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall-core/{COPYING,changelog.txt,releasenotes.txt}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall
 %dir %{_datadir}/shorewall/
 %{_datadir}/shorewall/coreversion
@@ -277,7 +279,7 @@ fi
 
 %files init
 %defattr(644,root,root,755)
-%doc shorewall-init-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall-init/{COPYING,changelog.txt,releasenotes.txt}
 %attr(755,root,root) %{_sbindir}/shorewall-init
 %attr(755,root,root) %{_sysconfdir}/NetworkManager/dispatcher.d/01-shorewall
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/shorewall-init