]> TLD Linux GIT Repositories - packages/shorewall.git/blobdiff - shorewall.spec
- updated to 5.2.1
[packages/shorewall.git] / shorewall.spec
index 9dec2f2cf00851d22b176afa382fc1e462e46c6f..bd9598d2f72780620c69609c5647d43af74ef12a 100644 (file)
@@ -2,25 +2,28 @@
 # A very helpful document for packaging Shorewall is "Anatomy of Shorewall 4.0"
 # which is found at http://www.shorewall.net/Anatomy.html
 #
+%define                ver     5.2.1
+%define                rel     %{nil}
+
 Summary:       Shoreline Firewall - an iptables-based firewall for Linux systems
 Summary(pl.UTF-8):     Shoreline Firewall - zapora sieciowa oparta na iptables
 Name:          shorewall
-Version:       5.2.0.5
-Release:       2
+Version:       %{ver}%{rel}
+Release:       1
 License:       GPL
 Group:         Networking/Utilities
-Source0:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-%{version}.tar.bz2
-# Source0-md5: 3fb5f8c1f0012c0221681bc6d62b84a3
-Source1:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-lite-%{version}.tar.bz2
-# Source1-md5: 821f5b69ba22fb9950195647ff3ad223
-Source2:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}6-%{version}.tar.bz2
-# Source2-md5: 7f8a9fcc0227e50b21da553acb99f764
-Source3:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}6-lite-%{version}.tar.bz2
-# Source3-md5: 57fbbf639a3351212c02026ba0e7b89d
-Source4:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-init-%{version}.tar.bz2
-# Source4-md5: 87cc6453104a65fac36996a86469157e
-Source5:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/%{name}-core-%{version}.tar.bz2
-# Source5-md5: 16e6505831f5c1bc19c08d8982a4becc
+Source0:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-%{version}.tar.bz2
+# Source0-md5: 904a6b38d97bbdfc97b2713ac7f902e2
+Source1:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-lite-%{version}.tar.bz2
+# Source1-md5: 3ebbacbe1414588c01f068264f97de4b
+Source2:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}6-%{version}.tar.bz2
+# Source2-md5: d6597b128ff6affef5d7d1dc8b6cd90c
+Source3:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}6-lite-%{version}.tar.bz2
+# Source3-md5: c267e40785d85a2b607234b7388be5b1
+Source4:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-init-%{version}.tar.bz2
+# Source4-md5: 6f0365f0d1401221d319844f027b49b5
+Source5:       http://www.shorewall.net/pub/shorewall/5.2/shorewall-%{ver}/%{name}-core-%{version}.tar.bz2
+# Source5-md5: ca867aed49a68c58be90add6be937fb2
 Source10:      %{name}.init
 Source11:      %{name}.logrotate
 Patch0:                %{name}-config.patch
@@ -29,7 +32,6 @@ Patch2:               tld.patch
 Patch3:                man.patch
 Patch4:                init.patch
 Patch5:                shell-fix.patch
-Patch6:                perl.patch
 URL:           http://www.shorewall.net/
 BuildRequires: perl
 BuildRequires: perl(Digest::SHA)
@@ -138,8 +140,9 @@ and shutdown.
 %setup -qcT -a0 -a1 -a2 -a3 -a4 -a5
 targets="shorewall-core shorewall shorewall-lite shorewall6 shorewall6-lite shorewall-init"
 for i in $targets; do
-       cp -p $i-%{version}/shorewallrc.{redhat,tld}
-       %{__sed} -i -r -e 's!RedHat/Fedora!TLD !; s/^HOST\=redhat/HOST\=tld/; /^(SERVICEDIR|SERVICEFILE)/d;' $i-%{version}/shorewallrc.tld
+        mv $i-%{version} $i
+       cp -p $i/shorewallrc.{redhat,tld}
+       %{__sed} -i -r -e 's!RedHat/Fedora!TLD !; s/^HOST\=redhat/HOST\=tld/; /^(SERVICEDIR|SERVICEFILE)/d;' $i/shorewallrc.tld
 done
 %patch0 -p1
 %patch1 -p1
@@ -147,7 +150,6 @@ done
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 # Remove hash-bang from files which are not directly executed as shell
 # scripts. This silences some rpmlint errors.
@@ -158,7 +160,7 @@ rm -rf $RPM_BUILD_ROOT
 
 targets="shorewall-core shorewall shorewall-lite shorewall6 shorewall6-lite shorewall-init"
 for i in $targets; do
-       cd $i-%{version}
+       cd $i
        ./configure \
                VENDOR=tld \
                LIBEXECDIR=%{_libexecdir} \
@@ -188,7 +190,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc shorewall-%{version}/{COPYING,changelog.txt,releasenotes.txt,Samples}
+%doc shorewall/{COPYING,changelog.txt,releasenotes.txt,Samples}
 %attr(755,root,root) %{_sbindir}/shorewall
 %dir %{_sysconfdir}/shorewall
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall/*
@@ -220,7 +222,7 @@ fi
 
 %files lite
 %defattr(644,root,root,755)
-%doc shorewall-lite-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall-lite/{COPYING,changelog.txt,releasenotes.txt}
 %attr(755,root,root) %{_sbindir}/shorewall-lite
 %dir %{_sysconfdir}/shorewall-lite
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall-lite/shorewall-lite.conf
@@ -234,7 +236,7 @@ fi
 
 %files -n shorewall6
 %defattr(644,root,root,755)
-%doc shorewall6-%{version}/{COPYING,changelog.txt,releasenotes.txt,Samples6}
+%doc shorewall6/{COPYING,changelog.txt,releasenotes.txt,Samples6}
 %attr(755,root,root) %{_sbindir}/shorewall6
 %dir %{_sysconfdir}/shorewall6
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall6/*
@@ -249,7 +251,7 @@ fi
 
 %files -n shorewall6-lite
 %defattr(644,root,root,755)
-%doc shorewall6-lite-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall6-lite/{COPYING,changelog.txt,releasenotes.txt}
 %attr(755,root,root) %{_sbindir}/shorewall6-lite
 %dir %{_sysconfdir}/shorewall6-lite
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/shorewall6-lite/shorewall6-lite.conf
@@ -264,7 +266,7 @@ fi
 
 %files core
 %defattr(644,root,root,755)
-%doc shorewall-core-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall-core/{COPYING,changelog.txt,releasenotes.txt}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/shorewall
 %dir %{_datadir}/shorewall/
 %{_datadir}/shorewall/coreversion
@@ -278,7 +280,7 @@ fi
 
 %files init
 %defattr(644,root,root,755)
-%doc shorewall-init-%{version}/{COPYING,changelog.txt,releasenotes.txt}
+%doc shorewall-init/{COPYING,changelog.txt,releasenotes.txt}
 %attr(755,root,root) %{_sbindir}/shorewall-init
 %attr(755,root,root) %{_sysconfdir}/NetworkManager/dispatcher.d/01-shorewall
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/shorewall-init