]> TLD Linux GIT Repositories - packages/systemtap.git/blobdiff - systemtap.spec
- rediffed patches
[packages/systemtap.git] / systemtap.spec
index b43d6a9882de304ef871c2d81fd2f208a97fef7a..04c911e44c28eec0063472fb3a68b0e7e6b26dab 100644 (file)
@@ -3,12 +3,12 @@
 %bcond_without doc             # documentation build
 %bcond_with    publican        # publican guides build [as of 3.0 not rebuilt automatically, PDFs are included]
 %bcond_without crash           # crash extension
-%bcond_without dyninst         # dyninst support
+%bcond_with    dyninst         # dyninst support
 %bcond_without java            # Java runtime support
 %bcond_without python2         # Python 2.x runtime support
 %bcond_without python3         # Python 3.x runtime support
 
-%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc64 s390 s390x
+%ifnarch %{ix86} %{x8664} x32 alpha arm ia64 ppc64 s390 s390x
 %undefine      with_crash
 %endif
 %ifnarch %{ix86} %{x8664} x32 ppc ppc64 aarch64
 Summary:       Instrumentation System
 Summary(pl.UTF-8):     System oprzyrzÄ…dowania
 Name:          systemtap
-Version:       3.2
-Release:       2
+Version:       3.3
+Release:       6
 License:       GPL v2+
 Group:         Base
 Source0:       http://sourceware.org/systemtap/ftp/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 457147cde312eab7ff8cb49add93f4b4
+# Source0-md5: 7f80117649a9eb663781b5372e8a4f96
 Patch0:                %{name}-configure.patch
 Patch1:                %{name}-build.patch
 Patch2:                %{name}-rpm-4.5-support.patch
@@ -40,7 +40,7 @@ BuildRequires:        docbook-dtd412-xml
 BuildRequires: elfutils-devel >= 0.148
 BuildRequires: gettext-devel >= 0.19.4
 BuildRequires: gettext-tools >= 0.19.4
-BuildRequires: glib2-devel
+BuildRequires: glib2-devel >= 2.0
 BuildRequires: json-c-devel >= 0.12
 %{?with_java:BuildRequires:    jdk}
 %if %{with dyninst} || %{with java}
@@ -64,7 +64,6 @@ BuildRequires:        python3-setuptools
 BuildRequires: readline-devel
 BuildRequires: rpm-devel
 %{?with_java:BuildRequires:    rpm-javaprov}
-BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sqlite3-devel >= 3.7
 BuildRequires: xmlto
@@ -351,10 +350,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/stapsh
 # XXX: %attr(4754,root,stapusr) staprun ?
 %attr(755,root,root) %{_bindir}/staprun
+%dir %{_libexecdir}/%{name}
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-authorize-cert
+%attr(755,root,root) %{_libexecdir}/%{name}/stapio
+%if %{with crash}
+%if "%{_libdir}" != "%{_libexecdir}"
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/stap-authorize-cert
-%attr(755,root,root) %{_libdir}/%{name}/stapio
-%{?with_crash:%attr(755,root,root) %{_libdir}/%{name}/staplog.so}
+%endif
+%attr(755,root,root) %{_libdir}/%{name}/staplog.so
+%endif
 %{_mandir}/man1/stap-merge.1*
 %{_mandir}/man1/stap-report.1*
 %{_mandir}/man1/stapref.1*
@@ -394,9 +398,9 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with java}
 %files runtime-java
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/stapbm
-%attr(755,root,root) %{_libdir}/%{name}/libHelperSDT_*.so
-%{_libdir}/%{name}/HelperSDT.jar
+%attr(755,root,root) %{_libexecdir}/%{name}/stapbm
+%attr(755,root,root) %{_libexecdir}/%{name}/libHelperSDT_*.so
+%{_libexecdir}/%{name}/HelperSDT.jar
 %endif
 
 %if %{with python2}
@@ -437,8 +441,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/runtime
 %if %{with python2} || %{with python3}
-%dir %{_libexecdir}/systemtap
-%dir %{_libexecdir}/systemtap/python
+%dir %{_libexecdir}/%{name}
+%dir %{_libexecdir}/%{name}/python
 %attr(755,root,root) %{_libexecdir}/systemtap/python/stap-resolve-module-function.py
 %endif
 
@@ -455,12 +459,12 @@ rm -rf $RPM_BUILD_ROOT
 %files server
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/stap-server
-%attr(755,root,root) %{_libdir}/%{name}/stap-env
-%attr(755,root,root) %{_libdir}/%{name}/stap-gen-cert
-%attr(755,root,root) %{_libdir}/%{name}/stap-serverd
-%attr(755,root,root) %{_libdir}/%{name}/stap-sign-module
-%attr(755,root,root) %{_libdir}/%{name}/stap-start-server
-%attr(755,root,root) %{_libdir}/%{name}/stap-stop-server
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-env
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-gen-cert
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-serverd
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-sign-module
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-start-server
+%attr(755,root,root) %{_libexecdir}/%{name}/stap-stop-server
 %dir %{_sysconfdir}/stap-server
 %dir %{_sysconfdir}/stap-server/conf.d
 %attr(754,root,root) /etc/rc.d/init.d/stap-server