]> TLD Linux GIT Repositories - packages/tigervnc.git/commitdiff
- udpated to 1.8.0, patches from Fedora
authorMarcin Krol <hawk@tld-linux.org>
Thu, 15 Mar 2018 09:07:30 +0000 (09:07 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 15 Mar 2018 09:07:30 +0000 (09:07 +0000)
tigervnc-as-needed.patch [deleted file]
tigervnc-cookie.patch [deleted file]
tigervnc-getmaster.patch
tigervnc-manpages.patch [new file with mode: 0644]
tigervnc-pointersync.patch [deleted file]
tigervnc-rh692048.patch [deleted file]
tigervnc-shebang.patch [new file with mode: 0644]
tigervnc-utilize-system-crypto-policies.patch [new file with mode: 0644]
tigervnc-xstartup.patch
tigervnc.spec
xserver.patch

diff --git a/tigervnc-as-needed.patch b/tigervnc-as-needed.patch
deleted file mode 100644 (file)
index 9114eea..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am~   2011-04-20 13:46:16.993047050 +0200
-+++ tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am    2011-04-20 14:03:35.942724608 +0200
-@@ -1,11 +1,12 @@
- TIGERVNC_SRCDIR=${top_srcdir}/../..
- LIB_DIR=${top_builddir}/../../common
-+OS_LIB=$(LIB_DIR)/os/libos.a
- RFB_LIB=$(LIB_DIR)/rfb/librfb.la
- RDR_LIB=$(LIB_DIR)/rdr/librdr.la
- NETWORK_LIB=$(LIB_DIR)/network/libnetwork.la
- XREGION_LIB=$(LIB_DIR)/Xregion/libXregion.la
--COMMON_LIBS=$(NETWORK_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
-+COMMON_LIBS=$(NETWORK_LIB) $(OS_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
- noinst_LTLIBRARIES = libvnccommon.la
diff --git a/tigervnc-cookie.patch b/tigervnc-cookie.patch
deleted file mode 100644 (file)
index c066a5f..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -up tigervnc-1.0.90-20091221svn3929/unix/vncserver.cookie tigervnc-1.0.90-20091221svn3929/unix/vncserver
---- tigervnc-1.0.90-20091221svn3929/unix/vncserver.cookie      2009-11-12 11:39:54.000000000 +0100
-+++ tigervnc-1.0.90-20091221svn3929/unix/vncserver     2009-12-21 16:15:01.907799091 +0100
-@@ -189,27 +189,12 @@ $vncPort = 5900 + $displayNumber;
- $desktopLog = "$vncUserDir/$host:$displayNumber.log";
- unlink($desktopLog);
--# Make an X server cookie - use /dev/urandom on systems that have it,
--# otherwise use perl's random number generator, seeded with the sum
--# of the current time, our PID and part of the encrypted form of the password.
--
--my $cookie = "";
--if (open(URANDOM, '<', '/dev/urandom')) {
--  my $randata;
--  if (sysread(URANDOM, $randata, 16) == 16) {
--    $cookie = unpack 'h*', $randata;
--  }
--  close(URANDOM);
--}
--if ($cookie eq "") {
--  srand(time+$$+unpack("L",`cat $vncUserDir/passwd`));
--  for (1..16) {
--    $cookie .= sprintf("%02x", int(rand(256)) % 256);
--  }
--}
--
--system("xauth -f $xauthorityFile add $host:$displayNumber . $cookie");
--system("xauth -f $xauthorityFile add $host/unix:$displayNumber . $cookie"); 
-+# Make an X server cookie - use mcookie
-+$cookie = `/usr/bin/mcookie`;
-+open (XAUTH, "|xauth -f $xauthorityFile source -");
-+print XAUTH "add $host:$displayNumber . $cookie\n";
-+print XAUTH "add $host/unix:$displayNumber . $cookie\n";
-+close XAUTH;
- if ($opt{'-name'}) {
-     $desktopName = $opt{'-name'};
index ddfd1a5c6dcfb4f0da9097b86dd4c680836ee14b..e87998766ad2d104647b08f32c0f80001fa439e8 100644 (file)
@@ -1,6 +1,7 @@
---- tigervnc-1.5.0/unix/xserver/hw/vnc/InputXKB.c      2015-07-28 05:43:09.554174840 +0000
-+++ tigervnc-1.5.0/unix/xserver/hw/vnc/InputXKB.c      2015-07-28 08:18:46.217591974 +0000
-@@ -210,10 +210,7 @@ void vncPrepareInputDevices(void)
+diff -urpa tigervnc-1.8.0.orig/unix/xserver/hw/vnc/InputXKB.c tigervnc-1.8.0/unix/xserver/hw/vnc/InputXKB.c
+--- tigervnc-1.8.0.orig/unix/xserver/hw/vnc/InputXKB.c 2017-05-16 13:53:28.000000000 +0000
++++ tigervnc-1.8.0/unix/xserver/hw/vnc/InputXKB.c      2018-03-14 13:40:39.471889909 +0000
+@@ -214,10 +214,7 @@ void vncPrepareInputDevices(void)
  
  unsigned vncGetKeyboardState(void)
  {
@@ -12,7 +13,7 @@
  }
  
  unsigned vncGetLevelThreeMask(void)
-@@ -234,7 +231,7 @@ unsigned vncGetLevelThreeMask(void)
+@@ -238,7 +235,7 @@ unsigned vncGetLevelThreeMask(void)
                        return 0;
        }
  
@@ -21,7 +22,7 @@
  
        act = XkbKeyActionPtr(xkb, keycode, state);
        if (act == NULL)
-@@ -259,7 +256,7 @@ KeyCode vncPressShift(void)
+@@ -263,7 +260,7 @@ KeyCode vncPressShift(void)
        if (state & ShiftMask)
                return 0;
  
@@ -30,7 +31,7 @@
        for (key = xkb->min_key_code; key <= xkb->max_key_code; key++) {
                XkbAction *act;
                unsigned char mask;
-@@ -299,7 +296,7 @@ size_t vncReleaseShift(KeyCode *keys, si
+@@ -303,7 +300,7 @@ size_t vncReleaseShift(KeyCode *keys, si
  
        count = 0;
  
@@ -39,7 +40,7 @@
        xkb = master->key->xkbInfo->desc;
        for (key = xkb->min_key_code; key <= xkb->max_key_code; key++) {
                XkbAction *act;
-@@ -355,7 +352,7 @@ KeyCode vncPressLevelThree(void)
+@@ -359,7 +356,7 @@ KeyCode vncPressLevelThree(void)
                        return 0;
        }
  
@@ -48,7 +49,7 @@
  
        act = XkbKeyActionPtr(xkb, keycode, state);
        if (act == NULL)
-@@ -386,7 +383,7 @@ size_t vncReleaseLevelThree(KeyCode *key
+@@ -390,7 +387,7 @@ size_t vncReleaseLevelThree(KeyCode *key
  
        count = 0;
  
@@ -57,7 +58,7 @@
        xkb = master->key->xkbInfo->desc;
        for (key = xkb->min_key_code; key <= xkb->max_key_code; key++) {
                XkbAction *act;
-@@ -429,7 +426,7 @@ KeyCode vncKeysymToKeycode(KeySym keysym
+@@ -433,7 +430,7 @@ KeyCode vncKeysymToKeycode(KeySym keysym
        if (new_state != NULL)
                *new_state = state;
  
@@ -66,7 +67,7 @@
        for (key = xkb->min_key_code; key <= xkb->max_key_code; key++) {
                unsigned int state_out;
                KeySym dummy;
-@@ -486,7 +483,7 @@ int vncIsLockModifier(KeyCode keycode, u
+@@ -490,7 +487,7 @@ int vncIsLockModifier(KeyCode keycode, u
        XkbDescPtr xkb;
        XkbAction *act;
  
@@ -75,7 +76,7 @@
  
        act = XkbKeyActionPtr(xkb, keycode, state);
        if (act == NULL)
-@@ -524,7 +521,7 @@ int vncIsAffectedByNumLock(KeyCode keyco
+@@ -528,7 +525,7 @@ int vncIsAffectedByNumLock(KeyCode keyco
        if (numlock_keycode == 0)
                return 0;
  
@@ -84,7 +85,7 @@
  
        act = XkbKeyActionPtr(xkb, numlock_keycode, state);
        if (act == NULL)
-@@ -558,7 +555,7 @@ KeyCode vncAddKeysym(KeySym keysym, unsi
+@@ -562,7 +559,7 @@ KeyCode vncAddKeysym(KeySym keysym, unsi
        KeySym *syms;
        KeySym upper, lower;
  
diff --git a/tigervnc-manpages.patch b/tigervnc-manpages.patch
new file mode 100644 (file)
index 0000000..5919226
--- /dev/null
@@ -0,0 +1,28 @@
+diff --git a/unix/vncserver b/unix/vncserver
+index c4d0535..08a9308 100755
+--- a/unix/vncserver
++++ b/unix/vncserver
+@@ -637,6 +637,7 @@ sub Usage
+       "                 [-geometry <width>x<height>]\n".
+       "                 [-pixelformat rgbNNN|bgrNNN]\n".
+       "                 [-fp <font-path>]\n".
++      "                 [-cc <visual>]\n".
+       "                 [-fg]\n".
+       "                 [-autokill]\n".
+       "                 [-noxstartup]\n".
+diff --git a/vncviewer/vncviewer.cxx b/vncviewer/vncviewer.cxx
+index a2bc029..6923d0e 100644
+--- a/vncviewer/vncviewer.cxx
++++ b/vncviewer/vncviewer.cxx
+@@ -338,6 +338,11 @@ static void usage(const char *programName)
+           "       %s [parameters] -listen [port] [parameters]\n",
+           programName, programName);
+   fprintf(stderr,"\n"
++        "Options:\n\n"
++        "  -display Xdisplay - Specifies the X display for the viewer window\n"
++        "  -geometry geometry - Standard X position and sizing specification.\n");
++
++  fprintf(stderr,"\n"
+           "Parameters can be turned on with -<param> or off with -<param>=0\n"
+           "Parameters which take a value can be specified as "
+           "-<param> <value>\n"
diff --git a/tigervnc-pointersync.patch b/tigervnc-pointersync.patch
deleted file mode 100644 (file)
index 3ac8f2c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -up tigervnc-1.3.0/unix/xserver/hw/vnc/Input.cc.pointersync tigervnc-1.3.0/unix/xserver/hw/vnc/Input.cc
---- tigervnc-1.3.0/unix/xserver/hw/vnc/Input.cc.pointersync    2014-07-14 16:27:49.412251632 +0100
-+++ tigervnc-1.3.0/unix/xserver/hw/vnc/Input.cc        2014-07-14 16:29:06.968643301 +0100
-@@ -1,5 +1,5 @@
- /* Copyright (C) 2009 TightVNC Team
-- * Copyright (C) 2009 Red Hat, Inc.
-+ * Copyright (C) 2009, 2014 Red Hat, Inc.
-  * Copyright 2013 Pierre Ossman for Cendio AB
-  *
-  * This is free software; you can redistribute it and/or modify
-@@ -202,6 +202,14 @@ void InputDevice::PointerMove(const rfb:
- const rfb::Point &InputDevice::getPointerPos(void)
- {
-+      if (pointerDev != NULL) {
-+              int x, y;
-+
-+              GetSpritePosition (pointerDev, &x, &y);
-+              cursorPos.x = x;
-+              cursorPos.y = y;
-+      }
-+
-       return cursorPos;
- }
diff --git a/tigervnc-rh692048.patch b/tigervnc-rh692048.patch
deleted file mode 100644 (file)
index 310cb1b..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -up tigervnc-1.4.2/common/rfb/SecurityClient.cxx.rh692048 tigervnc-1.4.2/common/rfb/SecurityClient.cxx
---- tigervnc-1.4.2/common/rfb/SecurityClient.cxx.rh692048      2015-02-12 18:32:50.168861186 +0000
-+++ tigervnc-1.4.2/common/rfb/SecurityClient.cxx       2015-02-12 18:33:13.168003696 +0000
-@@ -49,7 +49,7 @@ StringParameter SecurityClient::secTypes
- #endif
-  ")",
- #ifdef HAVE_GNUTLS
-- "X509Plain,TLSPlain,X509Vnc,TLSVnc,X509None,TLSNone,VncAuth,None",
-+ "VeNCrypt,X509Plain,TLSPlain,X509Vnc,TLSVnc,X509None,TLSNone,VncAuth,None",
- #else
-  "VncAuth,None",
- #endif
-diff -up tigervnc-1.4.2/common/rfb/Security.cxx.rh692048 tigervnc-1.4.2/common/rfb/Security.cxx
---- tigervnc-1.4.2/common/rfb/Security.cxx.rh692048    2015-01-23 23:37:23.000000000 +0000
-+++ tigervnc-1.4.2/common/rfb/Security.cxx     2015-02-12 18:32:50.168861186 +0000
-@@ -68,7 +68,6 @@ const std::list<rdr::U8> Security::GetEn
-   list<rdr::U8> result;
-   list<U32>::iterator i;
--  result.push_back(secTypeVeNCrypt);
-   for (i = enabledSecTypes.begin(); i != enabledSecTypes.end(); i++)
-     if (*i < 0x100)
-       result.push_back(*i);
-@@ -106,8 +105,6 @@ bool Security::IsSupported(U32 secType)
-   for (i = enabledSecTypes.begin(); i != enabledSecTypes.end(); i++)
-     if (*i == secType)
-       return true;
--  if (secType == secTypeVeNCrypt)
--    return true;
-   return false;
- }
-diff -up tigervnc-1.4.2/common/rfb/SecurityServer.cxx.rh692048 tigervnc-1.4.2/common/rfb/SecurityServer.cxx
---- tigervnc-1.4.2/common/rfb/SecurityServer.cxx.rh692048      2015-02-12 18:32:50.168861186 +0000
-+++ tigervnc-1.4.2/common/rfb/SecurityServer.cxx       2015-02-12 18:33:24.977076868 +0000
-@@ -43,7 +43,7 @@ StringParameter SecurityServer::secTypes
- #endif
-  ")",
- #ifdef HAVE_GNUTLS
-- "TLSVnc,VncAuth",
-+ "VncAuth",
- #else
-  "VncAuth",
- #endif
diff --git a/tigervnc-shebang.patch b/tigervnc-shebang.patch
new file mode 100644 (file)
index 0000000..f76af87
--- /dev/null
@@ -0,0 +1,9 @@
+diff -up tigervnc-1.3.0/unix/vncserver.shebang tigervnc-1.3.0/unix/vncserver
+--- tigervnc-1.3.0/unix/vncserver.shebang      2013-07-24 12:22:34.962158378 +0100
++++ tigervnc-1.3.0/unix/vncserver      2013-07-24 12:22:41.593188190 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env perl
++#!/usr/bin/perl
+ #
+ #  Copyright (C) 2009-2010 D. R. Commander.  All Rights Reserved.
+ #  Copyright (C) 2005-2006 Sun Microsystems, Inc.  All Rights Reserved.
diff --git a/tigervnc-utilize-system-crypto-policies.patch b/tigervnc-utilize-system-crypto-policies.patch
new file mode 100644 (file)
index 0000000..dbf0dab
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/common/rfb/Security.cxx b/common/rfb/Security.cxx
+index e623ab5..4987b29 100644
+--- a/common/rfb/Security.cxx
++++ b/common/rfb/Security.cxx
+@@ -52,7 +52,7 @@ static LogWriter vlog("Security");
+ #ifdef HAVE_GNUTLS
+ StringParameter Security::GnuTLSPriority("GnuTLSPriority",
+   "GnuTLS priority string that controls the TLS session’s handshake algorithms",
+-  "NORMAL");
++  "@SYSTEM");
+ #endif
+
+ Security::Security()
index 610511d138f0057bb71882506fedbda9b1cdb0bd..a66f70ba43a269aace1e5a29b7d5ed46e301184d 100644 (file)
@@ -1,8 +1,8 @@
-diff -ur tigervnc-1.3.0.orig/unix/vncserver tigervnc-1.3.0/unix/vncserver
---- tigervnc-1.3.0.orig/unix/vncserver 2013-07-18 16:37:54.000000000 +0000
-+++ tigervnc-1.3.0/unix/vncserver      2013-07-21 21:01:17.590116481 +0000
-@@ -57,27 +57,13 @@
+diff -urpa tigervnc-1.8.0.orig/unix/vncserver tigervnc-1.8.0/unix/vncserver
+--- tigervnc-1.8.0.orig/unix/vncserver 2017-05-16 13:53:28.000000000 +0000
++++ tigervnc-1.8.0/unix/vncserver      2018-03-14 13:35:05.810893666 +0000
+@@ -61,27 +61,13 @@ $xauthorityFile = "$ENV{XAUTHORITY}" ||
+ $xstartupFile = $vncUserDir . "/xstartup";
  $defaultXStartup
      = ("#!/bin/sh\n\n".
 -       "unset SESSION_MANAGER\n".
@@ -35,12 +35,3 @@ diff -ur tigervnc-1.3.0.orig/unix/vncserver tigervnc-1.3.0/unix/vncserver
         "xterm -geometry 80x24+10+10 -ls -title \"\$VNCDESKTOP Desktop\" &\n".
         "twm &\n");
  
-@@ -322,8 +308,6 @@
- }
- $ENV{VNCDESKTOP}= $desktopName;
--system($exedir."vncconfig -iconic >> " . &quotedString($desktopLog) . " 2>&1 &");
--
- if ($opt{'-fg'}) {
-     system("$vncUserDir/xstartup >> " . &quotedString($desktopLog) . " 2>&1");
-     if (kill 0, `cat $pidFile`) {
index 6d55fb2a0fd04d32bd46e6015e13a175c9eb7187..29a6d6d156befeabe06e8e3b91dbc821a5ef9e96 100644 (file)
@@ -1,22 +1,22 @@
-%define                xversion        1.17.0
+%define                xversion        1.19.0
 
 Summary:       A TigerVNC remote display system
 Summary(pl.UTF-8):     System zdalnego dostępu TigerVNC
 Name:          tigervnc
-Version:       1.5.0
+Version:       1.8.0
 Release:       1
 License:       GPL v2
 Group:         X11/Applications/Networking
 Source0:       https://github.com/TigerVNC/tigervnc/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
-# Source0-md5: b11cc4c4d5249b9b8e355ee6f47ec4fe
+# Source0-md5: 5c9a80dd4b99b4eb19f535db5ce5830f
 Source1:       %{name}.desktop
 Source2:       vncserver.init
 Source3:       vncserver.sysconfig
-Patch0:                %{name}-cookie.patch
-Patch1:                %{name}-as-needed.patch
-Patch2:                %{name}-rh692048.patch
-Patch3:                tigervnc-xstartup.patch
-Patch4:                tigervnc-getmaster.patch
+Patch0:                %{name}-manpages.patch
+Patch1:                %{name}-shebang.patch
+Patch2:                %{name}-utilize-system-crypto-policies.patch
+Patch3:                %{name}-xstartup.patch
+Patch4:                %{name}-getmaster.patch
 Patch5:                xserver.patch
 URL:           http://www.tigervnc.com/
 BuildRequires: ImageMagick
@@ -217,9 +217,9 @@ export CXXFLAGS="%{rpmcxxflags} -fpermissive"
        --with-pic \
        --disable-static \
        --disable-xinerama \
-       --disable-composite \
        --disable-wayland \
        --disable-xwayland \
+       --enable-composite \
        --enable-glx \
        --enable-glx-tls \
        --enable-aiglx \
index f418680cb495a17be8a93916da7310d51f2d81e0..614f104a4d4d47137fa1e063647794fe119e20d1 100644 (file)
@@ -1,26 +1,26 @@
-diff -up xserver/configure.ac.vnc xserver/configure.ac
---- xserver/configure.ac.vnc   2012-08-28 15:35:23.778810954 +0200
-+++ xserver/configure.ac       2012-08-28 15:54:46.396743431 +0200
-@@ -73,6 +72,7 @@ dnl forcing an entire recompile.x
+diff -up xserver/configure.ac.xserver116-rebased xserver/configure.ac
+--- xserver/configure.ac.xserver116-rebased    2016-09-29 13:14:45.595441590 +0200
++++ xserver/configure.ac       2016-09-29 13:14:45.631442006 +0200
+@@ -74,6 +74,7 @@ dnl forcing an entire recompile.x
  AC_CONFIG_HEADERS(include/version-config.h)
  
  AM_PROG_AS
 +AC_PROG_CXX
  AC_PROG_LN_S
- AC_LIBTOOL_WIN32_DLL
- AC_DISABLE_STATIC
-@@ -1561,6 +1561,10 @@ if test "x$XVFB" = xyes; then
+ LT_PREREQ([2.2])
+ LT_INIT([disable-static win32-dll])
+@@ -1863,6 +1864,10 @@ if test "x$XVFB" = xyes; then
        AC_SUBST([XVFB_SYS_LIBS])
  fi
  
 +dnl Xvnc DDX
 +AC_SUBST([XVNC_CPPFLAGS], ["-DHAVE_DIX_CONFIG_H $XSERVER_CFLAGS"])
-+AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB $PRESENT_LIB $DRI3_LIB"])
++AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $DRI3_LIB $PRESENT_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
 +AC_SUBST([XVNC_SYS_LIBS], ["$GLX_SYS_LIBS"])
  
  dnl Xnest DDX
  
-@@ -1596,6 +1600,8 @@ if test "x$XORG" = xauto; then
+@@ -1898,6 +1903,8 @@ if test "x$XORG" = xauto; then
  fi
  AC_MSG_RESULT([$XORG])
  
@@ -29,7 +29,7 @@ diff -up xserver/configure.ac.vnc xserver/configure.ac
  if test "x$XORG" = xyes; then
        XORG_DDXINCS='-I$(top_srcdir)/hw/xfree86 -I$(top_srcdir)/hw/xfree86/include -I$(top_srcdir)/hw/xfree86/common'
        XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
-@@ -1815,7 +1821,6 @@ if test "x$XORG" = xyes; then
+@@ -2116,7 +2123,6 @@ if test "x$XORG" = xyes; then
        AC_DEFINE(XORG_SERVER, 1, [Building Xorg server])
        AC_DEFINE(XORGSERVER, 1, [Building Xorg server])
        AC_DEFINE(XFree86Server, 1, [Building XFree86 server])
@@ -37,7 +37,7 @@ diff -up xserver/configure.ac.vnc xserver/configure.ac
        AC_DEFINE(NEED_XF86_TYPES, 1, [Need XFree86 typedefs])
        AC_DEFINE(NEED_XF86_PROTOTYPES, 1, [Need XFree86 helper functions])
        AC_DEFINE(__XSERVERNAME__, "Xorg", [Name of X server])
-@@ -2280,6 +2285,7 @@ hw/dmx/Makefile
+@@ -2691,6 +2697,7 @@ hw/dmx/Makefile
  hw/dmx/man/Makefile
  hw/vfb/Makefile
  hw/vfb/man/Makefile
@@ -45,10 +45,10 @@ diff -up xserver/configure.ac.vnc xserver/configure.ac
  hw/xnest/Makefile
  hw/xnest/man/Makefile
  hw/xwin/Makefile
-diff -up xserver/hw/Makefile.am.vnc xserver/hw/Makefile.am
---- xserver/hw/Makefile.am.vnc 2012-08-28 15:35:23.856810890 +0200
-+++ xserver/hw/Makefile.am     2012-08-28 15:35:42.272795917 +0200
-@@ -33,7 +33,8 @@ SUBDIRS =                    \
+diff -up xserver/hw/Makefile.am.xserver116-rebased xserver/hw/Makefile.am
+--- xserver/hw/Makefile.am.xserver116-rebased  2016-09-29 13:14:45.601441659 +0200
++++ xserver/hw/Makefile.am     2016-09-29 13:14:45.631442006 +0200
+@@ -38,7 +38,8 @@ SUBDIRS =                    \
        $(DMX_SUBDIRS)          \
        $(KDRIVE_SUBDIRS)       \
        $(XQUARTZ_SUBDIRS)      \
@@ -58,10 +58,10 @@ diff -up xserver/hw/Makefile.am.vnc xserver/hw/Makefile.am
  
  DIST_SUBDIRS = dmx xfree86 vfb xnest xwin xquartz kdrive xwayland
  
-diff -up xserver/mi/miinitext.c.vnc xserver/mi/miinitext.c
---- xserver/mi/miinitext.c.vnc 2012-08-28 15:35:23.000000000 +0200
-+++ xserver/mi/miinitext.c     2012-09-05 15:07:40.714953972 +0200
-@@ -112,6 +112,10 @@ SOFTWARE.
+diff -up xserver/mi/miinitext.c.xserver116-rebased xserver/mi/miinitext.c
+--- xserver/mi/miinitext.c.xserver116-rebased  2016-09-29 13:14:45.618441855 +0200
++++ xserver/mi/miinitext.c     2016-09-29 13:14:45.631442006 +0200
+@@ -114,6 +114,10 @@ SOFTWARE.
  #include "micmap.h"
  #include "globals.h"
  
@@ -72,13 +72,24 @@ diff -up xserver/mi/miinitext.c.vnc xserver/mi/miinitext.c
  /* The following is only a small first step towards run-time
   * configurable extensions.
   */
-@@ -299,6 +303,9 @@ static ExtensionModule staticExtensions[
- #ifdef XSELINUX
-     {SELinuxExtensionInit, SELINUX_EXTENSION_NAME, &noSELinuxExtension},
- #endif
+@@ -238,6 +242,9 @@ EnableDisableExtensionError(const char *
+ /* List of built-in (statically linked) extensions */
+ static const ExtensionModule staticExtensions[] = {
 +#ifdef TIGERVNC
 +    {vncExtensionInit, "VNC-EXTENSION", NULL},
 +#endif
- };
- static ExtensionModule *ExtensionModuleList = NULL;
+     {GEExtensionInit, "Generic Event Extension", &noGEExtension},
+     {ShapeExtensionInit, "SHAPE", NULL},
+ #ifdef MITSHM
+--- xserver/include/os.h~      2016-10-03 09:07:29.000000000 +0200
++++ xserver/include/os.h       2016-10-03 14:13:00.013654506 +0200
+@@ -621,7 +621,7 @@
+ extern _X_EXPORT void
+ LogClose(enum ExitCode error);
+ extern _X_EXPORT Bool
+-LogSetParameter(LogParameter param, int value);
++LogSetParameter(enum _LogParameter param, int value);
+ extern _X_EXPORT void
+ LogVWrite(int verb, const char *f, va_list args)
+ _X_ATTRIBUTE_PRINTF(2, 0);