]> TLD Linux GIT Repositories - packages/udev.git/blobdiff - udev.spec
- apidocs bcond
[packages/udev.git] / udev.spec
index 737618986c4083a8cc4562de917a30392a245777..2250cdc8a088b0431282dae3dae059598c624c5b 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -1,15 +1,15 @@
 # TODO:
-#   - systemd have more rules, check them and add if possible
 #   - get rules patches from systemd (if any)
 #
 # Conditional build:
 %bcond_without selinux         # without SELinux support
+%bcond_with    apidocs         # with API docs
 
-Summary:       Device manager for the Linux 2.6 kernel series
-Summary(pl.UTF-8):     Zarządca urządzeń dla Linuksa 2.6
+Summary:       Device manager for the Linux kernel
+Summary(pl.UTF-8):     Zarządca urządzeń dla jądra Linuksa
 Name:          udev
 Version:       2.1.1
-Release:       0.1
+Release:       0.2
 Epoch:         2
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
@@ -38,7 +38,7 @@ BuildRequires:        glib2-devel >= 1:2.22.0
 BuildRequires: glibc-misc
 BuildRequires: gobject-introspection-devel >= 1.31.1
 BuildRequires: gperf
-BuildRequires: gtk-doc >= 1.18
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.18}
 BuildRequires: kmod-devel >= 14
 BuildRequires: libblkid-devel >= 2.20
 %{?with_selinux:BuildRequires: libselinux-devel >= 2.1.9}
@@ -69,14 +69,14 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _libexecdir     %{_prefix}/lib
 
 %description
-udev is the device manager for the Linux 2.6 kernel series. Its
-primary function is managing device nodes in /dev. It is the successor
-of devfs and hotplug.
+udev is the device manager for the Linux kernel. Its primary function
+is managing device nodes in /dev. It is the successor of devfs and
+hotplug.
 
 %description -l pl.UTF-8
-udev jest zarządcą urządzeń dla Linuksa 2.6. Jego główną funkcją jest
-zarządzanie węzłami urządzeń w katalogu /dev. Jest następcą devfs i
-hotpluga.
+udev jest zarządcą urządzeń dla jądra Linuksa. Jego główną funkcją
+jest zarządzanie węzłami urządzeń w katalogu /dev. Jest następcą devfs
+hotpluga.
 
 %package core
 Summary:       A userspace implementation of devfs - core part of udev
@@ -187,7 +187,9 @@ Dokumentacja API libgudev.
 %patch1 -p1
 
 %build
+%if %{with apidocs}
 %{__gtkdocize}
+%endif
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
@@ -197,12 +199,12 @@ Dokumentacja API libgudev.
         --libexecdir=/lib \
         --bindir=%{_sbindir} \
         %{?debug:--enable-debug} \
+        %{__enable_disable gtk-doc} \
         %{__enable_disable selinux} \
         --disable-silent-rules \
         --enable-introspection \
         --enable-blkid \
         --enable-gudev \
-        --enable-gtk-doc \
         --enable-keymap \
         --enable-libkmod \
         --enable-manpages \
@@ -333,7 +335,7 @@ fi
 %attr(755,root,root) %{_sbindir}/start_udev
 %attr(755,root,root) %{_sbindir}/udevd
 %attr(755,root,root) %{_sbindir}/udevadm
-%attr(755,root,root) /bin/udevadm
+%attr(755,root,root) %{_bindir}/udevadm
 
 %dir %{_sysconfdir}/udev
 %dir %{_sysconfdir}/udev/rules.d
@@ -388,9 +390,11 @@ fi
 %{_pkgconfigdir}/libudev.pc
 %{_npkgconfigdir}/udev.pc
 
+%if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/libudev
+%endif
 
 %files glib
 %defattr(644,root,root,755)
@@ -405,6 +409,8 @@ fi
 %{_pkgconfigdir}/gudev-1.0.pc
 %{_datadir}/gir-1.0/GUdev-1.0.gir
 
+%if %{with apidocs}
 %files glib-apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/gudev
+%endif