]> TLD Linux GIT Repositories - packages/zabbix.git/blobdiff - zabbix.spec
- updated to 6.0.4
[packages/zabbix.git] / zabbix.spec
index 577c1752511d2be26f85ff69033b66c0fe84965d..eb0ce642f78b5028609e43308a4496381e9d7eab 100644 (file)
 Summary:       Zabbix - network monitoring software
 Summary(pl.UTF-8):     Zabbix - oprogramowanie do monitorowania sieci
 Name:          zabbix
-Version:       5.0.7
-Release:       0.3
+Version:       6.0.4
+Release:       1
 License:       GPL v2+
 Group:         Networking/Utilities
-Source0:       https://cdn.zabbix.com/zabbix/sources/stable/5.0/%{name}-%{version}.tar.gz
-# Source0-md5: e0798bb1b53ab7b451556dc34c3b1827
+Source0:       https://cdn.zabbix.com/zabbix/sources/stable/6.0/%{name}-%{version}.tar.gz
+# Source0-md5: a4f60d529c18c1332354bddd402b561b
 Source1:       %{name}-apache.conf
 Source2:       %{name}_agentd.init
 Source3:       %{name}_server.init
@@ -413,7 +413,15 @@ EOF
 fi
 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
 
+%post server
+/sbin/chkconfig --add zabbix_server
+%service zabbix_server restart
+
 %postun server
+if [ "$1" = "0" ]; then
+       %service -q zabbix_server stop
+       /sbin/chkconfig --del zabbix_server
+fi
 if [ "$1" = "0" ]; then
        if [ -L %{_sbindir}/zabbix_server ] ; then
                rm -f %{_sbindir}/zabbix_server || :
@@ -439,6 +447,21 @@ ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
 %post proxy-sqlite3
 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
 
+%post proxy
+/sbin/chkconfig --add zabbix_server
+%service zabbix_server restart
+
+%postun proxy
+if [ "$1" = "0" ]; then
+       %service -q zabbix_proxy stop
+       /sbin/chkconfig --del zabbix_proxy
+fi
+if [ "$1" = "0" ]; then
+       if [ -L %{_sbindir}/zabbix_proxy ] ; then
+               rm -f %{_sbindir}/zabbix_proxy || :
+       fi
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README