]> TLD Linux GIT Repositories - packages/zabbix.git/blobdiff - zabbix.spec
- don't build Zabbix Agent 2 by default, it requires systemd to run
[packages/zabbix.git] / zabbix.spec
index 070245ee75bf281aa765bea68335704bc2e084fe..ec23c8caab5a82c0c6b867bd7ee4f8f9dbc4a272 100644 (file)
@@ -2,6 +2,7 @@
 # - initscript for zabbix-server, zabbix-proxy and zabbix-java
 #
 # Conditional build:
+%bcond_with    agent2  # build Zabbix Agent 2
 %bcond_without pgsql   # enable PostgreSQL support
 %bcond_without sqlite3 # enable sqlite3 support
 %bcond_without mysql   # enable MySQL support
 %define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
 
+%define                _noautoreq 'pear(.*\.php)'
+
 %define                php_min_version 5.4.0
 Summary:       Zabbix - network monitoring software
 Summary(pl.UTF-8):     Zabbix - oprogramowanie do monitorowania sieci
 Name:          zabbix
-Version:       6.0.13
+Version:       6.0.19
 Release:       1
 License:       GPL v2+
 Group:         Networking/Utilities
 Source0:       https://cdn.zabbix.com/zabbix/sources/stable/6.0/%{name}-%{version}.tar.gz
-# Source0-md5: 90397f76b04d1ffc3ca6b0c4f9fd8d60
+# Source0-md5: a57192d6bb17f9ca80a75f87d5462987
 Source1:       %{name}-apache.conf
 Source2:       %{name}_agentd.init
 Source3:       %{name}_server.init
 Source4:       %{name}_proxy.init
+Source5:       %{name}_agent2.init
 Patch0:                tld.patch
 Patch1:                sqlite3_dbname.patch
 Patch2:                always_compile_ipc.patch
@@ -32,7 +36,7 @@ BuildRequires:        OpenIPMI-devel
 BuildRequires: autoconf
 BuildRequires: automake >= 1:1.15
 BuildRequires: curl-devel
-#BuildRequires:        iksemel-devel
+%{?with_agent2:BuildRequires:  golang}
 %{?with_java:BuildRequires:    jdk}
 BuildRequires: libevent-devel
 BuildRequires: libssh2-devel
@@ -101,6 +105,20 @@ Zabbix agent collects data from the local system for a Zabbix server.
 %description agentd -l pl.UTF-8
 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
 
+%package agent2
+Summary:       Zabbix Agent 2
+Summary(pl.UTF-8):     Agent 2 Zabbixa
+Group:         Networking/Utilities
+Requires:      %{name} = %{version}-%{release}
+Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
+
+%description agent2
+Zabbix agent collects data from the local system for a Zabbix server.
+
+%description agent2 -l pl.UTF-8
+Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
+
 %package web
 Summary:       Web frontend for Zabbix
 Summary(pl.UTF-8):     Interfejs Web dla Zabbixa
@@ -261,6 +279,7 @@ This package provides the Zabbix Java Gateway.
 configure() {
        %configure \
        --enable-agent \
+       %{__enable_disable agent2} \
        --enable-ipv6 \
        %{__enable_disable java} \
        --with-jabber \
@@ -312,6 +331,7 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d,/etc/webapps/%{_webap
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
+       GOBIN=$RPM_BUILD_ROOT%{_sbindir} \
        ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
 
 for database in %{databases} ; do
@@ -336,6 +356,7 @@ cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
 install        %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
 install        %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_server
 install        %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_proxy
+install        %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
 
 mv $RPM_BUILD_ROOT%{_appdir}/ui/conf $RPM_BUILD_ROOT%{_sysconfdir}/web
 ln -s %{_sysconfdir}/web $RPM_BUILD_ROOT%{_appdir}/ui/conf
@@ -438,6 +459,16 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del zabbix_agentd
 fi
 
+%post agent2
+/sbin/chkconfig --add zabbix_agent2
+%service zabbix_agent2 restart
+
+%preun agent2
+if [ "$1" = "0" ]; then
+       %service -q zabbix_agent2 stop
+       /sbin/chkconfig --del zabbix_agent2
+fi
+
 %post proxy-mysql
 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
 
@@ -485,6 +516,26 @@ fi
 %attr(755,root,root) %{_sbindir}/zabbix_agentd
 %{_mandir}/man8/zabbix_agentd*
 
+%if %{with agent2}
+%files agent2
+%defattr(644,root,root,755)
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
+%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d
+%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.d/plugins.d
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/ceph.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/docker.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/memcached.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/modbus.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/mqtt.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/mysql.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/oracle.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/redis.conf
+%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.d/plugins.d/smart.conf
+%attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
+%attr(755,root,root) %{_sbindir}/zabbix_agent2
+%{_mandir}/man8/zabbix_agent2*
+%endif
+
 %files web
 %defattr(644,root,root,755)
 %attr(750,root,http) %dir %{_webapps}/%{_webapp}