- updated to 2.9.12
[packages/ansible.git] / poldek.patch
1 diff -ur ansible-2.8.0.orig/lib/ansible/module_utils/facts/system/pkg_mgr.py ansible-2.8.0/lib/ansible/module_utils/facts/system/pkg_mgr.py
2 --- ansible-2.8.0.orig/lib/ansible/module_utils/facts/system/pkg_mgr.py 2019-06-21 22:50:15.462000000 +0200
3 +++ ansible-2.8.0/lib/ansible/module_utils/facts/system/pkg_mgr.py      2019-06-21 22:51:42.117000000 +0200
4 @@ -13,7 +13,8 @@
5  # A list of dicts.  If there is a platform with more than one
6  # package manager, put the preferred one last.  If there is an
7  # ansible module, use that as the value for the 'name' key.
8 -PKG_MGRS = [{'path': '/usr/bin/yum', 'name': 'yum'},
9 +PKG_MGRS = [{'path': '/usr/bin/poldek', 'name': 'poldek'},
10 +            {'path': '/usr/bin/yum', 'name': 'yum'},
11              {'path': '/usr/bin/dnf', 'name': 'dnf'},
12              {'path': '/usr/bin/apt-get', 'name': 'apt'},
13              {'path': '/usr/bin/zypper', 'name': 'zypper'},