]> TLD Linux GIT Repositories - packages/ansible.git/commitdiff
- use pip source, install poldek.py, no shebang in poldek.py
authorMarcin Krol <hawk@tld-linux.org>
Sun, 7 Jan 2024 21:16:35 +0000 (22:16 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sun, 7 Jan 2024 21:16:35 +0000 (22:16 +0100)
ansible.spec
poldek.py

index 46fbc1d7121d599e533a87583dcb1b52e866989e..3124f2716ba344b4641e033f0c629b5332c60b13 100644 (file)
@@ -4,8 +4,8 @@ Version:        2.16.2
 Release:       1
 License:       GPL v3+
 Group:         Development/Libraries
-Source0:       https://github.com/ansible/ansible/archive/refs/tags/v%{version}.tar.gz
-# Source0-md5: 91855c745f4304113e5f3bc8df7525cf
+Source0:       https://files.pythonhosted.org/packages/66/5f/3098fac361ca16fc42ac30a2da09939286afd9af289f156ac9fbe87595e9/%{name}-core-%{version}.tar.gz
+# Source0-md5: 60684b6b2056b6a71f18f09a07ecc98c
 Source1:       poldek.py
 Patch0:                poldek.patch
 URL:           https://ansible.com
@@ -31,7 +31,7 @@ on remote nodes. Extension modules can be written in any language and
 are transferred to managed machines automatically.
 
 %prep
-%setup -q
+%setup -q -n %{name}-core-%{version}
 %patch0 -p1
 
 %{__sed} -i '1s,/usr/bin/env python,%{__python3},' test/lib/ansible_test/_util/target/cli/ansible_test_cli_stub.py
@@ -43,6 +43,8 @@ are transferred to managed machines automatically.
 rm -rf $RPM_BUILD_ROOT
 %py3_install
 
+install -p %{SOURCE1} $RPM_BUILD_ROOT%{py3_sitescriptdir}/ansible/modules/
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
index bc306a6e3a636c1e803f40bb3757f0011c97e3bb..9b44bd500ce6e153a4d80716c4a320d7b391e0e2 100644 (file)
--- a/poldek.py
+++ b/poldek.py
@@ -1,4 +1,3 @@
-#!/usr/bin/python
 # -*- coding: utf-8 -*-
 
 # Copyright: (c) 2019, Marcin Krol <hawk@tld-linux.org>