]> TLD Linux GIT Repositories - packages/coreutils.git/blobdiff - coreutils.spec
- merged 8.30 from PLD
[packages/coreutils.git] / coreutils.spec
index 7a597074e64dec3eda49947ced2e229e4846ece9..e8cba5fba057d0623b5ae78df9a8aa8f63bbc710 100644 (file)
@@ -1,17 +1,18 @@
+#
 # Conditional build:
-%bcond_with    advcopy # progress bar in cp (orphaned patch)
+%bcond_with    advcopy         # progress bar in cp (orphaned patch)
 %bcond_with    multicall       # Compile all the tools in a single binary
-%bcond_without tests   # do not perform "make test check"
+%bcond_with    tests           # unit tests running
 
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.29
+Version:       8.30
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 960cfe75a42c9907c71439f8eb436303
+# Source0-md5: ab06d68949758971fe744db66b572816
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -23,6 +24,7 @@ Patch0:               %{name}-info.patch
 Patch1:                %{name}-getgid.patch
 Patch2:                %{name}-uname-cpuinfo.patch
 Patch3:                %{name}-date-man.patch
+
 Patch6:                %{name}-fmt-wchars.patch
 Patch7:                %{name}-sparc64.patch
 # http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
@@ -33,15 +35,16 @@ Patch10:    tests.patch
 URL:           http://www.gnu.org/software/coreutils/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
-BuildRequires: autoconf >= 2.64
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.11.2
 BuildRequires: gcc >= 5:3.2
-BuildRequires: gettext-tools >= 0.18.1
+BuildRequires: gettext-tools >= 0.19.2
 BuildRequires: gmp-devel
 BuildRequires: help2man
 BuildRequires: libcap-devel
 BuildRequires: libselinux-devel
 BuildRequires: rpmbuild(find_lang) >= 1.24
+BuildRequires: smack-devel
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.2
 BuildRequires: xz
@@ -108,6 +111,7 @@ Programy zawarte w tym pakiecie to:
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+
 %patch6 -p1
 %ifarch sparc64
 %patch7 -p1
@@ -118,9 +122,9 @@ Programy zawarte w tym pakiecie to:
 %endif
 %patch10 -p1
 
-mv man/pt_BR man/pt
+%{__mv} man/pt_BR man/pt
 
-%{__perl} -pi -e 's@GNU/Linux@TLD Linux@' m4/host-os.m4
+%{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
 
 # allow rebuilding *.gmo
 %{__rm} po/stamp-po
@@ -170,7 +174,7 @@ build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
        --enable-install-program=arch \
        --enable-no-install-program=hostname,kill,uptime
 
-%{__make}
+%{__make} -j1
 
 %if %{with tests}
 sed -i -e 's#COLUMNS##g' tests/envvar-check
@@ -184,16 +188,16 @@ install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
 df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,readlink,rm,rmdir,\
 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
 
 %if %{with multicall}
-mv $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
+%{__mv} $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
 ln -s ../../bin/coreutils $RPM_BUILD_ROOT%{_bindir}
 %endif
 
-mv $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
@@ -208,8 +212,6 @@ cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,su,uptime}.1
 # always remove, never packaged but sometimes installed
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
-# remove locales not available in the system
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr/LC_TIME
 
 %find_lang %{name}
 
@@ -339,8 +341,8 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS.256color
 %config(noreplace) /etc/shrc.d/colorls.csh
 %config(noreplace) /etc/shrc.d/colorls.sh
-%dir %{_libdir}/coreutils
-%attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
+%dir %{_libexecdir}/coreutils
+%attr(755,root,root) %{_libexecdir}/coreutils/libstdbuf.so
 %{_mandir}/man1/arch.1*
 %{_mandir}/man1/b2sum.1*
 %{_mandir}/man1/base32.1*