]> TLD Linux GIT Repositories - packages/coreutils.git/blobdiff - coreutils.spec
- PLD merge
[packages/coreutils.git] / coreutils.spec
index 2517905a7c2a07dbaf9ec5c1fdf7bf6a991bcde7..ec58cdb90a6ef58afec0e5115a894ca58ad2c9c8 100644 (file)
@@ -1,17 +1,17 @@
-#
 # Conditional build:
 %bcond_with    advcopy # progress bar in cp (orphaned patch)
+%bcond_with    multicall       # Compile all the tools in a single binary
 %bcond_without tests   # do not perform "make test check"
-#
+
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.23
-Release:       2
+Version:       8.25
+Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: abed135279f87ad6762ce57ff6d89c41
+# Source0-md5: 070e43ba7f618d747414ef56ab248a48
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -23,7 +23,6 @@ Patch0:               %{name}-info.patch
 Patch1:                %{name}-getgid.patch
 Patch2:                %{name}-uname-cpuinfo.patch
 Patch3:                %{name}-date-man.patch
-Patch5:                %{name}-7.4-sttytcsadrain.patch
 Patch6:                %{name}-fmt-wchars.patch
 Patch7:                %{name}-sparc64.patch
 # http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
@@ -37,7 +36,7 @@ BuildRequires:        attr-devel
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11.2
 BuildRequires: gcc >= 5:3.2
-BuildRequires: gettext-devel >= 0.18.1
+BuildRequires: gettext-tools >= 0.18.1
 BuildRequires: gmp-devel
 BuildRequires: help2man
 BuildRequires: libcap-devel
@@ -104,12 +103,11 @@ Programy zawarte w tym pakiecie to:
 
 %prep
 %setup -q -a1
-#patch8 -p1
+%patch8 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
 %patch6 -p1
 %ifarch sparc64
 %patch7 -p1
@@ -120,6 +118,8 @@ Programy zawarte w tym pakiecie to:
 %endif
 %patch10 -p1
 
+mv man/pt_BR man/pt
+
 %{__perl} -pi -e 's@GNU/Linux@TLD Linux@' m4/host-os.m4
 
 # allow rebuilding *.gmo
@@ -165,6 +165,7 @@ build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
 %configure \
        CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
        DEFAULT_POSIX2_VERSION=199209 \
+       %{?with_multicall:--enable-single-binary=symlinks} \
        --disable-silent-rules \
        --enable-install-program=arch \
        --enable-no-install-program=hostname,kill,uptime
@@ -183,22 +184,26 @@ install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
+mv $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
 df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,readlink,rm,rmdir,\
 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
 
-mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
+%if %{with multicall}
+mv $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
+ln -s ../../bin/coreutils $RPM_BUILD_ROOT%{_bindir}
+%endif
+
+mv $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p %{SOURCE4} %{SOURCE5} $RPM_BUILD_ROOT/etc/shrc.d
 
-cp -a man/pt_BR man/pt
 for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN; do
        install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
        cp -p man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
 done
-install %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
+cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
 # unwanted (-f left intentionally - some manuals could have no translations)
 rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,su,uptime}.1
 # always remove, never packaged but sometimes installed
@@ -254,6 +259,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /bin/uname
 %attr(755,root,root) /bin/unlink
 %attr(755,root,root) %{_bindir}/[
+%attr(755,root,root) %{_bindir}/base32
 %attr(755,root,root) %{_bindir}/base64
 %attr(755,root,root) %{_bindir}/chcon
 %attr(755,root,root) %{_bindir}/cksum
@@ -321,6 +327,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/whoami
 %attr(755,root,root) %{_bindir}/yes
 %attr(755,root,root) %{_sbindir}/chroot
+%if %{with multicall}
+%attr(755,root,root) /bin/coreutils
+%attr(755,root,root) %{_bindir}/coreutils
+%{_mandir}/man1/coreutils.1*
+%endif
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS.256color
 %config(noreplace) /etc/shrc.d/colorls.csh
@@ -328,6 +339,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/coreutils
 %attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
 %{_mandir}/man1/arch.1*
+%{_mandir}/man1/base32.1*
 %{_mandir}/man1/base64.1*
 %{_mandir}/man1/basename.1*
 %{_mandir}/man1/cat.1*