]> TLD Linux GIT Repositories - packages/coreutils.git/blobdiff - tests.patch
- PLD merge
[packages/coreutils.git] / tests.patch
index 70d1b9dc8a4de2fa5178acf19e66a83ba51519e6..ba90631a4a1f24503651ea84fa3bb5510dd1eb9a 100644 (file)
@@ -1,54 +1,43 @@
 --- coreutils-8.21/tests/misc/printenv.sh~     2013-01-31 01:46:24.000000000 +0100
 +++ coreutils-8.21/tests/misc/printenv.sh      2013-12-03 12:25:51.949012868 +0100
-@@ -23,8 +23,8 @@
- # printenv as a builtin, so we must invoke it via "env".
- # But beware of $_, set by many shells to the last command run.
- # Also, filter out LD_PRELOAD, which is set when running under valgrind.
--env | grep -Ev '^(_|LD_PRELOAD=)' > exp || framework_failure_
--env -- printenv | grep -Ev '^(_|LD_PRELOAD=)' > out || fail=1
-+env | grep -Ev '^(_|LD_PRELOAD=|RANDOM=)' > exp || framework_failure_
-+env -- printenv | grep -Ev '^(_|LD_PRELOAD=|RANDOM=)' > out || fail=1
+@@ -27,8 +27,8 @@ print_ver_ printenv
+ # env's output the same way as that of printenv and works around a bug
+ # on aarch64 at least where libc's execvp reverses the order of the
+ # output.
+-env -- env | grep -Ev '^(_|LD_PRELOAD)=' > exp || framework_failure_
+-env -- printenv | grep -Ev '^(_|LD_PRELOAD)=' > out || fail=1
++env -- env | grep -Ev '^(_|LD_PRELOAD|RANDOM=)=' > exp || framework_failure_
++env -- printenv | grep -Ev '^(_|LD_PRELOAD|RANDOM=)=' > out || fail=1
  compare exp out || fail=1
  
  # POSIX is clear that environ may, but need not be, sorted.
 --- coreutils-8.21/tests/misc/realpath.sh.orig 2013-12-03 12:36:46.105079823 +0100
 +++ coreutils-8.21/tests/misc/realpath.sh      2013-12-03 12:46:44.854069134 +0100
-@@ -16,8 +16,8 @@
- # You should have received a copy of the GNU General Public License
- # along with this program.  If not, see <http://www.gnu.org/licenses/>.
--. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
--print_ver_ realpath
-+. "${srcdir=.}/tests/init.sh"; path_prepend_ $initial_cwd_/src
-+print_ver_ $initial_cwd_/src/realpath
- stat_single=$(stat -c %d:%i /) || framework_failure_
- stat_double=$(stat -c %d:%i //) || framework_failure_
-@@ -40,68 +40,68 @@
+@@ -40,68 +40,68 @@ ln -s // two || framework_failure_
  ln -s /// three || framework_failure_
  
  # Basic operation
 -realpath -Pqz . >/dev/null || fail=1
 +$initial_cwd_/src/realpath -Pqz . >/dev/null || fail=1
  # Operand is required
--realpath >/dev/null && fail=1
--realpath --relative-base . --relative-to . && fail=1
--realpath --relative-base . && fail=1
-+$initial_cwd_/src/realpath >/dev/null && fail=1
-+$initial_cwd_/src/realpath --relative-base . --relative-to . && fail=1
-+$initial_cwd_/src/realpath --relative-base . && fail=1
+-returns_ 1 realpath >/dev/null || fail=1
+-returns_ 1 realpath --relative-base . --relative-to . || fail=1
+-returns_ 1 realpath --relative-base . || fail=1
++returns_ 1 $initial_cwd_/src/realpath >/dev/null || fail=1
++returns_ 1 $initial_cwd_/src/realpath --relative-base . --relative-to . || fail=1
++returns_ 1 $initial_cwd_/src/realpath --relative-base . || fail=1
  
  # -e --relative-* require directories
--realpath -e --relative-to=dir1/f --relative-base=. . && fail=1
+-returns_ 1 realpath -e --relative-to=dir1/f --relative-base=. . || fail=1
 -realpath -e --relative-to=dir1/  --relative-base=. . || fail=1
-+$initial_cwd_/src/realpath -e --relative-to=dir1/f --relative-base=. . && fail=1
++returns_ 1 $initial_cwd_/src/realpath -e --relative-to=dir1/f --relative-base=. . || fail=1
 +$initial_cwd_/src/realpath -e --relative-to=dir1/  --relative-base=. . || fail=1
  
  # Note NUL params are unconditionally rejected by canonicalize_filename_mode
--realpath -m '' && fail=1
--realpath --relative-base= --relative-to=. . && fail=1
-+$initial_cwd_/src/realpath -m '' && fail=1
-+$initial_cwd_/src/realpath --relative-base= --relative-to=. . && fail=1
+-returns_ 1 realpath -m '' || fail=1
+-returns_ 1 realpath --relative-base= --relative-to=. . || fail=1
++returns_ 1 $initial_cwd_/src/realpath -m '' || fail=1
++returns_ 1 $initial_cwd_/src/realpath --relative-base= --relative-to=. . || fail=1
  
  # symlink resolution
 -this=$(realpath .)
  EXTRA_DIST += nap.h test-futimens.h test-lutimens.h test-utimens.h test-utimens-common.h test-utimens.c macros.h
  
  ## end   gnulib module utimens-tests
+--- coreutils-8.23/tests/local.mk~     2015-01-04 16:12:22.000000000 +0000
++++ coreutils-8.23/tests/local.mk      2015-01-04 16:44:31.705861487 +0000
+@@ -163,7 +163,6 @@
+   tests/rm/cycle.sh                           \
+   tests/cp/link-heap.sh                               \
+   tests/cp/no-ctx.sh                          \
+-  tests/misc/tty-eof.pl                               \
+   tests/tail-2/inotify-hash-abuse.sh          \
+   tests/tail-2/inotify-hash-abuse2.sh         \
+   tests/tail-2/F-vs-missing.sh                        \
+@@ -339,7 +339,6 @@
+   tests/misc/sort-unique-segv.sh              \
+   tests/misc/sort-version.sh                  \
+   tests/misc/sort-NaN-infloop.sh              \
+-  tests/misc/sort-u-FMR.sh                    \
+   tests/split/filter.sh                               \
+   tests/split/suffix-auto-length.sh           \
+   tests/split/suffix-length.sh                        \
+@@ -468,7 +467,6 @@
+   tests/df/unreadable.sh                      \
+   tests/df/total-unprocessed.sh                       \
+   tests/df/no-mtab-status.sh                  \
+-  tests/df/skip-duplicates.sh                 \
+   tests/df/skip-rootfs.sh                     \
+   tests/dd/ascii.sh                           \
+   tests/dd/direct.sh                          \