]> TLD Linux GIT Repositories - packages/gcc.git/blobdiff - gcc-ada-x32.patch
- merged 10.2.0 from PLD, rel 0.1 for bootstrap (multilib changes)
[packages/gcc.git] / gcc-ada-x32.patch
diff --git a/gcc-ada-x32.patch b/gcc-ada-x32.patch
new file mode 100644 (file)
index 0000000..27e7e7d
--- /dev/null
@@ -0,0 +1,20 @@
+Based on patch from https://gcc.gnu.org/bugzilla/show_bug.cgi?id=56030
+Blocking bug https://gcc.gnu.org/bugzilla/show_bug.cgi?id=54040 has been fixed
+
+--- gcc-4.9.2/gcc/ada/gcc-interface/Makefile.in~       2014-12-27 17:19:06.000000000 +0000
++++ gcc-4.9.2/gcc/ada/gcc-interface/Makefile.in        2014-12-27 18:11:33.908691021 +0000
+@@ -355,6 +355,14 @@
+   else
+     ifeq ($(strip $(MULTISUBDIR)),/x32)
+       target_cpu:=x32
++    else
++      ifeq ($(strip $(MULTISUBDIR)),/64)
++        target_cpu:=x86_64
++      else
++        ifneq ($(findstring gnux32,$(target_os)),)
++          target_cpu:=x32
++        endif
++      endif
+     endif
+   endif
+ endif