]> TLD Linux GIT Repositories - packages/glusterfs.git/blobdiff - glusterfs-python.patch
- updated to 3.10.1
[packages/glusterfs.git] / glusterfs-python.patch
diff --git a/glusterfs-python.patch b/glusterfs-python.patch
new file mode 100644 (file)
index 0000000..f21d8f2
--- /dev/null
@@ -0,0 +1,11 @@
+--- glusterfs-3.10.1/configure.ac.orig 2017-04-11 13:49:09.000000000 +0000
++++ glusterfs-3.10.1/configure.ac      2017-04-11 13:50:45.343558629 +0000
+@@ -521,7 +521,7 @@
+    PYTHONDEV_CPPFLAGS=`echo ${PYTHONDEV_CPPFLAGS} | sed -e 's/-Wp,-D_FORTIFY_SOURCE=[[0-9]]//g'`
+    dnl Find python libs at user configured libdir and also "lib" under prefix
+-   PYTHONDEV_LDFLAGS="${PYTHON_LIBS} -L`${PYTHON}-config --prefix`/lib -L`${PYTHON}-config --prefix`/$libdir `${PYTHON}-config --ldflags`"
++   PYTHONDEV_LDFLAGS="${PYTHON_LIBS} `${PYTHON}-config --ldflags`"
+    BUILD_PYTHON_SITE_PACKAGES=${pythondir}
+    BUILD_PYTHON_INC=`$PYTHON -c "import sys; from distutils import sysconfig; sys.stdout.write(sysconfig.get_python_inc())" 2>/dev/null`