]> TLD Linux GIT Repositories - packages/lvm2.git/blobdiff - lvm2-thin.patch
- updated to 2.03.23, cleanup, minor merge from PLD
[packages/lvm2.git] / lvm2-thin.patch
index 0f0cd216a9cc7bfff59b52475234de45f7f9f227..ea210e67aed6e55f54b6c2bf01fa42a555dcd965 100644 (file)
@@ -1,6 +1,7 @@
---- LVM2.2.03.19/configure.ac.orig     2023-02-21 15:37:53.000000000 +0100
-+++ LVM2.2.03.19/configure.ac  2023-02-22 10:52:41.267893915 +0100
-@@ -393,7 +393,7 @@
+diff -urNpa LVM2.2.03.23.orig/configure.ac LVM2.2.03.23/configure.ac
+--- LVM2.2.03.23.orig/configure.ac     2023-12-03 19:58:43.179205581 +0100
++++ LVM2.2.03.23/configure.ac  2023-12-03 19:59:54.935057131 +0100
+@@ -409,7 +409,7 @@ dnl -- thin_check needs-check flag
  AC_ARG_ENABLE(thin_check_needs_check,
              AS_HELP_STRING([--disable-thin_check_needs_check],
                             [required if thin_check version is < 0.3.0]),
@@ -9,7 +10,16 @@
  
  # Test if necessary thin tools are available
  # if not - use plain defaults and warn user
-@@ -421,7 +421,7 @@
+@@ -424,7 +424,7 @@ AS_CASE(["$THIN"],
+                       THIN_CONFIGURE_WARN="y"
+               ])
+       ])
+-      AS_IF([test "$THIN_CHECK_NEEDS_CHECK" = "yes" && test "$THIN_CONFIGURE_WARN" != "y"], [
++      AS_IF([test "$THIN_CHECK_NEEDS_CHECK" = "autodetect" && test "$THIN_CONFIGURE_WARN" != "y"], [
+               THIN_CHECK_VSN=$("$THIN_CHECK_CMD" -V 2>/dev/null)
+               THIN_CHECK_VSN=${THIN_CHECK_VSN##* }  # trim away all before the first space
+               THIN_CHECK_VSN_MAJOR=$(echo "$THIN_CHECK_VSN" | $AWK -F '.' '{print $1}')
+@@ -438,7 +438,7 @@ AS_CASE(["$THIN"],
                        AC_MSG_WARN([$THIN_CHECK_CMD: Old version "$THIN_CHECK_VSN" found])
                        THIN_CHECK_VERSION_WARN="y"
                        THIN_CHECK_NEEDS_CHECK="no"
@@ -18,7 +28,7 @@
        ])
        # Empty means a config way to ignore thin dumping
        AS_IF([test "$THIN_DUMP_CMD" = "autodetect"], [
-@@ -505,7 +505,7 @@
+@@ -522,7 +522,7 @@ dnl -- cache_check needs-check flag
  AC_ARG_ENABLE(cache_check_needs_check,
              AS_HELP_STRING([--disable-cache_check_needs_check],
                             [required if cache_check version is < 0.5]),
  
  # Test if necessary cache tools are available
  # if not - use plain defaults and warn user
-@@ -520,7 +520,7 @@
-                       CACHE_CONFIGURE_WARN="y"
-               ])
-       ])
--      AS_IF([test "$CACHE_CHECK_NEEDS_CHECK" = "yes" && test "$CACHE_CONFIGURE_WARN" != "y"], [
-+      AS_IF([test "$CACHE_CHECK_NEEDS_CHECK" = "autodetect" && test "$CACHE_CONFIGURE_WARN" != "y"], [
-               $CACHE_CHECK_CMD -V 2>/dev/null >conftest.tmp
-               read -r CACHE_CHECK_VSN < conftest.tmp
-               IFS=.- read -r CACHE_CHECK_VSN_MAJOR CACHE_CHECK_VSN_MINOR CACHE_CHECK_VSN_PATCH LEFTOVER < conftest.tmp
-@@ -544,7 +544,7 @@
+@@ -562,7 +562,7 @@ AS_CASE(["$CACHE"],
                                AC_MSG_WARN([$CACHE_CHECK_CMD: Old version "$CACHE_CHECK_VSN" does not support new cache format V2])
                                CACHE_CHECK_VERSION_WARN=y
                        ])