]> TLD Linux GIT Repositories - packages/lvm2.git/blobdiff - lvm2.spec
- updated to 2.03.23, cleanup, minor merge from PLD
[packages/lvm2.git] / lvm2.spec
index 2972ebde86bd907e040eef7d1bb53022f42a532e..6a05e41a72b4202be459c27d1a0da3d4a98a315c 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
 %bcond_without python2         # Python 2 binding
 %bcond_without python3         # Python 3 binding and lvmdbusd
 
-# for convenience
-%if %{without python}
-%undefine      with_python2
-%undefine      with_python3
+# lvmlockd requires lvmpolld
+%if %{without lvmpolld}
+%undefine      with_lvmpolld
 %endif
-%if %{without python3}
-%undefine      with_lvmdbusd
+
+%if %{without cluster} && %{without sanlock}
+%undefine      with_lvmlockd
 %endif
 
 Summary:       The new version of Logical Volume Manager for Linux
 Summary(pl.UTF-8):     Nowa wersja Logical Volume Managera dla Linuksa
 Name:          lvm2
-Version:       2.03.21
+Version:       2.03.23
 Release:       1
 License:       GPL v2 and LGPL v2.1
 Group:         Applications/System
 Source0:       ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
-# Source0-md5: 1730b322321bed204487ba241105e005
+# Source0-md5: 0535b5e638b6f0b48f7b259e0ec0ba65
 Patch0:                %{name}-selinux.patch
 Patch1:                device-mapper-dmsetup-export.patch
 Patch2:                %{name}-tld_init.patch
@@ -53,10 +53,9 @@ BuildRequires:       libblkid-devel >= 2.24
 %{?with_selinux:BuildRequires: libsepol-devel}
 BuildRequires: ncurses-devel
 BuildRequires: pkgconfig
-%{?with_python2:BuildRequires: python-devel >= 2}
-%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
 %if %{with lvmdbusd}
 BuildRequires: python3-dbus
+BuildRequires: python3-devel >= 1:3.2
 BuildRequires: python3-pyudev
 %endif
 BuildRequires: readline-devel
@@ -72,10 +71,10 @@ Requires:   device-mapper >= %{version}-%{release}
 %{?with_selinux:Requires:      libselinux >= 1.10}
 # doesn't work with 2.4 kernels
 Requires:      uname(release) >= 2.6
-Suggests:      thin-provisioning-tools >= 0.5.4
-Obsoletes:     lvm
-Obsoletes:     lvm2-clvmd
-Obsoletes:     lvm2-systemd
+Suggests:      thin-provisioning-tools >= 0.7.0
+Obsoletes:     lvm < 2
+Obsoletes:     lvm2-clvmd < 2.03
+Obsoletes:     lvm2-systemd < 2.02.94
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
@@ -167,30 +166,6 @@ OCF Resource Agents for LVM2 processes.
 %description resource-agents -l pl.UTF-8
 Agenci OCF do monitorowania procesów LVM2.
 
-%package -n python-lvm
-Summary:       Python 2 interface to LVM2
-Summary(pl.UTF-8):     Interfejs Pythona 2 do LVM2
-Group:         Libraries/Python
-Requires:      device-mapper-libs = %{version}-%{release}
-
-%description -n python-lvm
-Python 2 interface to LVM2.
-
-%description -n python-lvm -l pl.UTF-8
-Interfejs Pythona 2 do LVM2.
-
-%package -n python3-lvm
-Summary:       Python 3 interface to LVM2
-Summary(pl.UTF-8):     Interfejs Pythona 3 do LVM2
-Group:         Libraries/Python
-Requires:      device-mapper-libs = %{version}-%{release}
-
-%description -n python3-lvm
-Python 3 interface to LVM2.
-
-%description -n python3-lvm -l pl.UTF-8
-Interfejs Pythona 3 do LVM2.
-
 %package -n device-mapper
 Summary:       Userspace support for the device-mapper
 Summary(pl.UTF-8):     Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
@@ -219,6 +194,8 @@ Summary(pl.UTF-8):  Biblioteki współdzielone device-mappera
 Group:         Libraries
 Requires:      libblkid >= 2.24
 Requires:      udev-libs >= 1:176
+Obsoletes:     python-lvm < 2.03
+Obsoletes:     python3-lvm < 2.03
 Conflicts:     device-mapper < 2.02.119-1
 
 %description -n device-mapper-libs
@@ -285,7 +262,6 @@ Statyczna biblioteka devmapper zbudowana z dietlibc.
 %{__autoconf}
 
 %configure \
-       --enable-applib \
        --enable-cache_check_needs_check \
        --enable-cmdlib \
 %if %{with cluster}
@@ -302,8 +278,6 @@ Statyczna biblioteka devmapper zbudowana z dietlibc.
 %endif
        --enable-lvmpolld \
        --enable-ocf \
-       %{?with_python2:--enable-python2_bindings} \
-       %{?with_python3:--enable-python3_bindings} \
        --enable-pkgconfig \
        --enable-readline \
        %{!?with_selinux:--disable-selinux} \
@@ -330,7 +304,9 @@ Statyczna biblioteka devmapper zbudowana z dietlibc.
        --with-thin-repair=/usr/sbin/thin_repair \
        --with-thin-restore=/usr/sbin/thin_restore \
        --with-udev-prefix=/ \
-       --with-usrlibdir=%{_libdir}
+       --with-usrlibdir=%{_libdir} \
+       --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
+       --with-writecache=internal
 # use bash because of "set -o pipefail"
 # V=1 still used because of missing --disable-silent-rules support in libdm (as of 2.03.09)
 %{__make} -j1 \
@@ -346,9 +322,9 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/
 
 %{__make} install install_system_dirs install_initscripts \
        DESTDIR=$RPM_BUILD_ROOT \
+       PYTHON_PREFIX=%{_prefix} \
        OWNER="" \
-       GROUP="" \
-       python3dir=%{py3_sitescriptdir}
+       GROUP=""
 
 %{__make} -C scripts \
        DESTDIR=$RPM_BUILD_ROOT
@@ -565,20 +541,6 @@ fi
 %dir %{_prefix}/lib/ocf/resource.d/lvm2
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
 
-%if %{with python2}
-%files -n python-lvm
-%defattr(644,root,root,755)
-#%attr(755,root,root) %{py_sitedir}/lvm.so
-#%{py_sitedir}/lvm-%{version}_*-py*.egg-info
-%endif
-
-%if %{with python3}
-%files -n python3-lvm
-%defattr(644,root,root,755)
-#%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
-#%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
-%endif
-
 %files -n device-mapper
 %defattr(644,root,root,755)
 %doc *_DM