]> TLD Linux GIT Repositories - packages/php.git/blobdiff - pcre-shared.patch
- updated to 7.4.0, partial PLD merge, release 0.1 (not tested yet)
[packages/php.git] / pcre-shared.patch
diff --git a/pcre-shared.patch b/pcre-shared.patch
deleted file mode 100644 (file)
index c1b2627..0000000
+++ /dev/null
@@ -1,180 +0,0 @@
-diff -urN php-7.3.12.orig/ext/pcre/config0.m4 php-7.3.12/ext/pcre/config0.m4
---- php-7.3.12.orig/ext/pcre/config0.m4        2019-12-12 21:43:24.775000000 +0100
-+++ php-7.3.12/ext/pcre/config0.m4     2019-12-12 21:43:36.336000000 +0100
-@@ -84,8 +84,9 @@
-       ])
-     fi
--    PHP_NEW_EXTENSION(pcre, php_pcre.c, no,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
-+    PHP_NEW_EXTENSION(pcre, php_pcre.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
-     PHP_INSTALL_HEADERS([ext/pcre], [php_pcre.h])
-+    EXTRA_LIBS="$EXTRA_LIBS -lpcre2-8"
-   else
-     AC_MSG_CHECKING([for PCRE library to use])
-     AC_MSG_RESULT([bundled])
-diff -urN php-7.3.12.orig/ext/pcre/php_pcre.c php-7.3.12/ext/pcre/php_pcre.c
---- php-7.3.12.orig/ext/pcre/php_pcre.c        2019-12-12 21:43:24.775000000 +0100
-+++ php-7.3.12/ext/pcre/php_pcre.c     2019-12-12 21:43:36.339000000 +0100
-@@ -19,6 +19,9 @@
- #include "php.h"
- #include "php_ini.h"
- #include "php_globals.h"
-+#if COMPILE_DL_PCRE
-+#define COMPILE_DL_PCRE_NOREDIRECT
-+#endif
- #include "php_pcre.h"
- #include "ext/standard/info.h"
- #include "ext/standard/basic_functions.h"
-@@ -290,6 +293,17 @@
-               pcre2_set_match_limit(mctx, (uint32_t)PCRE_G(backtrack_limit));
-       }
-+#if COMPILE_DL_PCRE
-+      pcre_get_compiled_regex_p = pcre_get_compiled_regex;
-+      pcre_get_compiled_regex_cache_p = pcre_get_compiled_regex_cache;
-+      php_pcre_replace_impl_p = php_pcre_replace_impl;
-+      php_pcre_match_impl_p = php_pcre_match_impl;
-+      php_pcre_split_impl_p = php_pcre_split_impl;
-+      php_pcre_create_match_data_p = php_pcre_create_match_data;
-+      php_pcre_free_match_data_p = php_pcre_free_match_data;
-+      php_pcre_mctx_p = php_pcre_mctx;
-+#endif
-+
-       return SUCCESS;
- }/*}}}*/
-diff -urN php-7.3.12.orig/ext/pcre/php_pcre.h php-7.3.12/ext/pcre/php_pcre.h
---- php-7.3.12.orig/ext/pcre/php_pcre.h        2019-12-12 21:43:24.777000000 +0100
-+++ php-7.3.12/ext/pcre/php_pcre.h     2019-12-12 21:45:10.506000000 +0100
-@@ -31,7 +31,35 @@
- #include <locale.h>
- #endif
-+#if !defined(COMPILE_DL_PCRE_NOREDIRECT)
-+#define pcre_get_compiled_regex (*pcre_get_compiled_regex_p)
-+#define pcre_get_compiled_regex_cache (*pcre_get_compiled_regex_cache_p)
-+#define php_pcre_replace_impl (*php_pcre_replace_impl_p)
-+#define php_pcre_match_impl (*php_pcre_match_impl_p)
-+#define php_pcre_split_impl (*php_pcre_split_impl_p)
-+#define php_pcre_create_match_data (*php_pcre_create_match_data_p)
-+#define php_pcre_free_match_data (*php_pcre_free_match_data_p)
-+#define php_pcre_mctx (*php_pcre_mctx_p)
-+#if !defined(COMPILE_DL_PCRE_NOEXTERN)
-+#     define PCRE_EXTERN extern
-+#else
-+#     define PCRE_EXTERN
-+#endif
-+#else
-+// for pcre.c
-+#define PCRE_EXTERN
-+extern void *pcre_get_compiled_regex_p;
-+extern void *pcre_get_compiled_regex_cache_p;
-+extern void *php_pcre_replace_impl_p;
-+extern void *php_pcre_match_impl_p;
-+extern void *php_pcre_split_impl_p;
-+extern void *php_pcre_create_match_data_p;
-+extern void *php_pcre_free_match_data_p;
-+extern void *php_pcre_mctx_p;
-+#endif
-+
- PHPAPI zend_string *php_pcre_replace(zend_string *regex, zend_string *subject_str, char *subject, size_t subject_len, zend_string *replace_str, size_t limit, size_t *replace_count);
-+PCRE_EXTERN
- PHPAPI pcre2_code* pcre_get_compiled_regex(zend_string *regex, uint32_t *capture_count, uint32_t *options);
- PHPAPI pcre2_code* pcre_get_compiled_regex_ex(zend_string *regex, uint32_t *capture_count, uint32_t *preg_options, uint32_t *coptions);
-@@ -43,21 +71,26 @@
- typedef struct _pcre_cache_entry pcre_cache_entry;
-+PCRE_EXTERN
- PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache(zend_string *regex);
- PHPAPI pcre_cache_entry* pcre_get_compiled_regex_cache_ex(zend_string *regex, int locale_aware);
-+PCRE_EXTERN
- PHPAPI void  php_pcre_match_impl(  pcre_cache_entry *pce, char *subject, size_t subject_len, zval *return_value,
-       zval *subpats, int global, int use_flags, zend_long flags, zend_off_t start_offset);
-+PCRE_EXTERN
- PHPAPI zend_string *php_pcre_replace_impl(pcre_cache_entry *pce, zend_string *subject_str, char *subject, size_t subject_len, zend_string *replace_str,
-       size_t limit, size_t *replace_count);
-+PCRE_EXTERN
- PHPAPI void  php_pcre_split_impl(  pcre_cache_entry *pce, zend_string *subject_str, zval *return_value,
-       zend_long limit_val, zend_long flags);
- PHPAPI void  php_pcre_grep_impl(   pcre_cache_entry *pce, zval *input, zval *return_value,
-       zend_long flags);
-+PCRE_EXTERN
- PHPAPI pcre2_match_context *php_pcre_mctx(void);
- PHPAPI pcre2_general_context *php_pcre_gctx(void);
- PHPAPI pcre2_compile_context *php_pcre_cctx(void);
-@@ -65,7 +98,9 @@
- PHPAPI void php_pcre_pce_decref(pcre_cache_entry *);
- PHPAPI pcre2_code *php_pcre_pce_re(pcre_cache_entry *);
- /* capture_count can be ignored, re is required. */
-+PCRE_EXTERN
- PHPAPI pcre2_match_data *php_pcre_create_match_data(uint32_t, pcre2_code *);
-+PCRE_EXTERN
- PHPAPI void php_pcre_free_match_data(pcre2_match_data *);
- ZEND_BEGIN_MODULE_GLOBALS(pcre)
-diff -urN php-7.3.12.orig/ext/phar/Makefile.frag php-7.3.12/ext/phar/Makefile.frag
---- php-7.3.12.orig/ext/phar/Makefile.frag     2019-12-12 21:43:24.654000000 +0100
-+++ php-7.3.12/ext/phar/Makefile.frag  2019-12-12 21:43:36.358000000 +0100
-@@ -14,7 +14,7 @@
-               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
-               if test "x$(PHP_MODULES)" != "x"; then \
-               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
--              for i in spl bz2 zlib phar; do \
-+              for i in pcre spl bz2 zlib phar; do \
-                       if test -f "$(top_builddir)/modules/$$i.la"; then \
-                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-                       fi; \
-diff -urN php-7.3.12.orig/ext/standard/basic_functions.c php-7.3.12/ext/standard/basic_functions.c
---- php-7.3.12.orig/ext/standard/basic_functions.c     2019-12-12 21:43:24.765000000 +0100
-+++ php-7.3.12/ext/standard/basic_functions.c  2019-12-12 21:43:36.361000000 +0100
-@@ -112,6 +112,18 @@
- PHPAPI php_basic_globals basic_globals;
- #endif
-+#if COMPILE_DL_PCRE
-+// Declare the pointers in core library
-+void *pcre_get_compiled_regex_p;
-+void *pcre_get_compiled_regex_cache_p;
-+void *php_pcre_replace_impl_p;
-+void *php_pcre_match_impl_p;
-+void *php_pcre_split_impl_p;
-+void *php_pcre_create_match_data_p;
-+void *php_pcre_free_match_data_p;
-+void *php_pcre_mctx_p;
-+#endif
-+
- #include "php_fopen_wrappers.h"
- #include "streamsfuncs.h"
-diff -urN php-7.3.12.orig/main/php_ini.c php-7.3.12/main/php_ini.c
---- php-7.3.12.orig/main/php_ini.c     2019-12-12 21:43:24.549000000 +0100
-+++ php-7.3.12/main/php_ini.c  2019-12-12 21:43:36.364000000 +0100
-@@ -807,8 +807,8 @@
-  */
- void php_ini_register_extensions(void)
- {
--      zend_llist_apply(&extension_lists.engine, php_load_zend_extension_cb);
-       zend_llist_apply(&extension_lists.functions, php_load_php_extension_cb);
-+      zend_llist_apply(&extension_lists.engine, php_load_zend_extension_cb);
-       zend_llist_destroy(&extension_lists.engine);
-       zend_llist_destroy(&extension_lists.functions);
-diff -urN php-7.3.12.orig/sapi/cli/tests/018.phpt php-7.3.12/sapi/cli/tests/018.phpt
---- php-7.3.12.orig/sapi/cli/tests/018.phpt    2019-12-12 21:43:24.534000000 +0100
-+++ php-7.3.12/sapi/cli/tests/018.phpt 2019-12-12 21:43:36.364000000 +0100
-@@ -20,8 +20,6 @@
- --EXPECTF--
- [PHP Modules]
- %a
--pcre
--%a
- [Zend Modules]
- %aDone