]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-pear.patch
- updated to 7.4.0, partial PLD merge, release 0.1 (not tested yet)
[packages/php.git] / php-pear.patch
diff --git a/php-pear.patch b/php-pear.patch
deleted file mode 100644 (file)
index 2772cd1..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
---- php-7.3.0beta3/configure.ac~       2018-09-05 19:02:49.000000000 +0300
-+++ php-7.3.0beta3/configure.ac        2018-09-05 19:04:13.237533903 +0300
-@@ -934,11 +934,6 @@
-   with_pear=no
- fi
--# If CLI is disabled -> disable PEAR
--if test "$PHP_CLI" = "no"; then
--  with_pear=no
--fi
--
- PHP_ARG_WITH(pear, [whether to install PEAR],
- [  --with-pear=DIR         Install PEAR in DIR [PREFIX/lib/php]
-   --without-pear          Do not install PEAR], DEFAULT, yes)
-@@ -1137,19 +1137,6 @@
-   --without-pear          Do not install PEAR], DEFAULT, yes)
- if test "$PHP_PEAR" != "no"; then
--
--  dnl
--  dnl PEAR dependencies
--  dnl
--  if test "$PHP_XML" = "no"; then
--    pear_error_msg="$pear_error_msg
--                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
--  fi
--
--  if test "$pear_error_msg"; then
--    AC_MSG_ERROR([$pear_error_msg])
--  fi
--
-   install_pear="install-pear"
-   PEAR_INSTALLDIR=$PHP_PEAR
---- php-5.2.6/sapi/cli/config.m4~      2008-11-16 18:35:31.000000000 +0200
-+++ php-5.2.6/sapi/cli/config.m4       2008-11-20 19:04:12.585061299 +0200
-@@ -4,7 +4,7 @@
- PHP_ARG_ENABLE(cli,,
- [  --disable-cli           Disable building CLI version of PHP
--                          (this forces --without-pear)], yes, no)
-+                          ], yes, no)
- AC_MSG_CHECKING(for CLI build)
- if test "$PHP_CLI" != "no"; then