]> TLD Linux GIT Repositories - packages/poldek.git/blobdiff - poldek-python-fix.patch
- cleanup
[packages/poldek.git] / poldek-python-fix.patch
diff --git a/poldek-python-fix.patch b/poldek-python-fix.patch
deleted file mode 100644 (file)
index b961902..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -urNpa poldek-0.32.2.orig/python/Makefile.am poldek-0.32.2/python/Makefile.am
---- poldek-0.32.2.orig/python/Makefile.am      2016-01-30 14:05:57.000000000 +0000
-+++ poldek-0.32.2/python/Makefile.am   2017-11-08 07:55:31.168941840 +0000
-@@ -3,8 +3,8 @@ py_ver     = $(shell python -c "import s
- py_prefix  = $(shell python -c "import sys; print sys.prefix")
- py_incdir  = $(py_prefix)/include/python$(py_ver)
--EXTRA_DIST = poldekmod.i local_stdint.c pyldek.py run.sh
--CLEANFILES = wrap_* poldekmod.py local_stdint.h
-+EXTRA_DIST = poldekmod.i pyldek.py run.sh
-+CLEANFILES = wrap_* poldekmod.py
- AM_CPPFLAGS = @TRURL_INCLUDE@ @TNDB_INCLUDE@ -I$(top_srcdir) -I$(py_incdir) -I.
-@@ -21,16 +21,12 @@ AM_CFLAGS=
- CFLAGS=
- CPPFLAGS += -DSWIG -DPOCLIDEK_ITSELF 
--poldekmod.i: local_stdint.h
--
--#install-exec-hook:
--#     $(mkinstalldirs) "$(DESTDIR)$(py_sitedir)"
-+install-exec-hook:
-+      $(mkinstalldirs) "$(DESTDIR)$(py_sitedir)"
-+      $(install_sh) .libs/_poldekmod.so "$(DESTDIR)$(py_sitedir)"
- poldekmod.py: wrap_poldekmod.c
--local_stdint.h: local_stdint.c
--      $(CPP) $< > $@
--
- #wrap_poldekmod.c: poldekmod.i
- #     $(SWIG) $(SWIG_PYTHON_OPT) $(INCLUDES) -I/usr/include -o $@ $<
-diff -urNpa poldek-0.32.2.orig/python/poldekmod.i poldek-0.32.2/python/poldekmod.i
---- poldek-0.32.2.orig/python/poldekmod.i      2016-01-30 14:05:57.000000000 +0000
-+++ poldek-0.32.2/python/poldekmod.i   2017-11-08 07:55:31.169941840 +0000
-@@ -1,7 +1,6 @@
- %module poldekmod
- %{
--#include "local_stdint.h"
- #include "poldek.h"
- #include "trurl/narray.h"
- #include "trurl/nhash.h"
-@@ -33,7 +32,6 @@ static struct vf_progress vfPyProgress;
- %}
- %include exception.i
--%include "local_stdint.h"
- %include "trurl/narray.h"
- %include "capreq.h"
- %include "pkg.h"
-diff -urNpa poldek-0.32.2.orig/python/wrap_poldekmod.c poldek-0.32.2/python/wrap_poldekmod.c
---- poldek-0.32.2.orig/python/wrap_poldekmod.c 2016-07-18 18:00:08.000000000 +0000
-+++ poldek-0.32.2/python/wrap_poldekmod.c      2017-11-08 07:55:53.362940517 +0000
-@@ -3065,7 +3065,6 @@ static swig_module_info swig_module = {s
- #define SWIG_as_voidptrptr(a) ((void)SWIG_as_voidptr(*a),(void**)(a)) 
--#include "local_stdint.h"
- #include "poldek.h"
- #include "trurl/narray.h"
- #include "trurl/nhash.h"