]> TLD Linux GIT Repositories - packages/poldek.git/commitdiff
- PLD merge, adjusted for TLD, regenerated python fix patch
authorMarcin Krol <hawk@tld-linux.org>
Wed, 8 Nov 2017 12:17:39 +0000 (12:17 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 8 Nov 2017 12:17:39 +0000 (12:17 +0000)
poldek-multiproto.patch [new file with mode: 0644]
poldek-no_local_stdint.patch [deleted file]
poldek-python-fix.patch [new file with mode: 0644]
poldek.spec

diff --git a/poldek-multiproto.patch b/poldek-multiproto.patch
new file mode 100644 (file)
index 0000000..3565009
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur -x .svn -x .git -x .bzr -x CVS -ruNp poldek-0.32.2.orig/conf_sections.c poldek-0.32.2/conf_sections.c
+--- poldek-0.32.2.orig/conf_sections.c 2016-01-30 18:21:06.000000000 +0100
++++ poldek-0.32.2/conf_sections.c      2017-03-31 20:34:21.955834004 +0200
+@@ -362,7 +362,7 @@ static struct poldek_conf_tag fetcher_ta
+              0, { 0 } },
+              
+    { "proto", 
+-     CONF_TYPE_STRING | CONF_TYPE_F_REQUIRED,
++     CONF_TYPE_STRING | CONF_TYPE_F_REQUIRED | CONF_TYPE_F_LIST,
+              NULL,
+              0, { 0 } },
+              
diff --git a/poldek-no_local_stdint.patch b/poldek-no_local_stdint.patch
deleted file mode 100644 (file)
index c8955f6..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ur poldek-0.32.2.orig/python/poldekmod.i poldek-0.32.2/python/poldekmod.i
---- poldek-0.32.2.orig/python/poldekmod.i      2016-01-30 14:05:57.000000000 +0000
-+++ poldek-0.32.2/python/poldekmod.i   2017-03-31 06:38:56.158927742 +0000
-@@ -1,7 +1,6 @@
- %module poldekmod
- %{
--#include "local_stdint.h"
- #include "poldek.h"
- #include "trurl/narray.h"
- #include "trurl/nhash.h"
-@@ -33,7 +32,6 @@
- %}
- %include exception.i
--%include "local_stdint.h"
- %include "trurl/narray.h"
- %include "capreq.h"
- %include "pkg.h"
-diff -ur poldek-0.32.2.orig/python/wrap_poldekmod.c poldek-0.32.2/python/wrap_poldekmod.c
---- poldek-0.32.2.orig/python/wrap_poldekmod.c 2016-07-18 18:00:08.000000000 +0000
-+++ poldek-0.32.2/python/wrap_poldekmod.c      2017-03-31 06:39:00.925928082 +0000
-@@ -3065,7 +3065,6 @@
- #define SWIG_as_voidptrptr(a) ((void)SWIG_as_voidptr(*a),(void**)(a)) 
--#include "local_stdint.h"
- #include "poldek.h"
- #include "trurl/narray.h"
- #include "trurl/nhash.h"
diff --git a/poldek-python-fix.patch b/poldek-python-fix.patch
new file mode 100644 (file)
index 0000000..b961902
--- /dev/null
@@ -0,0 +1,64 @@
+diff -urNpa poldek-0.32.2.orig/python/Makefile.am poldek-0.32.2/python/Makefile.am
+--- poldek-0.32.2.orig/python/Makefile.am      2016-01-30 14:05:57.000000000 +0000
++++ poldek-0.32.2/python/Makefile.am   2017-11-08 07:55:31.168941840 +0000
+@@ -3,8 +3,8 @@ py_ver     = $(shell python -c "import s
+ py_prefix  = $(shell python -c "import sys; print sys.prefix")
+ py_incdir  = $(py_prefix)/include/python$(py_ver)
+-EXTRA_DIST = poldekmod.i local_stdint.c pyldek.py run.sh
+-CLEANFILES = wrap_* poldekmod.py local_stdint.h
++EXTRA_DIST = poldekmod.i pyldek.py run.sh
++CLEANFILES = wrap_* poldekmod.py
+ AM_CPPFLAGS = @TRURL_INCLUDE@ @TNDB_INCLUDE@ -I$(top_srcdir) -I$(py_incdir) -I.
+@@ -21,16 +21,12 @@ AM_CFLAGS=
+ CFLAGS=
+ CPPFLAGS += -DSWIG -DPOCLIDEK_ITSELF 
+-poldekmod.i: local_stdint.h
+-
+-#install-exec-hook:
+-#     $(mkinstalldirs) "$(DESTDIR)$(py_sitedir)"
++install-exec-hook:
++      $(mkinstalldirs) "$(DESTDIR)$(py_sitedir)"
++      $(install_sh) .libs/_poldekmod.so "$(DESTDIR)$(py_sitedir)"
+ poldekmod.py: wrap_poldekmod.c
+-local_stdint.h: local_stdint.c
+-      $(CPP) $< > $@
+-
+ #wrap_poldekmod.c: poldekmod.i
+ #     $(SWIG) $(SWIG_PYTHON_OPT) $(INCLUDES) -I/usr/include -o $@ $<
+diff -urNpa poldek-0.32.2.orig/python/poldekmod.i poldek-0.32.2/python/poldekmod.i
+--- poldek-0.32.2.orig/python/poldekmod.i      2016-01-30 14:05:57.000000000 +0000
++++ poldek-0.32.2/python/poldekmod.i   2017-11-08 07:55:31.169941840 +0000
+@@ -1,7 +1,6 @@
+ %module poldekmod
+ %{
+-#include "local_stdint.h"
+ #include "poldek.h"
+ #include "trurl/narray.h"
+ #include "trurl/nhash.h"
+@@ -33,7 +32,6 @@ static struct vf_progress vfPyProgress;
+ %}
+ %include exception.i
+-%include "local_stdint.h"
+ %include "trurl/narray.h"
+ %include "capreq.h"
+ %include "pkg.h"
+diff -urNpa poldek-0.32.2.orig/python/wrap_poldekmod.c poldek-0.32.2/python/wrap_poldekmod.c
+--- poldek-0.32.2.orig/python/wrap_poldekmod.c 2016-07-18 18:00:08.000000000 +0000
++++ poldek-0.32.2/python/wrap_poldekmod.c      2017-11-08 07:55:53.362940517 +0000
+@@ -3065,7 +3065,6 @@ static swig_module_info swig_module = {s
+ #define SWIG_as_voidptrptr(a) ((void)SWIG_as_voidptr(*a),(void**)(a)) 
+-#include "local_stdint.h"
+ #include "poldek.h"
+ #include "trurl/narray.h"
+ #include "trurl/nhash.h"
index d59f1a45f5c95166343d1823625767c08684e75d..f372e1b965f962f4bdbbf00fb2000dff80e52276 100644 (file)
@@ -14,7 +14,7 @@
 %define                ver_db_rel      1
 %define                ver_rpm         4.5-49
 
-%define                rel     4
+%define                rel     5
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -35,8 +35,9 @@ Patch0:               %{name}-size-type.patch
 Patch1:                %{name}-config.patch
 Patch2:                pm-hooks.patch
 Patch3:                WTERMSIG.patch
-Patch4:                %{name}-no_local_stdint.patch
-Patch5:                %{name}-libdb.patch
+Patch4:                %{name}-multiproto.patch
+Patch5:                %{name}-python-fix.patch
+Patch6:                %{name}-libdb.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
@@ -203,6 +204,7 @@ Moduły języka Python dla poldka.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
@@ -241,6 +243,10 @@ CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
 %{__make} -j1
 #      --enable-trace
 
+%if %{with python}
+%{__make} -C python
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/cache/%{name}
@@ -253,7 +259,7 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 %if %{with python}
 %{__make} -C python -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
-       libdir=%{py_sitedir}
+       py_sitedir=%{py_sitedir}
 %endif
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
@@ -299,7 +305,7 @@ cp -a conf configs
 
 %if %{with python}
 %py_postclean
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
 %endif