]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - per-version-dirs.patch
- reworked for versioned install to allow multiple versions on same host
[packages/postgresql.git] / per-version-dirs.patch
diff --git a/per-version-dirs.patch b/per-version-dirs.patch
new file mode 100644 (file)
index 0000000..46e8c45
--- /dev/null
@@ -0,0 +1,44 @@
+--- a/src/Makefile.global.in
++++ b/src/Makefile.global.in
+@@ -120,7 +120,7 @@ libdir := @libdir@
+ pkglibdir = $(libdir)
+ ifeq "$(findstring pgsql, $(pkglibdir))" ""
+ ifeq "$(findstring postgres, $(pkglibdir))" ""
+-override pkglibdir := $(pkglibdir)/postgresql
++override pkglibdir := $(pkglibdir)/postgresql/@PG_MAJORVERSION@/lib
+ endif
+ endif
+@@ -168,7 +168,7 @@ endif # PGXS
+ # These derived path variables aren't separately configurable.
+-includedir_server = $(pkgincludedir)/server
++includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
+ includedir_internal = $(pkgincludedir)/internal
+ pgxsdir = $(pkglibdir)/pgxs
+--- a/src/bin/pg_config/pg_config.c
++++ b/src/bin/pg_config/pg_config.c
+@@ -27,6 +27,8 @@
+ #include "port.h"
+ #include "common/config_info.h"
++#include "../port/pg_config_paths.h"
++
+ static const char *progname;
+ /*
+@@ -148,11 +150,7 @@ main(int argc, char **argv)
+               }
+       }
+-      if (find_my_exec(argv[0], my_exec_path) < 0)
+-      {
+-              fprintf(stderr, _("%s: could not find own program executable\n"), progname);
+-              exit(1);
+-      }
++      snprintf(my_exec_path, sizeof(my_exec_path), "%s/%s", PGBINDIR, progname);
+       configdata = get_configdata(my_exec_path, &configdata_len);
+       /* no arguments -> print everything */