]> TLD Linux GIT Repositories - packages/proftpd.git/blobdiff - proftpd.spec
- drop one more old configuration migration trigger
[packages/proftpd.git] / proftpd.spec
index db0c38efae845e6e18486ab8fc05e18a0d9a4385..60301d59c2da360e47644b96f3ad100f02bc6bb4 100644 (file)
@@ -95,34 +95,13 @@ if [ "$1" = "0" ]; then \
        fi \
 fi
 
-%define module_triggerun \
-if [ $1 -le 1 ]; then \
-        exit 0 \
-fi \
-[ -d /etc/proftpd/conf.d ] || mkdir -p /etc/proftpd 2>/dev/null || : \
-%if "%1" == "mod_tls" \
-for f in /etc/ftpd/{conf.d/mod_tls.conf,server.crt,server.key}; do \
-       f=${f##*/} \
-       [ -f "/etc/ftpd/$f" ] && mv "/etc/ftpd/$f" /etc/proftpd 2>/dev/null || : \
-       [ -f "/etc/ftpd/conf.d/$f" ] && mv "/etc/ftpd/conf.d/$f" /etc/proftpd/conf.d 2>/dev/null || : \
-done \
-%else \
-[ -f /etc/ftpd/conf.d/%1.conf ] && mv /etc/ftpd/conf.d/%1.conf /etc/proftpd/conf.d 2>/dev/null || : \
-%endif \
-sed -i -e 's|/etc/ftpd|/etc/proftpd|g' /etc/ftpd/conf.d/%1.conf 2>/dev/null \
-[ -n "$(find /etc/ftpd/conf.d -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd/conf.d 2>/dev/null || : \
-[ -n "$(find /etc/ftpd -type d -empty 2>/dev/null)" ] && rmdir /etc/ftpd 2>/dev/null || :
-
 # it's sooo annoying to write them
 %define        module_scripts() \
 %post %1 \
 %module_post \
 \
 %postun %1 \
-%module_postun \
-\
-%triggerun %1 -- proftpd-%1 \
-%module_triggerun
+%module_postun
 
 %description
 ProFTPD is a highly configurable FTP daemon for Unix and Unix-like