]> TLD Linux GIT Repositories - packages/filesystem.git/blobdiff - filesystem.spec
- drop x32 and other archs not supported by TLD
[packages/filesystem.git] / filesystem.spec
index 3f4ed4038d1bd0ea85f90551b2bf30f2fb84a656..ef649ed6ab38c5d1106b2a8e4a22026f6f46edb8 100644 (file)
@@ -11,7 +11,7 @@ Summary:      Common directories
 Summary(pl.UTF-8):     Wspólne katalogi
 Name:          filesystem
 Version:       4.0
-Release:       34
+Release:       35
 License:       GPL
 Group:         Base
 BuildRequires: automake
@@ -22,15 +22,6 @@ Provides:    browser-plugins(%{_target_base_arch})
 %ifarch %{x8664}
 Provides:      browser-plugins(i386)
 %endif
-%ifarch ppc64
-Provides:      browser-plugins(ppc)
-%endif
-%ifarch s390x
-Provides:      browser-plugins(s390)
-%endif
-%ifarch sparc64
-Provides:      browser-plugins(sparc)
-%endif
 Provides:      filesystem-debuginfo = %{version}-%{release}
 Obsoletes:     filesystem-debuginfo < 3.0-36
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -42,14 +33,6 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %else
 %define                with_lib64      0
 %endif
-%if "%{_lib}" == "libx32"
-%define                with_libx32     1
-%else
-%ifarch %{x8664}
-# x32 as additional ABI
-%define                with_libx32     1
-%endif
-%endif
 
 # directory for "privilege separation" chroot
 %define                _privsepdir     /usr/share/empty
@@ -106,25 +89,6 @@ install -d \
        $RPM_BUILD_ROOT/usr/lib64/{browser-plugins,cmake,initrd,mozilla/extensions,pkcs11,pkgconfig} \
        $RPM_BUILD_ROOT/usr/lib/debug/lib64/security
 %endif
-%if %{with libx32}
-install -d \
-       $RPM_BUILD_ROOT/libx32/security \
-       $RPM_BUILD_ROOT/usr/libx32/{browser-plugins,cmake,initrd,mozilla/extensions,pkcs11,pkgconfig} \
-       $RPM_BUILD_ROOT/usr/lib/debug/libx32/security
-%endif
-
-%if "%{pld_release}" == "ac"
-rmdir $RPM_BUILD_ROOT/usr/include/X11
-# X11
-install -d $RPM_BUILD_ROOT/usr/X11R6/share
-for manp in man{1,2,3,4,5,6,7,8} ; do
-       install -d $RPM_BUILD_ROOT/usr/X11R6/man/$manp
-       for mloc in it ko pl; do
-               install -d $RPM_BUILD_ROOT/usr/X11R6/man/$mloc/$manp
-       done
-done
-install -d $RPM_BUILD_ROOT/usr/share/wm-properties
-%endif
 
 install -d \
        $RPM_BUILD_ROOT/usr/lib/debug/%{_lib} \
@@ -158,7 +122,6 @@ check_filesystem_dirs() {
 
 check_filesystem_dirs
 
-%if "%{pld_release}" != "ac"
 %pretrans -p <lua>
 -- this needs to be a dir
 if posix.stat("/usr/include/X11", "type") == "link" then
@@ -174,7 +137,6 @@ if posix.stat("/usr/include/X11", "type") == "link" then
        end
        posix.chdir(oldpwd)
 end
-%endif
 
 %post -p <lua>
 posix.chown("/var/log/archive", 0, %{gid_logs})
@@ -217,9 +179,7 @@ posix.chown("/etc/cron.d", 0, %{gid_crontab})
 %dir /run
 %dir /selinux
 %dir /sys
-%if "%{pld_release}" != "ac"
 %dir /usr/include/X11
-%endif
 %dir /usr/include/security
 %dir /usr/lib/ConsoleKit
 %dir /usr/lib/ConsoleKit/run-session.d
@@ -296,18 +256,6 @@ posix.chown("/etc/cron.d", 0, %{gid_crontab})
 %dir /usr/libx32/pkgconfig
 %endif
 
-%if "%{pld_release}" == "ac"
-%dir /usr/X11R6
-%dir /usr/X11R6/man
-/usr/X11R6/man/man*
-%lang(it) /usr/X11R6/man/it
-%lang(ko) /usr/X11R6/man/ko
-%lang(pl) /usr/X11R6/man/pl
-%dir /usr/X11R6/share
-
-%dir /usr/share/wm-properties
-%endif
-
 # debuginfo
 %dir /usr/lib/debug
 /usr/lib/debug/*