]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin-Makefile.patch
- updated to 2.0.25
[packages/munin.git] / munin-Makefile.patch
index e808657cd6b8bae5642f20d54f223a1dfea21d7a..5fd99671429723e1a7a49b5df3d9fa52ad2a50d9 100644 (file)
@@ -1,6 +1,7 @@
---- munin-1.4.0/Makefile~      2009-11-27 12:17:18.000000000 +0100
-+++ munin-1.4.0/Makefile       2009-11-30 14:33:15.977700738 +0100
-@@ -77,6 +77,7 @@
+diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
+--- munin-2.0.25.orig/Makefile 2014-11-24 21:46:24.000000000 +0000
++++ munin-2.0.25/Makefile      2015-09-08 10:02:24.392593251 +0000
+@@ -81,6 +81,7 @@ install-master-prime: $(INFILES_MASTER)
        mkdir -p $(CONFDIR)/munin-conf.d
        mkdir -p $(LIBDIR)
        mkdir -p $(BINDIR)
@@ -8,7 +9,7 @@
        mkdir -p $(PERLLIB)
        mkdir -p $(PERLLIB)/Munin/Master
        mkdir -p $(HTMLDIR)
-@@ -99,8 +100,8 @@
+@@ -112,8 +113,8 @@ install-master-prime: $(INFILES_MASTER)
        test -f $(HTMLDIR)/.htaccess || $(INSTALL) -m 0644 build/master/www/munin-htaccess $(HTMLDIR)/.htaccess
        test -f "$(CONFDIR)/munin.conf"  || $(INSTALL) -m 0644 build/master/munin.conf $(CONFDIR)/
  
 +      $(INSTALL) -m 0755 build/master/_bin/munin-cron $(SBINDIR)/
 +      $(INSTALL) -m 0755 build/master/_bin/munin-check $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-update $(LIBDIR)/
-       $(INSTALL) -m 0755 build/master/_bin/munin-graph $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-html $(LIBDIR)/
---- munin-1.4.0/Makefile.config~       2009-11-27 12:17:18.000000000 +0100
-+++ munin-1.4.0/Makefile.config        2009-11-30 14:32:28.827763277 +0100
+       $(INSTALL) -m 0755 build/master/_bin/munin-graph $(LIBDIR)/
+diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
+--- munin-2.0.25.orig/Makefile.config  2014-11-24 21:46:24.000000000 +0000
++++ munin-2.0.25/Makefile.config       2015-09-08 10:02:24.393593251 +0000
 @@ -17,10 +17,10 @@
  #
  # the base of the Munin installation.
@@ -34,7 +36,7 @@
  
  # Server only - where to put munin-cron
  BINDIR     = $(PREFIX)/bin
-@@ -32,31 +32,31 @@
+@@ -32,31 +32,31 @@ SBINDIR    = $(PREFIX)/sbin
  DOCDIR     = $(PREFIX)/doc
  
  # Where to put man pages
@@ -75,7 +77,7 @@
  
  # Location of PID files and other statefiles. On the server, must be
  # writable by the user "munin".
-@@ -98,7 +98,7 @@
+@@ -95,7 +95,7 @@ GOODSH     := $(shell PATH=`getconf PATH
  BASH       := /bin/bash
  
  # Server only - Where to install the perl libraries
@@ -84,7 +86,7 @@
  PERLLIB    = $(DESTDIR)$(PERLSITELIB)
  
  # Client only - Install plugins for this architecture
-@@ -106,7 +106,7 @@
+@@ -106,7 +106,7 @@ OSTYPE     := $(shell uname | LANG=C tr
  
  # How to figure out the hostname. (Only used in default configuration
  # files)
@@ -93,7 +95,7 @@
  
  # What is the safest way to create a tempfile.
  # Default is to figure it out by testing various methods.
-@@ -126,9 +126,9 @@
+@@ -129,9 +129,9 @@ CGIUSER := nobody
  # Which command to use to check if the USER and GROUP to run Munin as, exists.
  # These will work on most modern OSes:
  #
  
  # For OSX, comment out the previous two lines and comment in these
  #
-@@ -146,9 +146,9 @@
- #CHECKUSER  := $(shell pwget -n $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
- #CHECKGROUP := $(shell grget -n $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
+@@ -153,9 +153,9 @@ CHECKGROUP := $(shell $(GETENT) group $(
+ #CHECKUSER  := $(shell id $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
+ #CHECKGROUP := $(shell grep ^$(GROUP): /etc/group >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
  
 -CHOWN      := chown
 -CHMOD      := chmod